Not logged in. · Lost password · Register
Forum: General Help and Support Installation and Configuration RSS
Problem with Release 2011-11-10 "Angua RC1" "The mediaolddir ('media_attic') does not exist.."
Avatar
clauswobbe #1
Member since Sep 2010 · 4 posts
Group memberships: Members
Show profile · Link to this post
Subject: Problem with Release 2011-11-10 "Angua RC1" "The mediaolddir ('media_attic') does not exist.."
Hi guys
I've updated using the automatic plugin, but when I try to access my web site, I get the following error: "DokuWiki Setup Error
The mediaolddir ('media_attic') does not exist, isn't accessible or writable. You should check your config and permission settings. Or maybe you want to run the installer?"

I've googled a bit and understand this has probably something to do with new directories being needed, however, I can't seem to find any description of which directories this would be?! I've manually created media_attic and media_meta under data/media and given these two directories full permissions (777), but this still doesn't seem to solve my problem.

Any ideas?
Avatar
lupo49 (Moderator) #2
Member since Jul 2009 · 1399 posts · Location: Warstein, Germany
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
The directories have to be placed inside /data/ -> /data/media_attic/ and /data/media_meta/
Avatar
iandavo #3
Member since Dec 2011 · 1 post
Group memberships: Members
Show profile · Link to this post
I'm having the exact same problem. The directories are under /data, and both have 777 permissions. Any help would be appreciated!
Avatar
ironcloudz #4
Member since Dec 2011 · 1 post
Group memberships: Members
Show profile · Link to this post
I am having the same error and tried the sames "fixes" which did not...

HELP!
Avatar
lupo49 (Moderator) #5
Member since Jul 2009 · 1399 posts · Location: Warstein, Germany
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
How does your directory layout looks currently like?
Avatar
waldauf #6
Member since Dec 2011 · 3 posts
Group memberships: Members
Show profile · Link to this post
I had the same problem and I solved it by creating new directories (how was written before my post):
/data/media_attic
/data/media_meta

Now is wiki running.
Avatar
cycyx #7
Member since Feb 2012 · 1 post
Group memberships: Members
Show profile · Link to this post
Ok, so, I've finally updated my year old installation, and I'm running into this error.

ls -l
total 60
drwxrwxr-x 2 webadmin www-data  4096 2012-01-25 20:27 attic
drwxrwxr-x 2 webadmin www-data  4096 2012-01-25 20:27 cache
drwxrwxr-x 2 webadmin www-data  4096 2012-02-03 19:09 index
drwxrwxr-x 2 webadmin www-data  4096 2012-01-25 20:27 locks
drwxrwsr-x 3 webadmin www-data  4096 2012-01-25 20:27 media
drwxrwsr-x 2 webadmin www-data  4096 2012-01-25 20:27 media_attic
drwxrwsr-x 2 webadmin www-data  4096 2012-01-25 20:27 media_meta
drwxrwxr-x 2 webadmin www-data  4096 2012-01-25 20:27 meta
drwxrwxr-x 4 webadmin www-data  4096 2012-01-25 20:27 pages
-rw-rw-r-- 1 webadmin www-data  7917 2012-01-25 20:27 security.png
-rw-rw-r-- 1 webadmin www-data 12093 2012-01-25 20:27 security.xcf
drwxrwxr-x 2 webadmin www-data  4096 2012-01-25 20:27 tmp

The directories exist and are writable by the web server.

If I comment out the init_paths function call, the next error is "/page.idx is not writable". But it should be.

So basically, how can I update my installationto the last dokuwiki version?

Thank you for your replies.
Avatar
clauswobbe #8
Member since Sep 2010 · 4 posts
Group memberships: Members
Show profile · Link to this post
In reply to post #2
Subject: It worked! :-)
Wow - been away for a while. Now it works - I simply had to place the dirs in the right place. Quite embarassing :-)
Avatar
Guillermo #9
Member since Feb 2010 · 13 posts
Group memberships: Members
Show profile · Link to this post
In reply to post #6
Thanks very much.
Same problem here, this was resolved simply creating the two folders, as you state.
/data/media_attic
/data/media_meta

This was made in an little docuwiki, but I'm frightened with my production wiki where I've installed several plugins as
- indexmenu plugin
- fontcolor
- Pagemove
- of course Wiki Upgrade
- spanish language

I will fear for anything? (currently running Release 2011-05-25a "Rincewind")
Avatar
lupo49 (Moderator) #10
Member since Jul 2009 · 1399 posts · Location: Warstein, Germany
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
That's unrelated to an upgrade, but the pagemove plugin is broken since several months: https://www.dokuwiki.org/plugin:pagemove#warning_in_the_fo…
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2018-11-16, 21:51:09 (UTC +01:00)