Not logged in. · Lost password · Register
Forum: General Help and Support Installation and Configuration RSS
Cannot complete installation: php-cgi.exe - The FastCGI process exited unexpectedly
Avatar
dmayi #1
Member since Jun 2014 · 1 post
Group memberships: Members
Show profile · Link to this post
Subject: Cannot complete installation: php-cgi.exe - The FastCGI process exited unexpectedly
Help please... I am stuck. I keep getting this exception . I can load a other php pages with no problem, except the installer

I tried everything I could, stuck and almost about to give up

Question: the doc is a little obscure on the installation truly.
What should I launch index.php or what?

Thanks for your help


Issue: 

HTTP Error 500.0 - Internal Server Error
C:\php-5.5.13\php-cgi.exe - The FastCGI process exited unexpectedly

http://localhost/docman/index.php


Most likely causes:•IIS received the request; however, an internal error occurred during the processing of the request. The root cause of this error depends on which module handles the request and what was happening in the worker process when this error occurred.
•IIS was not able to access the web.config file for the Web site or application. This can occur if the NTFS permissions are set incorrectly.
•IIS was not able to process configuration for the Web site or application.
•The authenticated user does not have permission to use this DLL.
•The request is mapped to a managed handler but the .NET Extensibility Feature is not installed.

Things you can try:•Ensure that the NTFS permissions for the web.config file are correct and allow access to the Web server's machine account.
•Check the event logs to see if any additional information was logged.
•Verify the permissions for the DLL.
•Install the .NET Extensibility feature if the request is mapped to a managed handler.
•Create a tracing rule to track failed requests for this HTTP status code. For more information about creating a tracing rule for failed requests, click here.



Detailed Error Information:


Module
   FastCgiModule

Notification
   ExecuteRequestHandler

Handler
   PHP_via_FastCGI

Error Code
   0x000000ff



Requested URL
   http://localhost:80/docman/index.php

Physical Path
   C:\inetpub\wwwroot\docman\index.php

Logon Method
   Anonymous

Logon User
   Anonymous
Avatar
blake #2
Member since Dec 2014 · 1 post
Group memberships: Members
Show profile · Link to this post
I have this same error message on Windows Server 2012r2 with IIS 8.5 and PHP v5.6 (installed with the Microsft Web Platform Installer).
I also confirmed I have CGI installed in the Server Manager. http://www.iis.net/configreference/system.webserver/fastcg…

Suggestions anyone?
This post was edited 2 times, last on 2014-12-03, 23:32 by blake.
Avatar
hive #3
Member since Jan 2015 · 2 posts
Group memberships: Members
Show profile · Link to this post
I ran into the same thing. Was able to find that it is trying to load a DLL from Visual C++ 2012 Redistributable (x86). After you install that, it should run fine.
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2019-02-19, 21:06:29 (UTC +01:00)