Not logged in. · Lost password · Register
Forum: General Help and Support Installation and Configuration RSS
after migrating from php 5.6 to 7.2 images don't show anymore
Avatar
BuzzD #1
Member for 2 weeks · 3 posts
Group memberships: Members
Show profile · Link to this post
Subject: after migrating from php 5.6 to 7.2 images don't show anymore
Hello,
this is my first post here so Hello everybody :-)

I'm running dokuwiki Greebo on a hosted webspace with "1und1".

I used to run on php 5.6 but recently switched to 7.2. Since that, images are not shown anymore. When I switch back to 5.6 it works again. has anybody had this issue as well and can help? Or do you need more info on my setup?

TIA,
Sebastian
Avatar
Michaelsy #2
Member since Jun 2015 · 712 posts · Location: Düsseldorf, Germany
Group memberships: Members
Show profile · Link to this post
Try to switch to PHP 7.1

Or apply this patch: https://github.com/splitbrain/dokuwiki/pull/2420/files
(Be aware this method is not update-safe.)

Maybe you have to purge the DokuWiki cache by deleting the entire contents of the dir /data/cache

Feedback welcome - Michael Sy.
By Patreon.com a few eurons can be fed into the code phasers of
the DokuWiki engine. Besides, Andi's posts are worth reading.
Avatar
BuzzD #3
Member for 2 weeks · 3 posts
Group memberships: Members
Show profile · Link to this post
Thanks for your quick reply!

reverting to 7.1 didn't solve the issue but replacing the common.php did!

THX!
Avatar
gigibagigi #4
Member for a week · 2 posts
Group memberships: Members
Show profile · Link to this post
Hi,
I have the same problem, with PHP 7.1/7.2 and 1and1 hosting.

Could you explain how do you solve de issue?

Thanks

Riccardo
Avatar
BuzzD #5
Member for 2 weeks · 3 posts
Group memberships: Members
Show profile · Link to this post
Hi,
I replaced the entire code in the "common.php"
with this: https://github.com/sijongyeoil/dokuwiki/blob/985d6187472ee…

(just copy and paste it and don't forget to make a backup beofre doing so).
Avatar
Michaelsy #6
Member since Jun 2015 · 712 posts · Location: Düsseldorf, Germany
Group memberships: Members
Show profile · Link to this post
Quote by BuzzD:
I replaced the entire code in the "common.php"
with this: https://github.com/sijongyeoil/dokuwiki/blob/985d6187472ee…

That's a bit dangerous method and could be unwanted side effects. Cause we don't know which additional changes are in this version. Only applying the patch is a better idea.
By Patreon.com a few eurons can be fed into the code phasers of
the DokuWiki engine. Besides, Andi's posts are worth reading.
Avatar
gigibagigi #7
Member for a week · 2 posts
Group memberships: Members
Show profile · Link to this post
I have compared the patch
 https://github.com/splitbrain/dokuwiki/pull/2420/files
and
 https://github.com/sijongyeoil/dokuwiki/blob/985d6187472ee…

They are the same.

Now the wiki works perfectly.

Thanks at all
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2019-02-19, 20:45:22 (UTC +01:00)