Not logged in. · Lost password · Register
Page:  1  2  3 ... 11  12  13  next 

All posts by cziehr (192)

topic: PDF-Export Performance / Abbruch (dw2pdf, include-Plugin Problemchen)  in the forum: Non-English Discussion German discussion
Avatar
cziehr #1
Member since Jan 2011 · 192 posts · Location: 13189 Berlin
Group memberships: Members
Show profile · Link to this post
Da kann ich dir leider nichts zu sagen, ich benutze nur den Apache unter Ubuntu Linux und kenne mich mit dem IIS nicht aus. Google sagt z.B.: https://technet.microsoft.com/de-de/library/cc772095%28v=w…

Dementsprechend musst du auch mal googeln wo deine Server-Logs liegen.
topic: PDF-Export Performance / Abbruch (dw2pdf, include-Plugin Problemchen)  in the forum: Non-English Discussion German discussion
Avatar
cziehr #2
Member since Jan 2011 · 192 posts · Location: 13189 Berlin
Group memberships: Members
Show profile · Link to this post
In reply to post ID 47997
Ich vermute mal, dass das Problem der verfügbare Arbeitsspeicher ist.

Wie sind denn deine Server-Einstellungen? Nur weil du 2 GB Ram hast heißt das ja nicht dass der Webserver die komplett verwenden darf, das kommt drauf an wie viel du in der Konfiguration eingestellt hast.

Wo du die Logs findest hängt davon ab welches Betriebssystem und welche Server-Software du verwendest.
topic: PDF-Export Performance / Abbruch (dw2pdf, include-Plugin Problemchen)  in the forum: Non-English Discussion German discussion
Avatar
cziehr #3
Member since Jan 2011 · 192 posts · Location: 13189 Berlin
Group memberships: Members
Show profile · Link to this post
In reply to post ID 47989
Hallo Steve,

Die Belastung hängt natürlich davon ab welche Inhalte deine Seiten haben.

Gibt es denn außer der Belastung "wirkliche" Probleme?
Hast du dir mal die Server-Logs zu einem deiner Aufrufe angesehen?


Viele Grüße,
Christoph
topic: [gelöst} Beim Bearbeiten von Seiten plötzlich weiße Seite  in the forum: Non-English Discussion German discussion
Avatar
cziehr #4
Member since Jan 2011 · 192 posts · Location: 13189 Berlin
Group memberships: Members
Show profile · Link to this post
In reply to post ID 47919
Hi Mike,

es kann sein dass vom Betreiber nicht erlaubt wird diese Fehlermeldungen anzuzeigen (entsprechend der PHP-Einstellungen). Wenn das so ist hast du wohl erstmal schlechte Karten, zumindest hätte ich jetzt keinen weiteren Ansatzpunkt. Die Gründe für eine "blank page" können sehr vielfältig sein, und ohne Fehlermeldung wirst du da bei der Fehlerbehebung nicht weit kommen.

Hast du mal bei deinem Anbieter nachgeschaut ob es da FAQs o.ä. gibt in denen vielleicht drin steht wie man an die Fehlermeldungen kommt?


Viele Grüße,

Christoph
topic: [gelöst} Beim Bearbeiten von Seiten plötzlich weiße Seite  in the forum: Non-English Discussion German discussion
Avatar
cziehr #5
Member since Jan 2011 · 192 posts · Location: 13189 Berlin
Group memberships: Members
Show profile · Link to this post
In reply to post ID 47902
Hallo Mike,

öffne in deinem Wiki-Hauptverzeichnis die Datei doku.php

Füge dort direkt in die 2. Zeile nach dem <?php ein:

error_reporting(E_ALL);
ini_set("display_errors", 1);

Nun solltest du auch alle Fehler direkt auf der Seite angezeigt bekommen die normalerweise nur in die Log-Datei geschrieben werden.

Nachdem du den Fehler gefunden und beseitigt hast entferne die beiden Zeilen wieder oder kommentiere sie aus.


Viele Grüße,

Christoph
topic: [gelöst} Beim Bearbeiten von Seiten plötzlich weiße Seite  in the forum: Non-English Discussion German discussion
Avatar
cziehr #6
Member since Jan 2011 · 192 posts · Location: 13189 Berlin
Group memberships: Members
Show profile · Link to this post
In reply to post ID 47900
Hallo Mike,


mögliche Ursachen für die Behebung von weißen Seiten ("blank pages") findest du unter https://www.dokuwiki.org/faq:blankpage

Falls es sich um eine sehr große Seite handelt kommt evtl. auch https://www.dokuwiki.org/faq:largepage in Frage.


Viele Grüße,
Christoph
topic: Mein Wiki bleibt leer  in the forum: Non-English Discussion German discussion
Avatar
cziehr #7
Member since Jan 2011 · 192 posts · Location: 13189 Berlin
Group memberships: Members
Show profile · Link to this post
In reply to post ID 47582
Achso... du hast das Wiki wahrscheinlich über die Paketverwaltung installiert und nicht "von Hand". Da müsste ich erst nochmal nachschauen, bin aber gerade unterwegs. Gebe dir später oder morgen nochmal Bescheid was du machen musst.

Viele Grüße,
Christoph
topic: Mein Wiki bleibt leer  in the forum: Non-English Discussion German discussion
Avatar
cziehr #8
Member since Jan 2011 · 192 posts · Location: 13189 Berlin
Group memberships: Members
Show profile · Link to this post
In reply to post ID 47573
Hallo Michael,

offensichtlich gibt es ein Problem mit dem neuen Template, deine Beschreibung deutet auf einen PHP-Fehler hin. Was genau lässt sich so direkt jetzt nicht herausfinden, dafür solltest du einmal die Log-Dateien deines Servers auf Fehlermeldungen untersuchen.

Was du tun kannst um dein Wiki erstmal wieder zum Laufen zu bringen:

Öffne in Ubuntu die Datei /var/www/html/dokuwiki/conf/local.php (ggf. lautet der Pfad /var/www/dokuwiki/conf/local.php wenn dein Ubuntu noch die alte Dateistruktur verwendet).

Lösche die Zeile die mit

$conf['template']

beginnt. Nun kannst du wieder auf dein Wiki zugreifen und das Standard-Template "dokuwiki" wird dafür verwendet.

Wenn du dennoch das neue, nicht funktionierende Template verwenden möchtest musst du halt mal noch etwas Arbeit investieren um herauszufinden wo der Fehler liegt und wie du ihn behebst. Aber zumindest läuft dein Wiki (mit dem alten Template) dann wieder.


Viele Grüße,

Christoph
topic: Header nicht anzeigen (hiddenheader Plugin)  in the forum: Non-English Discussion German discussion
Avatar
cziehr #9
Member since Jan 2011 · 192 posts · Location: 13189 Berlin
Group memberships: Members
Show profile · Link to this post
In reply to post ID 47555
Das wrap-Plugin kann auch Text verstecken. Hast du es schonmal damit probiert?


Viele Grüße,

Christoph
topic: Template Green Steel, Inhaltsverzeichnis unerwünscht, wie deaktivieren?  in the forum: Non-English Discussion German discussion
Avatar
cziehr #10
Member since Jan 2011 · 192 posts · Location: 13189 Berlin
Group memberships: Members
Show profile · Link to this post
In reply to post ID 47497
Hallo Dieter,

lege im CSS-Ordner in dem auch die anderen CSS-Dateien liegen eine eigene CSS-Datei an. Das ist einfach eine Textdatei mit der Dateiendung CSS. Oder öffne eine der bestehenden Dateien, lösche den ganzen Inhalt raus und speichere sie unter einem eigenen Dateinamen. Oft wird dafür custom.css verwendet, aber du bist in der Wahl deines Dateinamens da völlig frei.

Bitte zum Bearbeiten nicht Word verwenden, denn das zerschießt dir wahrscheinlich die Datei. Nimm für Wordpad, oder falls du öfters Änderungen vornimmst, dann installiere dir die Open-Source-Software Notepad++: https://de.wikipedia.org/wiki/Notepad%2B%2B bzw. http://notepad-plus-plus.org/

In die Datei schreibst du dann folgenden Inhalt:

#dw__toc {
    visibility: hidden;
    margin: 0;
    width: 0px;
    height: 0px;
}

Nun musst du noch die Datei lib/tpl/greensteel/style.ini öffnen. Darin befinden sich im Block [stylesheets] viele Einträge mit den CSS-Dateien. Ganz am Ende diesen Blocks (nicht am Anfang, sonst werden die Standardwerte nicht überschrieben) fügst du dann die Zeile ein:

css/custom.css            = screen

(Bzw. musst du den Dateinamen halt anpassen wenn du nicht custom.css verwendest.)

Dann sollte es eigentlich funktionieren.


Noch ein Hinweis: Solltest du das Template mal aktualisieren wird dein Wert in der Ini-Datei wahrscheinlich überschreiben. Diese einzelne Zeile musst du dann wieder neu einfügen, das solltest du dir also irgendwo dokumentieren.


Viele Grüße,

Christoph
topic: Fehler in statdisplay  in the forum: Non-English Discussion German discussion
Avatar
cziehr #11
Member since Jan 2011 · 192 posts · Location: 13189 Berlin
Group memberships: Members
Show profile · Link to this post
In reply to post ID 47530
Achso, ich war wegen dem Fettgedrucktem so auf den Zeilenanfang fixiert dass ich mir die schließenden Tags gar nicht angeschaut habe. Die Zeilen untendrunter habe ich zwar auch gesehen, aber auch nur den Zeilenanfang. Da habt ihr natürlich vollkommen recht.

Viele Grüße,
Christoph
topic: Fehler in statdisplay  in the forum: Non-English Discussion German discussion
Avatar
cziehr #12
Member since Jan 2011 · 192 posts · Location: 13189 Berlin
Group memberships: Members
Show profile · Link to this post
In reply to post ID 47523
Wieso soll th da falsch sein?

http://wiki.selfhtml.org/wiki/Referenz:HTML/th


Viele Grüße,
Christoph
topic: Template Green Steel, Inhaltsverzeichnis unerwünscht, wie deaktivieren?  in the forum: Non-English Discussion German discussion
Avatar
cziehr #13
Member since Jan 2011 · 192 posts · Location: 13189 Berlin
Group memberships: Members
Show profile · Link to this post
In reply to post ID 47491
Hallo Dieter,

falls es in der Konfiguration keine Möglichkeit gibt das Inhaltsverzeichnis abzuschalten, dann kannst du das Inhaltsverzeichnis auch per CSS ausblenden indem du es mit der Größe 0 Pixel unsichtbar machst. Dafür müsstest du mal einen Link zu deinem Wiki hier reinstellen, ich verwende das Template nicht.

Viele Grüße,
Christoph
topic: Das Dokuwiki auf ein IOS Tablet installieren  in the forum: Non-English Discussion German discussion
Avatar
cziehr #14
Member since Jan 2011 · 192 posts · Location: 13189 Berlin
Group memberships: Members
Show profile · Link to this post
In reply to post ID 47433
Am Ende steht von was von iOS, da hast du recht. Allerdings greift er mit seinem iOS-Gerät über WLAN auf die Installation zu die auf seinem Mac läuft. Also auch kein richtiger Offline-Betrieb.

Da lobe ich mir doch Android, da gibts mehrere Apps die einen Webserver bereitstellen und das zeitaufwändigste an der Einrichtung ist das Kopieren des Wikis auf die SD-Karte...


Viele Grüße,

Christoph


EDIT: Das mit dem Dropbox-Zugriff auf die Rohdaten hab ich beim ersten Mal glatt überlesen. Aber das kann man ja wohl niemandem zumuten wenn man das Wiki einem größeren Personenkreis als dem Admin selbst zugänglich machen will...
topic: Einzug von Listenelementen verändern  in the forum: Non-English Discussion German discussion
Avatar
cziehr #15
Member since Jan 2011 · 192 posts · Location: 13189 Berlin
Group memberships: Members
Show profile · Link to this post
In reply to post ID 47426
Hi Alex,

hast du mal probiert mit negativen Zahlen weiterzumachen wenn dir 0 noch zu weit auseinander ist?


Grüße,

Christoph
Close Smaller – Larger + Reply to this post:
Special characters:
Page:  1  2  3 ... 11  12  13  next 
Special queries
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20120620-dev, © 2003-2011 by Yves Goergen
Current time: 2015-04-27, 00:29:05 (UTC +02:00)