Not logged in. · Lost password · Register

All posts by bb88 (15)

topic: Die Datei "xxx" wurde nicht gelöscht - sie wird noch verwendet (Media-Manager)  in the forum: Non-English Discussion German discussion
Avatar
bb88 #1
Member since May 2013 · 15 posts
Group memberships: Members
Show profile · Link to this post
Ah, ok, also es wird geprüft, ob die Datei irgendwo _eingebunden_ ist.
Das ist etwas anderes, dann habe ich die Meldung falsch verstanden.

Und dass man das abschalten kann - fein.
topic: Die Datei "xxx" wurde nicht gelöscht - sie wird noch verwendet (Media-Manager)  in the forum: Non-English Discussion German discussion
Avatar
bb88 #2
Member since May 2013 · 15 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 35872
Ich mache den alten Thread mal wieder auf, da ich gerade mit Release 2018-04-22b "Greebo" auf die gleiche Meldung stieß.

Grundfrage: Warum möchte Dokuwiki überhaupt verfolgen, welche Dateien "verwendet" werden?
Wir haben hier HTTP als Grundlage, und das ist bekanntlich stateless.
Wenn zwei Leute einmal gleichzeitig eine Datei bearbeiten - dann müssen die sich eben absprechen.
Der häufigere Fall dürfte aber sein, dass der Lock (oder was?) irgendwie stehengeblieben ist, wie auch beim Threadstarter offenbar.
> Der Check sollte besser einfach aus dem Code herausgenommen werden.
topic: User ohne Email  in the forum: Non-English Discussion German discussion
Avatar
bb88 #3
Member since May 2013 · 15 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 66627
Danke für den Hinweis.
Aber "Successfully imported users will receive the usual notification with their username and password"
Und diese Nachricht wird dann an die Email gehen - die ja hier nicht benutzt werden soll.
Von daher scheint mir das Editieren der users...php als goldrichtig, für meine Anwendung (die vll nicht alltäglich ist).

@Michaelsy, wer dann auf Deuwel-komm-raus doch seine Email da einträgt .. bitte.

Nachtrag: Das klappt, also den String im Libreoffice-Calc mit o.g. Extension erzeugen und per copy-paste in die users.auth.php einsetzen. Man muss nur den Login-name in lowercase wandeln.
Die Usernamen erzeuge ich aus einer Liste verbreiteter Vornamen mit einem kurzen Hash hintendran, die Passwörter per rand() - die dann den Usern mitgeteilt werden. Die können dann, bei Bedarf, den 'Full Name' und die Email im Profil nachtragen, oder auch das PW ändern.
This post was edited 2 times, last on 2019-06-30, 23:42 by bb88.
topic: User ohne Email  in the forum: Non-English Discussion German discussion
Avatar
bb88 #4
Member since May 2013 · 15 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 66623
Das hatte ich auch schon mal gelesen und wollte diesen Weg - 200 Emails auszuwerten, um die Passwörter darin wieder in die Liste zu schleusen - vermeiden.

Da ist der Weg über das Editieren der users.auth.php doch sehr viel eleganter.
Man generiert User-ID (Random+Hash), Passwort (dito) und Password-Hash in Calc, setzt dort auch den String für die users.auth.php zusammen, und kann die dann per copy-paste oder export direkt aktivieren .. stell ich mir so vor.

Nur Password-Ändern durch die User geht dann mangels eigener Email nicht; hier akzeptabel.
This post was edited on 2019-06-25, 13:58 by bb88.
topic: User ohne Email  in the forum: Non-English Discussion German discussion
Avatar
bb88 #5
Member since May 2013 · 15 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 66616
Danke für die Hinweise!
@pop, dass man die Email nicht funktional braucht, löst ja schon meine erste Frage.
Mit den Passwörtern hast du recht - meine Idee war ja, die (kryptische) User-Id als PW zu nutzen, das geht natürlich nicht gut, weil diese ID bei einem Edit sichtbar ist und sich dann jeder damit einloggen könnte - kleiner Denkfehler.
Ich werde nun User-IDs und PWs vorab generieren, und habe jetzt auch die passende Libreoffice-Extension dazu gefunden, denn zu meinem Erstaunen sind solche nicht in Calc enthalten.
10 Jahre alt, läuft aber mit dem aktuellen 6.2 problemlos (!).
@Michaelsy, fein, das direkte Editieren der users.auth.php ist hier sehr vorteilhaft.

Werde wieder berichten, ob das geklappt hat.
topic: User ohne Email  in the forum: Non-English Discussion German discussion
Avatar
bb88 #6
Member since May 2013 · 15 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 66611
Weil die Site (Einstiegsseite) im WWW sichtbar ist, später auch Teile des Workshop-Ergebnis.

Und es soll jeder User eine eigene ID haben, damit die Beiträge unterscheidbar sind, auch bei Diskussionen.
topic: User ohne Email  in the forum: Non-English Discussion German discussion
Avatar
bb88 #7
Member since May 2013 · 15 posts
Group memberships: Members
Show profile · Link to this post
Subject: User ohne Email
Für einen Workshop mit ~200 Leuten möchte ich vorab die User anlegen und jedem Teilnehmer einen individuellen (Hash-) Usernamen nennen (oder zusenden).
Eine Vielzahl von Usern kann man jetzt schon mit der Import-Funktion im User Manager erzeugen.
Die CSV-Tabelle mit den Hash-UserId und (fiktiven) Namen würde ich dann mit Libreoffice-Calc erzeugen.

FRAGEN:
Deren Emails weiss ich vorab nicht - und eigentlich braucht man dabei gar keine Email; was zusätzlich den Vorteil der Datensparsamkeit hätte (Datenschutz).

1. (Wie) Kann man Dokuwiki so einstellen, dass?:
a) keine Email für einen User benötigt wird,
   oder notfalls
b) keine funktionierende Email (dann würde ich dummy-Emails in die User-Liste eintragen)

Da die Email wohl gebraucht wird, um ein Passwort auszuhandeln, bedeutet das auch:
2. Kann ich Passwörter festlegen (/importieren), sodass die User sie nicht selbst angeben müssen (/können)?
Oder kann man Passwörter weglassen - die UserId enthält hier ja praktisch beides?
This post was edited on 2019-06-24, 17:17 by bb88.
topic: The datadir ('pages') at ./data/pages is not found  in the forum: General Help and Support Installation and Configuration
Avatar
bb88 #8
Member since May 2013 · 15 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 66332
We can keep it short - add this line on the installation page:
'The webserver needs access rights to the data directory (see security).'

Actually, this is not a security issue, it is needed for Dokuwiki to work.
topic: The datadir ('pages') at ./data/pages is not found  in the forum: General Help and Support Installation and Configuration
Avatar
bb88 #9
Member since May 2013 · 15 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 66276
My proposal was to put the hint about needed permissions on the install page:
https://www.dokuwiki.org/install

So instead of 'Read the security page before you begin installing. Take it seriously.' which implies 'You have to learn the Unix permission system before you can install Dokuwiki' one could say:
'Open access for the server to the data directory, for example:
 chown -R www-data:www-data ./ '

This is all the magic I propose.
topic: The datadir ('pages') at ./data/pages is not found  in the forum: General Help and Support Installation and Configuration
Avatar
bb88 #10
Member since May 2013 · 15 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 65295
@Andi and other hard working OS software creators:
  • Thanks a lot for this beautiful software!
  • Really, thanks a lot for this beautiful software!

BTW, you might consider to offer install instructions - on one page - that will get the software running even for people who are not willing to change the Unix permissions.

Think of it as driving a car - you do normally not need to be able to bleed the brake system before you use one.
And yes, sure, neither of this work is witchcraft. But ...
topic: contact plugin works fine, moderncontact doesn't  in the forum: General Help and Support Plugins
Avatar
bb88 #11
Member since May 2013 · 15 posts
Group memberships: Members
Show profile · Link to this post
Subject: contact plugin works fine, moderncontact doesn't
I used the contact plugin for some time on a
  2009-12-25b "Lemming"
dokuwiki and it works fine.
Now I get spams quite often und found the moderncontact plugin:
https://www.dokuwiki.org/plugin:contactmodern
It is meant to work very similar to the original one, only it allows recaptcha.
So I installed 'moderncontact' (and deactivated 'contact') and configured it with a recaptcha key.
BUT now the page renders only a media icon with the name 'contact' and not the form.

Switching back to 'contact' and deactivating 'moderncontact' works fine.
What can be the cause of the failure?
topic: Lost password - fails  in the forum: Offtopic Forum Help
Avatar
bb88 #12
Member since May 2013 · 15 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 38648
oookay, I actually expected a button/link and did not read the text to the end.

Thanks for the info, straightforward would be different, though.
topic: EDIT button deactivated after restore  in the forum: General Help and Support Installation and Configuration
Avatar
bb88 #13
Member since May 2013 · 15 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 38642
Ok, the file rights were changed during the restore - the solution was simple:
../data/> chown -R www-data pages/
topic: EDIT button deactivated after restore  in the forum: General Help and Support Installation and Configuration
Avatar
bb88 #14
Member since May 2013 · 15 posts
Group memberships: Members
Show profile · Link to this post
Subject: EDIT button deactivated after restore
After a spam attack (because I allowed everyone to register without being notified) I had to edit / restore my dokuwiki installation.
Now everything is fine as before - only no one, including me as admin, can edit a page anymore  (:

The "EDIT PAGE" Button is simply not displayed.
I checked and unchecked the "Edt page" checkbox in the config "Disable Dokuwiki actions" - no effect.

Maybe I changed or deleted some metadata with the restore, and I ran "Cache revision eraser".

So how can one reset the access configuration?
topic: Lost password - fails  in the forum: Offtopic Forum Help
Avatar
bb88 #15
Member since May 2013 · 15 posts
Group memberships: Members
Show profile · Link to this post
Subject: Lost password - fails
When using the "lost password" link on the forum login page, one is sent to the help page of the forum software:
http://newsboard.unclassified.de/docs/usage/register#forgo…

...but not to the actual "lost password" form / app.
Close Smaller – Larger + Reply to this post:
Special characters:
Special queries
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2019-12-08, 21:53:18 (UTC +01:00)