Not logged in. · Lost password · Register
Page:  1  2  next 

All posts by bpaddock (20)

topic: Can't Farm with PHP 5.6 but can with 5.5  in the forum: General Help and Support Server Setup
Avatar
bpaddock #1
Member since Apr 2014 · 20 posts
Group memberships: Members
Show profile · Link to this post
Subject: Can't Farm with PHP 5.6 but can with 5.5
When I switch to PHP 5.6 I get this error:

DokuWiki Setup Error

The datadir ('pages') at
/home/web/doku/farm/www.kpaddock.com/conf/../data/pages is not found,
isn't accessible or writable. You should check your config and
permission settings. Or maybe you want to run the installer?

that I'm not getting with PHP 5.5.

Anyone have any insights? 
The files are there and nothing is changing about the permission between 5.5 and 5.6.
topic: The plugin repository could not be contacted. Make sure your server....  in the forum: General Help and Support Server Setup
Avatar
bpaddock #2
Member since Apr 2014 · 20 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 49992
Quote by turnermm on 2015-09-26, 00:58:
Do you think this would help?

ini_set('display_errors',"1");
error_reporting(E_ALL);
ini_set('error_log',"path/to/log");

It would write all errors to the specified log file.  Just put it in doku.php.

Any of this mean anything to anyone?  I'm still having this problem.  Line 0?

Notice: Undefined index: flags in /home/web/doku/farmer/lib/plugins/include/helper.php on line 782

Strict Standards: Declaration of syntax_plugin_imagereference_imgcaption::handle() should be compatible with DokuWiki_Syntax_Plugin::handle($match, $state, $pos, Doku_Handler $handler) in /home/web/doku/farmer/lib/plugins/imagereference/syntax/imgcaption.php on line 19

Strict Standards: Declaration of syntax_plugin_imagereference_imgcaption::render() should be compatible with DokuWiki_Syntax_Plugin::render($format, Doku_Renderer $renderer, $data) in /home/web/doku/farmer/lib/plugins/imagereference/syntax/imgcaption.php on line 19

Strict Standards: Declaration of syntax_plugin_wrap_div::handle() should be compatible with DokuWiki_Syntax_Plugin::handle($match, $state, $pos, Doku_Handler $handler) in /home/web/doku/farmer/lib/plugins/wrap/syntax/div.php on line 0

Strict Standards: Declaration of syntax_plugin_wrap_div::render() should be compatible with DokuWiki_Syntax_Plugin::render($format, Doku_Renderer $renderer, $data) in /home/web/doku/farmer/lib/plugins/wrap/syntax/div.php on line 0

Strict Standards: Declaration of syntax_plugin_include_include::handle() should be compatible with DokuWiki_Syntax_Plugin::handle($match, $state, $pos, Doku_Handler $handler) in /home/web/doku/farmer/lib/plugins/include/syntax/include.php on line 0

Strict Standards: Declaration of syntax_plugin_include_include::render() should be compatible with DokuWiki_Syntax_Plugin::render($format, Doku_Renderer $renderer, $data) in /home/web/doku/farmer/lib/plugins/include/syntax/include.php on line 0

Notice: Undefined offset: 1 in /home/web/doku/farmer/lib/plugins/include/helper.php on line 79

Strict Standards: Declaration of syntax_plugin_include_wrap::handle() should be compatible with DokuWiki_Syntax_Plugin::handle($match, $state, $pos, Doku_Handler $handler) in /home/web/doku/farmer/lib/plugins/include/syntax/wrap.php on line 0

Strict Standards: Declaration of syntax_plugin_include_wrap::render() should be compatible with DokuWiki_Syntax_Plugin::render($format, Doku_Renderer $renderer, $data) in /home/web/doku/farmer/lib/plugins/include/syntax/wrap.php on line 0

Strict Standards: Declaration of syntax_plugin_include_editbtn::handle() should be compatible with DokuWiki_Syntax_Plugin::handle($match, $state, $pos, Doku_Handler $handler) in /home/web/doku/farmer/lib/plugins/include/syntax/editbtn.php on line 0

Strict Standards: Declaration of syntax_plugin_include_editbtn::render() should be compatible with DokuWiki_Syntax_Plugin::render($format, Doku_Renderer $renderer, $data) in /home/web/doku/farmer/lib/plugins/include/syntax/editbtn.php on line 0

Strict Standards: Declaration of syntax_plugin_include_footer::handle() should be compatible with DokuWiki_Syntax_Plugin::handle($match, $state, $pos, Doku_Handler $handler) in /home/web/doku/farmer/lib/plugins/include/syntax/footer.php on line 0

Strict Standards: Declaration of syntax_plugin_include_footer::render() should be compatible with DokuWiki_Syntax_Plugin::render($format, Doku_Renderer $renderer, $data) in /home/web/doku/farmer/lib/plugins/include/syntax/footer.php on line 0

Notice: Undefined index: comment in /home/web/doku/farmer/lib/plugins/discussion/action.php on line 190
topic: The plugin repository could not be contacted. Make sure your server....  in the forum: General Help and Support Server Setup
Avatar
bpaddock #3
Member since Apr 2014 · 20 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 50037
I had "Use SSL to connect to proxy" checked,

I don't have that checked, am not using any kind of proxy nor using SSL.

I've flushed via 'iptables -F' and I still get that red line at the top saying the "The plugin repository could not be contacted. Make sure your server....".

I'm also using Yaws as a sever so it is nothing Apache related.

Any other ideas?
topic: Works with PHP 5.5 not working with 5.6  in the forum: General Help and Support Server Setup
Avatar
bpaddock #4
Member since Apr 2014 · 20 posts
Group memberships: Members
Show profile · Link to this post
Subject: Works with PHP 5.5 not working with 5.6
Using 2015-08-10a "Detritus" I'm having the following problem.  I did have the same problem with earlier versions as well.
My distro is Gentoo.

I have a working system with PHP 5.5.29 .

If I change nothing but the PHP version to 5.6.13 I get this on my Farm:

Warning: session_start(): open(/tmp/sess_rmi1sagflrnmrm9928j9l80no2, O_RDWR) failed: Permission denied (13) in /home/web/doku/farmer/inc/init.php on line 154
DokuWiki Setup Error

The datadir ('pages') at /home/web/doku/farm/www.kpaddock.com/conf/../data/pages is not found, isn't accessible or writable. You should check your config and permission settings. Or maybe you want to run the installer?

Warning: Unknown: open(/tmp/sess_rmi1sagflrnmrm9928j9l80no2, O_RDWR) failed: Permission denied (13) in Unknown on line 0

Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/tmp) in Unknown on line 0

What do I need to fix?
topic: The plugin repository could not be contacted. (Extension Manager can not check plugin repository.)  in the forum: General Help and Support Installation and Configuration
Avatar
bpaddock #5
Member since Apr 2014 · 20 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 48723
"The url you mention doesn't exist so far I see."

Yeah, somethng got lost along the way not sure where, sorry.


dokuwiki/lib/plugins/extension/helper/repository.php has this:

 * DokuWiki Plugin extension (Helper Component)


#define('EXTENSION_REPOSITORY_API', 'http://localhost/dokuwiki/lib/plugins/pluginrepo/api.php');

if (!defined('EXTENSION_REPOSITORY_API_ENDPOINT'))
    define('EXTENSION_REPOSITORY_API', 'http://www.dokuwiki.org/lib/plugins/pluginrepo/api.php');


which is called indirectly from dokuwiki/lib/plugins/extension/admin.php

to set the value of hasAccess.

As far as I can tell hasAccess is set to false by php while I can access that URL from the command line.
I can only assume I have something configured incorrectly someplace.  The quesion is where?

I don't see where github gets invovled unless it is via the data returned by the api file?
topic: The plugin repository could not be contacted. (Extension Manager can not check plugin repository.)  in the forum: General Help and Support Installation and Configuration
Avatar
bpaddock #6
Member since Apr 2014 · 20 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 46586
Getting back to this as I may have found a security issue and want to make sure everything is up to date.

I'm not a PHP expert.  If I followed the code correctly it ends up at file repository.php that tries to access this url:

 https://www.dokuwiki.org/lib/plugins/pluginrepophpi.php

If I do this from the server prompt:

curl -i  https://www.dokuwiki.org/lib/plugins/pluginrepophpi.php

I get a file that looks like version information for plugins, as I would expect.

So what is it telling me that curl from the prompt can access the file but repository.php can not?
topic: Minimun / Recommended Server Requirements  in the forum: General Help and Support Server Setup
Avatar
bpaddock #7
Member since Apr 2014 · 20 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 47187
Virtually unknown is the YAWS server written in Erlang.

It runs in low memory environments long after Apache has died under heavy loads as demonstrated here:

https://www.sics.se/~joe/apachevsyaws.html

I have been running a Dokuwiki Farm with YAWS for about a year now with no issues.

Only notable configuration change  to get Dokuwiki working with YAWS is redirect in fpm-php/php.ini needs set to zero as tho it is an ISS server.
topic: How to delete images in Media manager?  in the forum: General Help and Support Installation and Configuration
Avatar
bpaddock #8
Member since Apr 2014 · 20 posts
Group memberships: Members
Show profile · Link to this post
Subject: How to delete images in Media manager?
I am setting up a new (non-farm) wiki.

FAQ tells me that I should have a 'delete' button:

https://www.dokuwiki.org/faq:deletemedia

The User Manger tells me that members of the group 'admin' has delete rights.

Yet I find no way to delete any uploaded images (no delete buttons) to the Media Manager when logged in as an admin.

Also can not get any namespaces into the Media Manager.

Makes me think I have something setup wrong, at a lost as to what?
topic: The plugin repository could not be contacted. (Extension Manager can not check plugin repository.)  in the forum: General Help and Support Installation and Configuration
Avatar
bpaddock #9
Member since Apr 2014 · 20 posts
Group memberships: Members
Show profile · Link to this post
Subject: The plugin repository could not be contacted.
Can someone tell me what outbound port I need to unblock to remove this message please?:

"The plugin repository could not be contacted. Make sure your server is allowed to contact www.dokuwiki.org and check your proxy settings."

I'm running DokuWiki on a Gentoo Virtual Server.  For security everything is locked up rather tight.
topic: How to edit a page that loads a broken iframe?  in the forum: General Help and Support Syntax and Usage
Avatar
bpaddock #10
Member since Apr 2014 · 20 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 44708
Thank you.

I found it was IE specific.  Chrome and Firefox both rendered the bad URL.
topic: How to edit a page that loads a broken iframe?  in the forum: General Help and Support Syntax and Usage
Avatar
bpaddock #11
Member since Apr 2014 · 20 posts
Group memberships: Members
Show profile · Link to this post
Subject: How to edit a page that loads a broken iframe?
In my wiki this page: http://wiki.kpaddock.com/doku.php/kpaddock:my_story_2013 which is lengthy.
Is trying to load an iframe by the iframe plugin that apparently has a bad address to Amazon for a book link.

The correct wiki page flashes up then the page is refereed to the bad address and goes blank.
Is there anyway to fix this short of editing the file over SSH?

Anyway to get  the iframe plugin to check if the address is valid before trying to render it?
Security issue here?
topic: How do you have different favicons for each animal in a farm?  in the forum: General Help and Support Server Setup
Avatar
bpaddock #12
Member since Apr 2014 · 20 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 44521
I'll give these a try again, must have had something in the wrong place, or cached someplace unexpected:

:favicon.ico , :wiki:favicon.ico

Each Animal in the Farm has its own CONF and DATA directory.
All others are in the Farmer, which would be the normal Dokuwiki locations.

Changing the template in the Farmer directory is not really a viable option to get multiple favicons, at least not in any way that I understand, when the Animals use the same template.

I could make template_cat, template_dog etc and share the base via symbolic links. 
This is not a solution that gives me the warm fuzzies.

Is there way to inherit templates then overload favicon?
This post was edited on 2014-06-23, 22:33 by bpaddock.
topic: How do you have different favicons for each animal in a farm?  in the forum: General Help and Support Server Setup
Avatar
bpaddock #13
Member since Apr 2014 · 20 posts
Group memberships: Members
Show profile · Link to this post
Subject: How do you have different favicons for each animal in a farm?
How do you have different favicon.ico for each animal in a farm?

Searching did not lead me to any conclusive answer.
topic: Permission denied (13) in /home/web/doku/farmer/inc/init.php  in the forum: General Help and Support Server Setup
Avatar
bpaddock #14
Member since Apr 2014 · 20 posts
Group memberships: Members
Show profile · Link to this post
Subject: Permission denied (13) in /home/web/doku/farmer/inc/init.php
After a crash of the fcgi server, yet again, is it really this unstable?  On a system reboot I get this:

What should the permission on /tmp be?  Where do I set where temporary files go so I can point it to a directory I have better control over?

Also why is it telling me data/pages is not accessible/writable when having a failure of /tmp?  The pages are there with the correct permissions as far as I can tell.

Warning: session_start(): open(/tmp/sess_hgpa3amjoccqk1ajd5gjo8mba5, O_RDWR) failed: Permission denied (13) in /home/web/doku/farmer/inc/init.php on line 154
DokuWiki Setup Error

The datadir ('pages') at /home/web/doku/farm/wiki.kpaddock.com/conf/../data/pages is not found, isn't accessible or writable. You should check your config and permission settings. Or maybe you want to run the installer?

Warning: Unknown: open(/tmp/sess_hgpa3amjoccqk1ajd5gjo8mba5, O_RDWR) failed: Permission denied (13) in Unknown on line 0

Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/tmp) in Unknown on line 0
topic: Is it possible to use Gallery  inside of a Wrap? (Can't get Gallary to show picture when wrapping.)  in the forum: General Help and Support Plugins
Avatar
bpaddock #15
Member since Apr 2014 · 20 posts
Group memberships: Members
Show profile · Link to this post
Subject: Is it possible to use Gallery  inside of a Wrap?
I tried to use a Gallery link to an image inside of a Wrap block.  Wrap shows the gallary link text rather than the image.

What is the correct syntax to show an image inside a Wrap?
Close Smaller – Larger + Reply to this post:
Special characters:
Page:  1  2  next 
Special queries
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2019-11-17, 12:23:39 (UTC +01:00)