Not logged in. · Lost password · Register

All posts by alexlehm (11)

topic: Version information in the download link  in the forum: Community dokuwiki.org
Avatar
alexlehm #1
Member since Apr 2014 · 11 posts
Group memberships: Members
Show profile · Link to this post
After thinking this over a bit, maybe it would be possible to add a Content-Disposition header to supply a version based filename (doesn't work with wget though I think).

something like dokuwiki-2014-01-01-hashkey.tar.gz

this doesn't have to be reflected in the filename, if it is sent in the header.
topic: Version information in the download link  in the forum: Community dokuwiki.org
Avatar
alexlehm #2
Member since Apr 2014 · 11 posts
Group memberships: Members
Show profile · Link to this post
Subject: Version information in the download link
When downloading the dokuwiki distribution, the download links now contain a hashkey, probably to thwart hotlinking.

Previously the download filename contained the version date, which was kind of less confusing when processing more than one archive in a download dir e.g. with wget.

Would it be possible to include the version date in the download filename as well, like dokuwiki-2014-05-05a-hashkey.tar.gz ?
topic: Update button on plugins page - BUG ??  in the forum: General Help and Support Plugins
Avatar
alexlehm #3
Member since Apr 2014 · 11 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 44052
Thanks, I have updated the plugins as far as possible and switched from pagemove to move. That leaves the backup plugin, which may get fixed later.

For some reason some plugins didn't get the update even after retrying, when uninstalling and installing the plugins again, it worked (e.g. folded plugin), no idea why that happened.
topic: Update button on plugins page - BUG ??  in the forum: General Help and Support Plugins
Avatar
alexlehm #4
Member since Apr 2014 · 11 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 44039
Currently I am seeing a incorrect date on the following plugins:

BackupTool for DokuWiki
barcode -- 2D-Barcode Plugin
Divalign2 Plugin
Dw2Pdf plugin
Folded Plugin - Block
Linkbonus Plugin [preliminar]
Pagelist Plugin
Pagemove plugin
sqlite plugin

I'm not quite sure if all the plugins are actually used in our wiki, some may be obsolete.
topic: Show the short name of each plugin in the extension manager?  in the forum: General Help and Support Plugins
Avatar
alexlehm #5
Member since Apr 2014 · 11 posts
Group memberships: Members
Show profile · Link to this post
Subject: Show the short name of each plugin in the extension manager?
I'm not sure if the extension manager is a plugin itself, anyway I have a feature request for the plugin list.

The short name of each plugin (i.e. the dir it is installed in the plugins dir) would be helpful when trying to debug issues with plugin installation etc. Currently this is not displayed, even in the details view of the plugin. (I had one plugin installed in a dir named as hashkey for some reason which causes a duplicate entry in the plugin list, but this was not obvious).

Also it would be nice to show the plugin date in the list title, this is currently shown in the details view only.
topic: Update button on plugins page - BUG ??  in the forum: General Help and Support Plugins
Avatar
alexlehm #6
Member since Apr 2014 · 11 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 44025
I have now installed backup plugin in a dokuwiki installation that didn't have any plugins installed, it also shows the update version is available message.

It looks like the plugin was updated at the point in time (according to the github.com commit entry), but the plugin.info.txt file was not updated. Maybe this is the issue with all plugins not showing the correct update date?
topic: Update button on plugins page - BUG ??  in the forum: General Help and Support Plugins
Avatar
alexlehm #7
Member since Apr 2014 · 11 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 43316
Subject: Update button/version check on plugins page
I have the same issue I think, it narrowed this down to the plugin version of a plugin being different than the date that is reported on the extension manager page, e.g. I have the plugin "backup", which displays as follows:

[Image: http://i.imgur.com/qsdAp8S.png]

When I download the zip from the download url and extract it, the plugin.info.txt file shows:

base        backup
author      Terence J. Grant, Andreas Wagner
email       tjgrant@tatewake.com, andreas.wagner@em.uni-frankfurt.de
date        2011-04-26
name        BackupTool for DokuWiki
desc        A tool to backup your data and configuration.
url         http://www.dokuwiki.org/plugin:backup

and the github source also has the last commit about the same time, so I guess the date reported by the plugin update check is incorrect or the download url is wrong and there is another update available somewhere (which I don't think is likely since the author is still the same.)
topic: Github installation links do not work  in the forum: General Help and Support Plugins
Avatar
alexlehm #8
Member since Apr 2014 · 11 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 43799
The fix in the current development version fixes the missing header, but the header keyword was missing the colon.

I have check the fix with a squid running locally and adding user/pw to the unit tests, but it doesn't make much sense to put that into the normal source unless the test proxy is changed to require auth (or if you want to be really thorough, have on with and one without auth).
topic: Github installation links do not work  in the forum: General Help and Support Plugins
Avatar
alexlehm #9
Member since Apr 2014 · 11 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 43798
cannot do git inside the office network, I will create a bug fix this evening.

if you want to check, take a look at line 543 of inc/HTTPClient.php.
topic: Github installation links do not work  in the forum: General Help and Support Plugins
Avatar
alexlehm #10
Member since Apr 2014 · 11 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 43796
sorry, I analyzed the issue further and found the bug now (corrected the previous post accordingly).
topic: Github installation links do not work  in the forum: General Help and Support Plugins
Avatar
alexlehm #11
Member since Apr 2014 · 11 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 41006
Even though the thread is a bit old, let me add my findings regarding the issue.

(removed previous text since it turned out not to be the cause of the issue)

When accessing the plugin urls with a proxy requiring authentication, the https CONNECT requests are missing the authentication header due to a small error in the _ssltunnel method. The proxy gives a authentication required response (407) that makes the request fail obviously.
This post was edited on 2014-04-29, 16:53 by alexlehm.
Close Smaller – Larger + Reply to this post:
Special characters:
Special queries
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2019-08-19, 22:51:20 (UTC +02:00)