Not logged in. · Lost password · Register
Page:  1  2  next 

All posts by bmentink (24)

topic: Blank page Error 500 after upgrade to Greebo on FreeBSD  in the forum: General Help and Support Server Setup
Avatar
bmentink #1
Member since Sep 2014 · 24 posts
Group memberships: Members
Show profile · Link to this post
Ok, I installed php72-filter, restarted the server and all is good again ..

In the end, the simplest way was to upgrade the iocage jail, then do a "pkg upgrade" within the jail, then install the above filter package and restart.

Hope this helps someone else ..
topic: Blank page Error 500 after upgrade to Greebo on FreeBSD  in the forum: General Help and Support Server Setup
Avatar
bmentink #2
Member since Sep 2014 · 24 posts
Group memberships: Members
Show profile · Link to this post
Subject: Blank page Error 500 after upgrade to Greebo on FreeBSD
Hi,

I am getting the following error after upgrade to Greebo. I also did an upgrade to Freebsd which may have upgraded PHP ..


2019/02/22 15:19:42 [error] 45065#101638: *1 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Call to undefined function session_name() in /usr/local/www/dokuwiki/inc/init.php on line 231" while reading response header from upstream, client: 173.208.130.202, server: localhost, request: "GET /start?do=diff&rev2[0]=1490831500&rev2[1]=1523244950&difftype=sidebyside HTTP/1.1", upstream: "fastcgi://unix:/var/run/php-fpm.sock:", host: "www.mywebpage.com"

PHP Version is now 5.6.40
nginx Version is 1.14.2

Any suggestions please

EDIT: php56-session is installed, do I need to enable it somewhere maybe ..?

Upgraded to PHP72 and now I get:

[error] 8339#101673: *1 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Uncaught Error: Call to undefined function filter_var() in /usr/local/www/dokuwiki/lib/plugins/quickstats/scripts/php-inet6_1.0.2/valid_v6.php:20

This post was edited 2 times, last on 2019-02-22, 05:18 by bmentink.
topic: "Nice URL" rewrite does not work at all.  in the forum: General Help and Support Installation and Configuration
Avatar
bmentink #3
Member since Sep 2014 · 24 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 56310
Quote by FosseWay on 2017-04-08, 22:05:
It may be irrelevant, but did you notice the double-slash in this line of your config between www and dokuwiki?

alias.url += ("/dokuwiki" => "/usr/local/www//dokuwiki/")

Doesn't look right to me.

You are right, good catch .. I will fix it tonight, and see if that helps.
topic: "Nice URL" rewrite does not work at all.  in the forum: General Help and Support Installation and Configuration
Avatar
bmentink #4
Member since Sep 2014 · 24 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 56184
Also, I find I can do the following from outside my local network ...

wget mywebpage.com/dokuwiki/doku.php

The file is fetched fine ... does that mean url rewrite is not working, and I have some big security holes ... please help!
This post was edited on 2017-04-06, 06:26 by bmentink.
topic: Your PHP seems to miss SSL support. Downloading will not work for many DokuWiki extensions.  in the forum: General Help and Support Installation and Configuration
Avatar
bmentink #5
Member since Sep 2014 · 24 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 55105
Quote by MichaelWaterman on 2017-01-06, 21:54:
Fixed it!

I'm running dokuwiki on a sinology NAS and upgraded the software (Incl php) last week. Apparently the openssl extension wasn't enabled by default, hence the error message. After enabling the openssl in the php extension interface it started working again!

Hope anyone can make use of this information!

Michael

Can you elaborate a bit more on how you enabled this. I have the same issue running dokuwiki on FreeNAS..
Thanks
topic: "Nice URL" rewrite does not work at all.  in the forum: General Help and Support Installation and Configuration
Avatar
bmentink #6
Member since Sep 2014 · 24 posts
Group memberships: Members
Show profile · Link to this post
Subject: "Nice URL" rewrite does not work at all.
Hi,

I am trying to get "Nice URL's" working with config option 1.

When I set $conf['userewrite'] = '1'; and setup lighttpd as follows, I get 404 page errors:

Relavant part of lighttpd.conf is:

server.document-root = "/usr/local/www"

var.dokudir = server.document-root + "/dokuwiki"

# rewrites for dokuwiki
$HTTP["url"] =~ "^" + var.dokudir { index-file.names = ("doku.php") }
    url.rewrite = (
      "^" + var.dokudir + "/lib/.*$"                     => "$0",
      "^" + var.dokudir + "/_media/(.*)?\?(.*)$"         => var.dokudir + "/lib/exe/fetch.php?media=$1&$2",
      "^" + var.dokudir + "/_media/(.*)$"                => var.dokudir + "/lib/exe/fetch.php?media=$1",
      "^" + var.dokudir + "/_detail/(.*)?\?(.*)$"        => var.dokudir + "/lib/exe/detail.php?media=$1&$2",
      "^" + var.dokudir + "/_detail/(.*)?$"              => var.dokudir + "/lib/exe/detail.php?media=$1",
      "^" + var.dokudir + "/_export/([^/]+)/(.*)\?(.*)$" => var.dokudir + "/doku.php?do=export_$1&id=$2&$3",
      "^" + var.dokudir + "/_export/([^/]+)/(.*)"        => var.dokudir + "/doku.php?do=export_$1&id=$2",
      "^" + var.dokudir + "/doku.php.*"                  => "$0",
      "^" + var.dokudir + "/feed.php.*"                  => "$0",
      "^" + var.dokudir + "/(.*)\?(.*)"                  => var.dokudir + "/doku.php?id=$1&$2",
      "^" + var.dokudir + "/(.*)"                        => var.dokudir + "/doku.php?id=$1"
    )

url.rewrite-once = ( "^/dokuwiki/(data|conf|bin|inc)/+.*" => "/nonexistentfolder" )


##
## both rewrite/redirect support back reference to regex conditional using %n
##
#$HTTP["host"] =~ "^www\.(.*)" {
#  url.redirect            = ( "^/(.*)" => "http://%1/$1" )
#}

$HTTP["url"] =~ "^/dokuwiki" { server.follow-symlink = "enable" }
$HTTP["url"] =~ "/(\.|_)ht" { url.access-deny = ( "" ) }
$HTTP["url"] =~ "^" + var.dokudir + "/(bin|data|inc|conf)/+.*"  { url.access-deny = ( "" ) }

alias.url += ("/dokuwiki" => "/usr/local/www//dokuwiki/")
--------------------------------------------------------

My dokuwiki top level directory is:  /usr/local/www/dokuwiki

I have the rewrite php module enabled.

Thanks for any help.

EDIT: I did remember that I had to put in a full path for doku.php before the site would index properly from just the site address.
i.e
index-file.names += (
  "dokuwiki/doku.php", "doku.php", "index.xhtml", "index.html", "index.htm", "default.htm",
"index.php"
)
--------------------------------------------------------
This post was edited 2 times, last on 2017-04-06, 10:12 by bmentink.
topic: help changing over to authpdo please  in the forum: General Help and Support Installation and Configuration
Avatar
bmentink #7
Member since Sep 2014 · 24 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 55873
Thanks.

lighttpd -v
.. shows that ssl has been compiled into my version of lighttpd. So maybe it is something to do with my php version and ssl.
This post was edited on 2017-03-13, 18:47 by bmentink.
topic: help changing over to authpdo please  in the forum: General Help and Support Installation and Configuration
Avatar
bmentink #8
Member since Sep 2014 · 24 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 55840
Yeah, I am using freebsd on my server in a freenas jail. I installed lighttpd and php5.5 previously when setting up the web server.
I take it I have to install & setup openssl, but do I have to install a php-openssl extension as well? Just not familiar at all with ssl.

Sorry if this is way of topic. Probably should post this on a FreeNAS forum.
topic: help changing over to authpdo please  in the forum: General Help and Support Installation and Configuration
Avatar
bmentink #9
Member since Sep 2014 · 24 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 55838
Many thanks guys ..

Now I just have to see why I get the following message in Extension Manager:

Your PHP seems to miss SSL support. Downloading will not work for many DokuWiki extensions.

Do I have to do something with my web server? (lighttpd)
This post was edited on 2017-03-08, 20:51 by bmentink.
topic: help changing over to authpdo please  in the forum: General Help and Support Installation and Configuration
Avatar
bmentink #10
Member since Sep 2014 · 24 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 55668
I did not set up the sql extension before, I just notice it is there in the default installation.
I don't know what the sql authentication is even for, enlighten me ....

I am using the default athentication
authplain
topic: help changing over to authpdo please  in the forum: General Help and Support Installation and Configuration
Avatar
bmentink #11
Member since Sep 2014 · 24 posts
Group memberships: Members
Show profile · Link to this post
Subject: help changing over to authpdo please
Hi,

I have just updated my Dokuwiki (after 2 years) on my FreeNAS box and find that authpdo extension is now used instead of the other sql extensions.

What are the "simple" steps to changing over? I understand that in configuration you enable the authpdo as authentication method, but I don't know what, if anything, to set in the configuration for that extension.

I had a look at the dokuwiki page for authpro, but it is too complicated to follow for me, I know nothing about SQL and I should not have to, to use dokuwiki (I did not have to before)

.. or can I just disable it.

Any help appreciated

PS: I am also getting SSL errors on PHP, I don't know if that is part of the above, it means I cannot download extension upgrades.
This post was edited on 2017-02-25, 01:40 by bmentink.
topic: Upgrade issues  in the forum: General Help and Support Server Setup
Avatar
bmentink #12
Member since Sep 2014 · 24 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 49592
Quote by Klap-in:
The last hotfix of DokuWiki fixes an issue with installing via the Extension Manager. Are you sure you have installed that version?

VERSION Shows: 2015-08-10a "Detritus"
topic: Upgrade issues  in the forum: General Help and Support Server Setup
Avatar
bmentink #13
Member since Sep 2014 · 24 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 49591
Quote by Klap-in:
Local changes to style.ini has to be move to the conf folder.
See https://www.dokuwiki.org/devel:style.ini#local_styleini for details

Ahh .. did not realize the change of format .. work now, thanks.
topic: Upgrade issues  in the forum: General Help and Support Server Setup
Avatar
bmentink #14
Member since Sep 2014 · 24 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 49568
Update:

It seems that style.ini still allows changing the page width, but the file style.local.ini is not recognized ..

The only way I can install the extensions, is by manual installation, downloading with the extension manager does not work anymore.
topic: Upgrade issues  in the forum: General Help and Support Server Setup
Avatar
bmentink #15
Member since Sep 2014 · 24 posts
Group memberships: Members
Show profile · Link to this post
Subject: Upgrade issues
Hi,

I have just upgraded to the latest and have issues combining the tar-ball with my working Dokuwiki, I have the following issues.

1. The style.local.ini file that I had that sets up full width wiki no longer works after being placed in the same directory as the style.ini file.

2. I can no longer install extensions: I get the following error when trying to upgrade or re-install the bookcreator extension/plugin.
I wonder if there is some permission issue that has got overwritten? I did have to "chown http.http" on the files after I merged them, as I did that as root.

What is the correct way to merge the tar-ball with your existing wiki during an upgrade?

Thanks
Close Smaller – Larger + Reply to this post:
Special characters:
Page:  1  2  next 
Special queries
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2020-02-17, 08:02:07 (UTC +01:00)