Not logged in. · Lost password · Register
Page:  1  2  3 ... 226  227  228  next 

All posts by andi (3412)

topic: Spam Alerts  in the forum: Offtopic Forum Help
Avatar
andi (Administrator) #1
User title: splitbrain
Member since May 2006 · 3499 posts · Location: Berlin Germany
Group memberships: Administrators, Members
Show profile · Link to this post
Quote by ach on 2019-11-07, 01:12:
As pop is reporting lots of spam, would it not make sense to give them admin permissions? Let me know if you're interested.

Good idea!

pop, I added you to the group of Global Moderators. You now can delete posts and users and access the moderator's sub forum. Welcome, and thank you very much for your help.
Read this if you don't get any useful answers.
Lies dies wenn du keine hilfreichen Antworten bekommst.
topic: AD-Login across internet (AD-Server is in another network than the webserver)  in the forum: General Help and Support Installation and Configuration
Avatar
andi (Administrator) #2
User title: splitbrain
Member since May 2006 · 3499 posts · Location: Berlin Germany
Group memberships: Administrators, Members
Show profile · Link to this post
In reply to post ID 67753
Quote by Odido:
And I thought the setting in local.php is the one I need for authad and is overwriting the setting in dokuwiki.php. Or am I wrong??

No, that's correct.
Read this if you don't get any useful answers.
Lies dies wenn du keine hilfreichen Antworten bekommst.
topic: Romanization or deaccent for unsupported languages  in the forum: General Help and Support Features and Functionality
Avatar
andi (Administrator) #3
User title: splitbrain
Member since May 2006 · 3499 posts · Location: Berlin Germany
Group memberships: Administrators, Members
Show profile · Link to this post
In reply to post ID 67702
Why don't you create a pull request with your changes?
Read this if you don't get any useful answers.
Lies dies wenn du keine hilfreichen Antworten bekommst.
topic: AD-Login across internet (AD-Server is in another network than the webserver)  in the forum: General Help and Support Installation and Configuration
Avatar
andi (Administrator) #4
User title: splitbrain
Member since May 2006 · 3499 posts · Location: Berlin Germany
Group memberships: Administrators, Members
Show profile · Link to this post
In reply to post ID 67725
Quote by Odido:
I just checked it. Now it says: "Dieses Auth Plugin ist in der Konfiguration nicht aktiviert, Du solltest es deaktivieren." When I disable the plugin and reenable it, it seems ok.

So it's actually not used. It's not enough to just have the plugin installed. You need to switch DokuWiki to use it for authentication: https://www.dokuwiki.org/config:authtype
Read this if you don't get any useful answers.
Lies dies wenn du keine hilfreichen Antworten bekommst.
topic: No ACL setup yet!  AUTHAD working  in the forum: General Help and Support Installation and Configuration
Avatar
andi (Administrator) #5
User title: splitbrain
Member since May 2006 · 3499 posts · Location: Berlin Germany
Group memberships: Administrators, Members
Show profile · Link to this post
In reply to post ID 67693
Quote by JMS:
1. I get the error "No ACL setup yet! Denying access to everyone." on the login screen

Show us your ACLs. You probably miss a rule for @ALL on the root.

Quote by JMS:
2. AD NTLM SSO does not work anymore. Users are presented with the logon screen with the purple  "No ACL setup yet! Denying access to everyone."  Users can enter their credentials and log on fine.

I have the old server up and running and have been comparing IIS and PHP configurations. Other than version differences the configurations are very similar.

Hard to give any advice here without knowing your exact setup.
Read this if you don't get any useful answers.
Lies dies wenn du keine hilfreichen Antworten bekommst.
topic: AD-Login across internet (AD-Server is in another network than the webserver)  in the forum: General Help and Support Installation and Configuration
Avatar
andi (Administrator) #6
User title: splitbrain
Member since May 2006 · 3499 posts · Location: Berlin Germany
Group memberships: Administrators, Members
Show profile · Link to this post
In reply to post ID 67692
Quote by Odido:
SSL is enabled.

that wasn't my question. did you check that authad is enabled?

Quote by Odido:
putenv('LDAPTLS_REQCERT=never');

disabling certificate checking isn't the best idea security wise. but see
https://stackoverflow.com/questions/3866406/need-help-igno…
Read this if you don't get any useful answers.
Lies dies wenn du keine hilfreichen Antworten bekommst.
topic: fail2ban vs. data directory security check  in the forum: General Help and Support Installation and Configuration
Avatar
andi (Administrator) #7
User title: splitbrain
Member since May 2006 · 3499 posts · Location: Berlin Germany
Group memberships: Administrators, Members
Show profile · Link to this post
In reply to post ID 67677
Quote by Aevalys:
AH01797: client denied by server configuration: /xxx/data/dont-panic-if-you-see-this-in-your-logs-it-means-your-directory-permissions-are-correct.png,

The problem is that I use fail2ban and this error triggers him and blocks the visitor. So I'd like to remove that message from apache alert log, but how to do this ?

You rather should configure fail2ban correctly
Read this if you don't get any useful answers.
Lies dies wenn du keine hilfreichen Antworten bekommst.
topic: AD-Login across internet (AD-Server is in another network than the webserver)  in the forum: General Help and Support Installation and Configuration
Avatar
andi (Administrator) #8
User title: splitbrain
Member since May 2006 · 3499 posts · Location: Berlin Germany
Group memberships: Administrators, Members
Show profile · Link to this post
In reply to post ID 67686
Just a hunch: did you actually enable the authad authentication?
Read this if you don't get any useful answers.
Lies dies wenn du keine hilfreichen Antworten bekommst.
topic: AD-Login across internet (AD-Server is in another network than the webserver)  in the forum: General Help and Support Installation and Configuration
Avatar
andi (Administrator) #9
User title: splitbrain
Member since May 2006 · 3499 posts · Location: Berlin Germany
Group memberships: Administrators, Members
Show profile · Link to this post
In reply to post ID 67683
You're not getting any other messages despite having the debug option enabled? Then it seems the connection is just fine, only the binding fails. Maybe because of a wrong user or password? Maybe the user you're trying is disabled? Maybe your AD server has additional logs to debug this?
Read this if you don't get any useful answers.
Lies dies wenn du keine hilfreichen Antworten bekommst.
topic: Best practice? Gesamte Installation migrieren (Wie kann ich ein komplettes Dokuwiki auf einen anderen Server übertragen?)  in the forum: Non-English Discussion German discussion
Avatar
andi (Administrator) #10
User title: splitbrain
Member since May 2006 · 3499 posts · Location: Berlin Germany
Group memberships: Administrators, Members
Show profile · Link to this post
In reply to post ID 67604
https://www.dokuwiki.org/faq:servermove
Read this if you don't get any useful answers.
Lies dies wenn du keine hilfreichen Antworten bekommst.
topic: Neue Version?  in the forum: Non-English Discussion German discussion
Avatar
andi (Administrator) #11
User title: splitbrain
Member since May 2006 · 3499 posts · Location: Berlin Germany
Group memberships: Administrators, Members
Show profile · Link to this post
In reply to post ID 67567
https://www.dokuwiki.org/faq:nextrelease
Read this if you don't get any useful answers.
Lies dies wenn du keine hilfreichen Antworten bekommst.
topic: Subdirectory Install  in the forum: General Help and Support Installation and Configuration
Avatar
andi (Administrator) #12
User title: splitbrain
Member since May 2006 · 3499 posts · Location: Berlin Germany
Group memberships: Administrators, Members
Show profile · Link to this post
In reply to post ID 67526
Quote by darb:
without using a redirect.

Quote by pop:
header("Location: dokuwiki/doku.php");

That is a redirect!?

I'm not sure what OP expected, but the proper solution would be to either change the server's document root or to move up all the files one level.
Read this if you don't get any useful answers.
Lies dies wenn du keine hilfreichen Antworten bekommst.
topic: Lesebestätigung per Checkbox  in the forum: Non-English Discussion German discussion
Avatar
andi (Administrator) #13
User title: splitbrain
Member since May 2006 · 3499 posts · Location: Berlin Germany
Group memberships: Administrators, Members
Show profile · Link to this post
In reply to post ID 67535
https://www.dokuwiki.org/plugin:acknowledge
Read this if you don't get any useful answers.
Lies dies wenn du keine hilfreichen Antworten bekommst.
topic: SimpleNavi breaking apart  in the forum: General Help and Support Plugins
Avatar
andi (Administrator) #14
User title: splitbrain
Member since May 2006 · 3499 posts · Location: Berlin Germany
Group memberships: Administrators, Members
Show profile · Link to this post
In reply to post ID 67206
This also doesn't look like the simplenavi plugin either.
Read this if you don't get any useful answers.
Lies dies wenn du keine hilfreichen Antworten bekommst.
topic: draw.io plugin  in the forum: General Help and Support Plugins
Avatar
andi (Administrator) #15
User title: splitbrain
Member since May 2006 · 3499 posts · Location: Berlin Germany
Group memberships: Administrators, Members
Show profile · Link to this post
In reply to post ID 67509
Quote by lejmr on 2019-10-13, 11:11:
I have just done a very basic implementation of Draw.io plugin.

Cool, however there are a couple of things that need improvements.

  • the javascript pollutes the global namespace, you should wrap everything in a anonymous function
  • you should use jQuery to attach events
  • the toolbar button always inserts the same name
  • no ACLs are checked for saving and loading these images
  • media should be referenced by the ml() function (also no need to use data URIs to display it)
  • media file paths should be created with the mediaFN() function
  • don't use inline JavaScript and CSS

I'm not sure I understand how the data is stored. I see references to something called xmlpng in the javascript code, but later the images are used as PNG images... So I guess this is a PNG with some XML data embedded? I would prefer to use SVG instead of PNG (if possible).

It would probably also be cool if one could use drawio images just like other images. Eg. by overriding the image syntax and have a convention that draw.io images end in .drawio.png - that way users could simply insert existing draw.io drawings from the media popup.
Read this if you don't get any useful answers.
Lies dies wenn du keine hilfreichen Antworten bekommst.
Close Smaller – Larger + Reply to this post:
Special characters:
Page:  1  2  3 ... 226  227  228  next 
Special queries
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2019-11-14, 21:18:20 (UTC +01:00)