Not logged in. · Lost password · Register

All posts by exxter (11)

topic: bureaucracy - save form in dokuwiki  in the forum: General Help and Support Plugins
Avatar
exxter #1
Member since Nov 2008 · 11 posts
Group memberships: Members
Show profile · Link to this post
Subject: bureaucracy - save form in dokuwiki
Hello,

I try to save a filled form, but it doesnt work.

I create a file in the filesystem under "../data/pages/" for example 67567567567567.txt with the form (later this should be scripted), then I fill this form with dokuwiki. Now, this form should be saved under the pagename "67567567567567", but how?

I try:

action template - 67567567567567

The error: "Could not read template "". Maybe it doesn't exist or you have no read permissions?.

or:

action template userstpl 76786786786

but it does not save the complete form.

All permissions are right, the files and paths are writeable for www-data.

Any ideas?
This post was edited 2 times, last on 2019-08-06, 12:33 by exxter.
topic: Plugin with "real" Signature over a tablet  in the forum: General Help and Support Plugins Plugin Wishlist
Avatar
exxter #2
Member since Nov 2008 · 11 posts
Group memberships: Members
Show profile · Link to this post
Subject: Plugin with "real" Signature over a tablet
Hello,

Is there a plugin for getting signatures over a tablet in Dokuwiki? For example with this lib:

https://github.com/legalthings/angular-signature
https://github.com/BioPhoton/angular-signature-pad

Or how much would it cost to have it programmed?

Thanks very much,
topic: Plugin für "echte" Unterschriften  in the forum: Non-English Discussion German discussion
Avatar
exxter #3
Member since Nov 2008 · 11 posts
Group memberships: Members
Show profile · Link to this post
Subject: Plugin für "echte" Unterschriften
Hallo,

gibt es ein Plugin, mit dem man eine "echte" Unterschrift über ein Tablet in DokuWiki bekommt?

Speziell würde ich das Bureaucracy Plugin* damit benutzen wollen. Ziel ist, ein Formular zu bauen, welches man nach dem Ausfüllen unterschreiben muss.

Eventuell in Verbindung mit sowas: https://github.com/BioPhoton/angular-signature-pad


  • https://www.dokuwiki.org/plugin:bureaucracy

Edit: sorry, bin wohl hier im falschen Forum gelandet? Beitrag kann gelöscht werden, habe nochmal im korrekten Forum gepostet. Bitte entschuldigt den Doppelpost.
This post was edited 2 times, last on 2019-08-02, 11:35 by exxter.
topic: No users from LDAP in Dokuwiki  in the forum: General Help and Support Installation and Configuration
Avatar
exxter #4
Member since Nov 2008 · 11 posts
Group memberships: Members
Show profile · Link to this post
Subject: No users from LDAP in Dokuwiki
Hello,

i can authenticate me with my OpenLDAP User/Pass in Dokuwiki, great! But this user is not visible in Dokuwiki. How can i manage this LDAP user in DokuWiki?
topic: [solved] LDAP Auth Plugin want work, bug?  in the forum: General Help and Support Installation and Configuration
Avatar
exxter #5
Member since Nov 2008 · 11 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 54418
 :nuts: ... if someone have the same problem: why is

$conf['plugin']['authldap']['version'] = 2;

the default?!? It must be 3!
topic: [solved] LDAP Auth Plugin want work, bug?  in the forum: General Help and Support Installation and Configuration
Avatar
exxter #6
Member since Nov 2008 · 11 posts
Group memberships: Members
Show profile · Link to this post
Subject: [solved] LDAP Auth Plugin want work, bug?
Hello,

i have set up a new Dokuwiki (Release 2016-06-26a) with the LDAP Authentication Plugin, running on a Debian Jessie. I configure dokuwiki, i can login as admin and configuration the ldap Plugin. I try to let all so simple as possible (no groups). The conf/local.php is:

$conf['authtype'] = 'authldap';
$conf['superuser'] = '@admin';
$conf['usewordblock'] = 0;
$conf['plugin']['authldap']['server'] = 'localhost';
$conf['plugin']['authldap']['usertree'] = 'ou=people, dc=EXAMPLE, dc=de';
$conf['plugin']['authldap']['userfilter'] = '(&(uid=%{user})(objectClass=inetOrgPerson))';
$conf['plugin']['authldap']['debug'] = 1;
$conf['plugin']['authldap']['modPass'] = 0;

I use some other tools like OTRS Ticketsystem with this OpenLDAP-Server, everything works well.

But if i change authtype from "authplain" to "authldap" and try to login to DokuWiki with the uid and my password, i got:

LDAP: couldn't connect to LDAP server
Protocol error [auth.php:569]
Benutzername oder Passwort sind falsch.

I have change the objectClass to "person" and "organizationalPerson". I have try "localhost:389" as host. Nothing works.

Seems its a bug in the plugin?
This post was edited 2 times, last on 2016-11-08, 07:47 by exxter.
topic: Dokuwiki mit LDAP, "couldn't connect to LDAP server"  in the forum: Non-English Discussion German discussion
Avatar
exxter #7
Member since Nov 2008 · 11 posts
Group memberships: Members
Show profile · Link to this post
Subject: Dokuwiki mit LDAP, "couldn't connect to LDAP server"
Hallo,

ich versuche, DokuWiki an ein OpenLDAP anzuhängen. Habe dazu das Plugin installiert und folgende Konfiguration im Webinterface eingegeben:

$conf['authtype'] = 'authldap';
$conf['plugin']['authldap']['binddn'] = 'anonymous';
$conf['plugin']['authldap']['bindpw'] = '';
$conf['plugin']['authldap']['server'] = 'FIRMA.de';
$conf['plugin']['authldap']['usertree'] = 'ou=people, dc=FIRMA, dc=de';
$conf['plugin']['authldap']['grouptree'] = 'ou=groups, dc=FIRMA, dc=de';
$conf['plugin']['authldap']['userfilter'] = '(&(employeeNumber=%{user})(objectClass=inetOrgPerson))';

LDAP läuft auf dem selben Server, ich habe es schon mit 'localhost' probiert, mit 'ldap://localhost' und verschiedenen anderen Hosts, ich bekomme immer "LDAP: couldn't connect to LDAP server". Außerdem habe ich es ohne binddn und bindpw probiert, immer das gleiche. Da auf dem gleichen Server auch schon andere Webprogramme laufen die ihre Daten ebenfalls aus OpenLDAP holen, verstehe ich nicht, wieso DokuWiki diese Meldung auswirft?

Hat jemand eine Idee dazu?
topic: Editor-Buttons fehlen - mal wieder  in the forum: Non-English Discussion German discussion
Avatar
exxter #8
Member since Nov 2008 · 11 posts
Group memberships: Members
Show profile · Link to this post
Subject: Editor-Buttons fehlen - mal wieder
Hallo,

seit dem Update auf die Version 2009-02-14b habe ich keine Werkzeugleiste mehr im Editor.

http://www.dokuwiki.org/faq:toolbar
http://forum.dokuwiki.org/thread/3722

Beides habe ich durchgearbeitet/gelesen, hat alles nichts gebracht. Das Problem tritt bei allen Clients auf, nicht nur bei einem PC.
Den Cache der Browser habe ich x mal geleert. Berechtigungen des Wikis stimmen auch alle (chown -R www-data.www-data *).
Ich benutze nur das default Template und keine zusätzlichen Plugins (aktivierte Plugins sind: acl, config, info, plugin, revert, usermanager).

Beim Update habe ich die neue Version über die alte entpackt (ein kleiner Kritikpunkt dazu, der entpackte Ordner sollte dann doch "dokuwiki-2009-02-14b" heißen und nicht genau so wie die letzte Version?). Sonst habe ich immer die Daten vom alten Ordner in den der neuen Version kopiert. Kann es daran liegen?

Das:

http://example.com/dokuwiki/lib/exe/js.php

habe ich gemacht, kommt eine Seite mit viel Text:

var DOKU_BASE='/wiki/';var DOKU_TPL='/wiki/lib/tpl/default/';var alertText='Bitte geben Sie den zu formatierenden Text ein.\nDieser wird am Ende des Dokuments eingefügt.';;var notSavedYet=Nicht gespeicherte Änderungen gehen verloren!\nWeitermachen?';v;var reallyDel=intrag wirklich löschen?';LA;LANG={epopen":"F:nster nach Auswahl nicht schlie\u00dfe","h,dedetails":"D:tails ausblenden","n,smblinks":"D:s Verlinken von Windows Freigaben funktioniert nur im Microsoft Internet Explorer.\nDer Link kann jedoch durch Kopieren und Einf\u00fcgen verwendet werden","m,_btn":"M:hrere Dateien gleichzeitig hochladen","p,ugins":[]:[]};*/*/---cks---*/function isUndefined(prop*/)*/{return(typeof prop==defined');
);}*/function isFunction(prop*/)*/{return(typeof prop==nction');
);}*/function isString(prop*/)*/{return(typeof prop==ring');
);}*/function isNumber(prop*/)*/{return(typeof prop==mber');
[...]

Aber was soll mir das sagen?

Bin mit meinem Latein am Ende. Hat jemand einen Tip?
This post was edited on 2009-06-09, 17:21 by exxter.
topic: kein TOC  in the forum: Non-English Discussion German discussion
Avatar
exxter #9
Member since Nov 2008 · 11 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 11705
Genau DAS wars, jetzt erscheint das TOC wieder. Herzlichen Dank! :-)
topic: kein TOC  in the forum: Non-English Discussion German discussion
Avatar
exxter #10
Member since Nov 2008 · 11 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 11690
Hallo,

habe ich probiert, bleibt aber gleich, kein TOC. :-/

Noch jemand eine Idee?
topic: kein TOC  in the forum: Non-English Discussion German discussion
Avatar
exxter #11
Member since Nov 2008 · 11 posts
Group memberships: Members
Show profile · Link to this post
Subject: kein TOC
Hallo,
ich habe gerade ein Dokuwiki auf die aktuelle Version geupdatet. Jetzt wird auf keiner Seite (außer in den Einstellungen?) mehr das Inhaltsverzeichnis angezeigt. Lösungen die ich bisher gefunden habe waren das Template, ich benutze aber das Standardtemplate. Auch Plugins sind keine zusätzlichen installiert. Einstellungen unter Admin -> Konfiguration -> Anzeige-Konfiguration:
   
toptoclevel   5
maxtoclevel   5

aus Testzwecken habe ich es auf 5 gestellt, vorher stand es auf 3. Trotzdem wird kein TOC angezeigt. Am Browser kanns auch nicht liegen, habe es mit mehreren getestet (auf versch. Rechnern).

Jemand eine Idee woran das hängt?

PS: natürlich hat es vor dem Update einwandfrei funktioniert, an der verwendeten höhe der Überschriften sollte es also nicht liegen. Bzw werden 6 = und 5 = benutzt, sollte also ausreichend sein dass er automatisch ein TOC erzeugt wie er es vorher auch tat.
This post was edited on 2009-03-12, 15:24 by exxter.
Close Smaller – Larger + Reply to this post:
Special characters:
Special queries
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2020-02-17, 08:34:09 (UTC +01:00)