Not logged in. · Lost password · Register
Page:  1  2  next 

All posts by SonoDavid2 (20)

topic: Colorizing a heading via source code  in the forum: General Help and Support Templates and Layout
Avatar
SonoDavid2 #1
Member since Mar 2016 · 20 posts · Location: Belgium
Group memberships: Members
Show profile · Link to this post
I would do this using css3. This is a style file that your browser loads for every page you visit in the DokuWiki.

Try using this css

h1 {
    color: #da251c;
}

Put this in the file conf/userall.css which you have to create yourself.

Your can find more about this topic using this link: https://www.dokuwiki.org/devel:css
topic: Open current page with a separate stand­alone program (Need another, non-standard way, to edit a page)  in the forum: General Help and Support Features and Functionality
Avatar
SonoDavid2 #2
Member since Mar 2016 · 20 posts · Location: Belgium
Group memberships: Members
Show profile · Link to this post
In reply to post ID 53674
I like your solution with the AllText extension. It works great for the wiki I'm using and this way I can add some functionality to the editor without difficult programming :)
topic: Background Color Bootstrap3  in the forum: General Help and Support Templates and Layout
Avatar
SonoDavid2 #3
Member since Mar 2016 · 20 posts · Location: Belgium
Group memberships: Members
Show profile · Link to this post
In reply to post ID 53643
I just thought, probably when using the optional bootstrap theme, it gets loaded from the online repository. (https://maxcdn.bootstrapcdn.com/bootstrap/3.3.7/css/bootst…)
So you need to change to options to 'customised bootstrap theme' and set the link to your own theme.

Sorry if his is not too helpful but I hope you find the solution.
topic: Background Color Bootstrap3  in the forum: General Help and Support Templates and Layout
Avatar
SonoDavid2 #4
Member since Mar 2016 · 20 posts · Location: Belgium
Group memberships: Members
Show profile · Link to this post
In reply to post ID 53638
I think you need a css file, currently I can't really look for it myself but the file should be called something like bootstrap.css .
Change the background-color property in there.
Probably you will need to change the text colors too.
topic: Another Austrian guy is here  in the forum: Community User Introductions
Avatar
SonoDavid2 #5
Member since Mar 2016 · 20 posts · Location: Belgium
Group memberships: Members
Show profile · Link to this post
In reply to post ID 53374
Subject: Hello Austrian guy
Hello Karl,

I am from also working with JIRA and Confluence, but I think DokuWiki has a nice little community and most importantly it's free and open source :)

I hope you can find something useful here  :-D

Greets,

Joachim
topic: Ability to delete a page with a button  in the forum: General Help and Support Features and Functionality
Avatar
SonoDavid2 #6
Member since Mar 2016 · 20 posts · Location: Belgium
Group memberships: Members
Show profile · Link to this post
In reply to post ID 53262
I'm going to add it to the current bug tracker. I'm not a developer, but I do know some programming so I could try to do it.
Not going to pay someone to do it though, I don't need it that urgently :p
topic: Ability to delete a page with a button  in the forum: General Help and Support Features and Functionality
Avatar
SonoDavid2 #7
Member since Mar 2016 · 20 posts · Location: Belgium
Group memberships: Members
Show profile · Link to this post
Subject: Ability to delete a page with a button
Hello,

I'm wondering why there is no functionality to remove an old page by pressing the Delete button.
Currently to delete pages I have to edit a page and delete all the text in the topic, then click Save to remove an old or outdated article in the Wiki.
Even worse, I have to explain this to all people working on the wiki. Why not add this simple functionality?

Greetings,
Joachim
topic: Automatic Tooltip Glossary  in the forum: General Help and Support Plugins Plugin Wishlist
Avatar
SonoDavid2 #8
Member since Mar 2016 · 20 posts · Location: Belgium
Group memberships: Members
Show profile · Link to this post
In reply to post ID 45036
I think a glossary is something different then a list of abbreviations.
Let me show with an example:

An abbreviation: BTW = By the way
A glossary term: CMS = Short term for Content Delivery Network. A CDN is a large distributed system of servers deployed in multiple data centers across the Internet. The goal of a CDN is to serve content to end-users with high availability and high performance.

The first one is included into a list of abbreviations.
The second one is included into a glossary.

Is there a possibility of having an abbreviation list and a glossary in the dokuwiki?
topic: How Can I attach a page to an email? (I'm wondering how to do that)  in the forum: General Help and Support Features and Functionality
Avatar
SonoDavid2 #9
Member since Mar 2016 · 20 posts · Location: Belgium
Group memberships: Members
Show profile · Link to this post
In reply to post ID 52928
I'm using the bootstrap3 template on my wiki, in which there is an option to add some sharing links to the wiki.
You can see the sharing links in the top right corner of the page, for example on our company wiki:

http://flowtime.be/dokuwiki/start

Click on the 'letter' icon to share the link in a new e-mail.
topic: unable to upload file in Dokuwiki media manager  in the forum: General Help and Support General Stuff
Avatar
SonoDavid2 #10
Member since Mar 2016 · 20 posts · Location: Belgium
Group memberships: Members
Show profile · Link to this post
In reply to post ID 52508
Subject: FIXED!
It seems like the hosting provider finally woke up and fixed the problem (EDIT: So they disabled the rule which made uploading images impossible). Uploading files is fixed and I'm finally able to upload images without going trough the troublesome ftp uploading process  :-D
Thanks for all the tips and feel free to visit the wiki at http://flowtime.be/dokuwiki/doku.php?id=start
topic: unable to upload file in Dokuwiki media manager  in the forum: General Help and Support General Stuff
Avatar
SonoDavid2 #11
Member since Mar 2016 · 20 posts · Location: Belgium
Group memberships: Members
Show profile · Link to this post
In reply to post ID 52462
I am running the DokuWiki on a shared server. It runs on the same IP-adress as another website, but in a subdomain.
This shouldn't be the problem since I managed to do this with the same wiki installation on another server too, and that one runs fine.
I am able to log in to the server using ftp (using FileZilla on Windows 10) and found the etc folder in the root, but there are only two files: group and passwd. No other folders though.

Version of the Dokuwiki is Detritus (the last one) and it's running on PHP 5.6, probably with default settings since the shared server doesn't give me access to the PHP settings.
This post was edited 3 times, last on 2016-05-24, 18:21 by SonoDavid2.
topic: Hello, I'm Joachim, working on a dokuwiki for my company  in the forum: Community User Introductions
Avatar
SonoDavid2 #12
Member since Mar 2016 · 20 posts · Location: Belgium
Group memberships: Members
Show profile · Link to this post
Subject: Hello, I'm Joachim, working on a dokuwiki for my company
Greetings form Belgium! -Good morning, afternoon, evening, or night -
I'm an engineer working for a company that writes technical documentation for businesses.
I'm making a Wiki for our company to promote our company as well give free information away about technical writing.
I'm 26 and other hobbies include gaming on PS4 and playing board games.

I hope I can contribute a bit to this community and others will help me too with my problems.

The dokuwiki is currently up and running, on wiki.flowtime.be, but still there are some trouble uploading images. I'm really looking into it now and hope to find a solution soon.

Greetings!

Joachim
topic: unable to upload file in Dokuwiki media manager  in the forum: General Help and Support General Stuff
Avatar
SonoDavid2 #13
Member since Mar 2016 · 20 posts · Location: Belgium
Group memberships: Members
Show profile · Link to this post
In reply to post ID 52457
I found that I can't find the file /etc/asl/modsecurity_crs_30_http_policy.conf.
This is probably a file somehow hidden from view on the server?

So I don't really know what to do here, maybe someone can help? I'm guessing I'm not the only one with the file upload problem since i've seen a few topics about this.

I refer to the topics over here:
https://github.com/splitbrain/dokuwiki/issues/1104
https://forum.dokuwiki.org/thread/13051
This post was edited on 2016-05-23, 12:49 by SonoDavid2.
topic: unable to upload file in Dokuwiki media manager  in the forum: General Help and Support General Stuff
Avatar
SonoDavid2 #14
Member since Mar 2016 · 20 posts · Location: Belgium
Group memberships: Members
Show profile · Link to this post
In reply to post ID 52456
I found the error log on the server, when uploading a file this line is written into the log:

[Mon May 23 11:11:38 2016] [error] [client 81.82.205.48] ModSecurity:  [file "/etc/asl/modsecurity_crs_30_http_policy.conf"] [line "69"] [id "960010"] [msg "Request content type is not allowed by policy"] [severity "WARNING"] [tag "POLICY/ENCODING_NOT_ALLOWED"] Access denied with code 501 (phase 2). Match of "rx (?:^(?:application\\\\/x-www-form-urlencoded(?:;(?:\\\\s?charset\\\\s?=\\\\s?[\\\\w\\\\d\\\\-]{1,18})?)??$|multipart/form-data;)|text/xml)" against "REQUEST_HEADERS:Content-Type" required. [hostname "flowtime.be"] [uri "/dokuwiki/lib/exe/ajax.php"] [unique_id "V0LJSn8AAAEABZb-Pe8AAAAZ"]

I am fiddling a bit with the ajax.php file but no results yet.
topic: unable to upload file in Dokuwiki media manager  in the forum: General Help and Support General Stuff
Avatar
SonoDavid2 #15
Member since Mar 2016 · 20 posts · Location: Belgium
Group memberships: Members
Show profile · Link to this post
In reply to post ID 50844
I am currently having the same problem - pretty sure it has something to do with the php 5.6 version.
It's not the file size for sure and also not the plugins or theme.
The problem manifests itself on every browser, when uploading an image using the media manager, just says 'Failed'.
I'm looking into it now, but not sure if I will find a solution to this, I'll keep posting if I find something.

The same wiki files on another server work fine, by the way.
This post was edited on 2016-05-23, 12:49 by SonoDavid2.
Close Smaller – Larger + Reply to this post:
Special characters:
Page:  1  2  next 
Special queries
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2020-01-27, 18:59:52 (UTC +01:00)