Not logged in. · Lost password · Register
Page:  1  2  3  next 

All posts by rburn99 (34)

topic: suppressing blank line when starting a list  in the forum: General Help and Support Syntax and Usage
Avatar
rburn99 #1
Member since Mar 2017 · 34 posts
Group memberships: Members
Show profile · Link to this post
I thought style.css, print.css, all.css, and feed.css were the 'system' files that would be overwritten and userstyle.css, userprint.css, userall.css, and userfeed.css were the "safe" ones.  amiwrong? It's been a while since I set this wiki up but I thought I had to create userall.css myself.
topic: suppressing blank line when starting a list  in the forum: General Help and Support Syntax and Usage
Avatar
rburn99 #2
Member since Mar 2017 · 34 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 59551
got it sorted..  I added the following code to userall.css

p + ul {
margin-top: -20px !important;
}

p + ol {
margin-top: -20px !important;
}
topic: suppressing blank line when starting a list  in the forum: General Help and Support Syntax and Usage
Avatar
rburn99 #3
Member since Mar 2017 · 34 posts
Group memberships: Members
Show profile · Link to this post
Subject: suppressing blank line when starting a list
I don't like the blank line before the 1st item in a list as the list usually has something to do with the preceding line and I could easily add a blank line if necessary. How would I suppress this blank line?


Some topic (with current effect)

    subtext one
    subtext two
    subtext three

Some topic (with desired effect)
    subtext one
    subtext two
    subtext three
topic: bypassing the details page  in the forum: General Help and Support Syntax and Usage
Avatar
rburn99 #4
Member since Mar 2017 · 34 posts
Group memberships: Members
Show profile · Link to this post
Subject: bypassing the details page
Can the details page be bypassed? Rather than the file being displayed in the details page(http://mywiki/lib/exe/detail.…?id=logos&media=testfi…) when a media file is clicked, I would like the file to download or display all alone so that functionality more closely resembles typical web browsing when media files are clicked.
This post was edited on 2017-11-10, 16:00 by rburn99.
topic: How to use a media file as a link to another media file?  in the forum: General Help and Support Syntax and Usage
Avatar
rburn99 #5
Member since Mar 2017 · 34 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 58642
Do you have a link to any documentation on "this>_"?  I tried searching the web but came up empty

[[this>_media/tarusicon2016blackontransparent.svg|{{TarusIcon2016BlackTransparentThumbnail.jpg}}]]\\
gives me
The requested URL /_media/tarusicon2016blackontransparent.svg was not found on this server.

I tried different permutations but not knowing what 'this>' does I have no idea what to change
topic: How to use a media file as a link to another media file?  in the forum: General Help and Support Syntax and Usage
Avatar
rburn99 #6
Member since Mar 2017 · 34 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 58634
That doesn't work because the [[   ]] tells the wiki it's a link to a page rather than to a media file.

So far I have tried the following:
{{tarusicon2016blackontransparent.svg|TarusIcon2016BlackTransparentThumbnail.jpg}}\\
{{tarusicon2016blackontransparent.svg|{{TarusIcon2016BlackTransparentThumbnail.jpg}}}}\\
[[tarusicon2016blackontransparent.svg|{{TarusIcon2016BlackTransparentThumbnail.jpg}}]]\\
{{tarusicon2016blackontransparent.svg}}|{{TarusIcon2016BlackTransparentThumbnail.jpg}}\\

The first two show text instead of the thumbnail but they both serve up the svg file (although the resulting page is a bit unintuitive as there is nothing instructing the user to click here to download. They have to just realize that if they click the smaller version of the name of the file it will result in a download)
The third shows an image but when you click it dokuwiki says "This topic does not exist yet"
The fourth shows the jpg and clicking on it displays the media page for the jpg.

Perhaps I will just show a non linked version of the thumbnails with a "Download" link after each. Is there a way to tell dokuwiki to directly download a media file rather than showing a page about it and then downloading it from there?
This post was edited 2 times, last on 2017-11-08, 19:06 by rburn99.
topic: How to use a media file as a link to another media file?  in the forum: General Help and Support Syntax and Usage
Avatar
rburn99 #7
Member since Mar 2017 · 34 posts
Group memberships: Members
Show profile · Link to this post
Subject: How to use a media file as a link to another media file?
I have some svg graphics uploaded in the media manager. Because svg isn't guaranteed to be viewable on all systems I want the links to them to be jpg screencaptures. How do I use a media file as a link to another media file?

This creates a link to the svg file but shows text instead of the jpg thumbnail
{{tarusicon2016blackontransparent.svg|TarusIcon2016BlackTransparentThumbnail.jpg}}\\

This creates a link to the svg file but shows the same text as above but with pairs of brackets at each end
{{TarusIcon2016BlackTransparentThumbnail.jpg|tarusicon2016blackontransparent.svg}}\\
topic: Lists lose carriage returns  in the forum: General Help and Support Features and Functionality
Avatar
rburn99 #8
Member since Mar 2017 · 34 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 58069
Thanks for the suggestion, that is better. So basically you have to be out of the special mode (whatever it is) before the end of line of the list item. This seems like an issue(bug?) with dokuwiki itself as even the base functionality of **bold** breaks the list.
topic: Lists lose carriage returns  in the forum: General Help and Support Features and Functionality
Avatar
rburn99 #9
Member since Mar 2017 · 34 posts
Group memberships: Members
Show profile · Link to this post
Subject: Lists lose carriage returns
Lists lose their carriage returns if they are nested inside another formatting wrapper. For example:

<color gray>
Test
  *one
  *two
  *three
</color>

or

**
Test
  *one
  *two
  *three
**

Everything is there except the carriage returns. Is this something that I can address? I can work around it by doing the following:
**
Test\\
<wrap indent></wrap>one\\
<wrap indent></wrap>two\\
<wrap indent></wrap>three\\
**
but that doesn't seem like a good way.. especially with long lists, and you don't get the bullets.
This post was edited 2 times, last on 2017-09-12, 17:41 by rburn99.
topic: OrphansWanted  in the forum: General Help and Support Plugins
Avatar
rburn99 #10
Member since Mar 2017 · 34 posts
Group memberships: Members
Show profile · Link to this post
Subject: OrphansWanted
I'm using the OrphansWanted plugin and I have created a page with ~~ORPHANSWANTED:all~~
It lists the three sections okay. Checking the orphaned pages it shows 92 pages orphaned but checking those pages and clicking the Backlinks icon, most of them do show one or more backlinks listed. Can someone offer any guidance or input on this?
This post was edited on 2017-09-05, 18:25 by rburn99.
topic: @All permission problem  in the forum: General Help and Support Installation and Configuration
Avatar
rburn99 #11
Member since Mar 2017 · 34 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 57736
oops.. my bad. Yes, thanks MartinR for the case sensitive tip  :-D
topic: Controlling line spacing  in the forum: General Help and Support Templates and Layout
Avatar
rburn99 #12
Member since Mar 2017 · 34 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 57914
I was hoping to be able to control the amount of vertical space a blank line uses. Like setting the Leading/Kerning space.
topic: Table alternating row colors  in the forum: General Help and Support Templates and Layout
Avatar
rburn99 #13
Member since Mar 2017 · 34 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 57930
sheesh  Thanks for the help!
topic: Table alternating row colors  in the forum: General Help and Support Templates and Layout
Avatar
rburn99 #14
Member since Mar 2017 · 34 posts
Group memberships: Members
Show profile · Link to this post
Subject: Table alternating row colors
I put the code below in my userall.css file. I verified this file is being processed (the ul setting is being applied as well as a body background color test I had put in temporarily) But still no go on the tables.


tr:nth-child (odd) {
    background: #ccc !important;
}

ul {
list-style-image: url('conf\myimages\bullet.png') !important;
}
topic: How to change the bullet from grey square to blue circle  in the forum: General Help and Support Templates and Layout
Avatar
rburn99 #15
Member since Mar 2017 · 34 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 57925
Thanks for the tip. I put it in conf/userall.css Hopefully that's right. (was reading about the separate stylesheets for screen, printer, and all)
Close Smaller – Larger + Reply to this post:
Special characters:
Page:  1  2  3  next 
Special queries
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2020-01-18, 08:20:41 (UTC +01:00)