Not logged in. · Lost password · Register

All posts by SwissGeorge (4)

topic: Help improving the plugin pages (Making us of the plugin survey data)  in the forum: Community dokuwiki.org
SwissGeorge #1
Member since Oct 2017 · 4 posts · Location: area of zurich - switzerland
Group memberships: Members
Show profile · Link to this post
Subject: namespace templates
hi
i dropped onto your thread while trying to understand dokuwiki. i'm so browsing and reading a lot.

well, https://www.dokuwiki.org/start?id=namespace_templates seems to me a interesting entry.
no, i'm not focused on translations which are not up-to-date.

the section @GROUPS@ support is more obfuscating. a suggestion brought in 2010 is not transfered into the distribution code. patch information is wrong meanwhile and there is no explanation why. i also had a glimps at common.php.

my question is no ... what are governance constraints of dukuwiki to this case?

how could i bring some help in order to get it straight.

btw: there is an other intersting idea about symlinking in german translation ... dokuwiki should work with it or drop it.

have fun
topic: users.auth.php smd5 and ssha (different encryption results for smd5 / ssha)  in the forum: General Help and Support Installation and Configuration
SwissGeorge #2
Member since Oct 2017 · 4 posts · Location: area of zurich - switzerland
Group memberships: Members
Show profile · Link to this post
Subject: users.auth.php smd5 and ssha
hi (working with 2017-02-19b "Frusterick Manners")

i configured
$conf['authtype']       = 'authplain';
$conf['passcrypt']      = 'smd5';

encrypted <gugus123> with https://sprhost.com/tools/SMD5.php and added it's result as an entry to users.auth.php
oisadm:$1$e00dd38f$LsVwqiNMU4nYK89k8zKKI/:me:me@mydomain:admin,user
-> worked.

i then was encrypting <gugus123> with slappasswd -h {SMD5} and changed the entry. (slappasswd is provided by openldap see https://linux.die.net/man/8/slappasswd)
oisadm:yoE7ZH437opsxqeSW4JlTzIkWtp1qzU2:me:me@mydomain:admin,user
-> failed

intending to switch to authldap i also had a try with SSHA. i was using slappasswd -h {SSHA} again
changed the entries in dokuwiki and users.auth.php
$conf['passcrypt']      = 'ssha';
oisadm:yoE7ZH437opsxqeSW4JlTzIkWtp1qzU2:me:me@mydomain:admin,user
-> failed

what did i do wrong?
do i have to learn SSHA!=SSHA and SMD5!=SMD5 ?
what are the conditions to have it working? am i forced to use the right encryption tool in order to get it matched?

have fun
This post was edited on 2017-10-21, 20:21 by SwissGeorge.
topic: solved: css.php caching ? (changes in userstyle.css not processed)  in the forum: General Help and Support General Stuff
SwissGeorge #3
Member since Oct 2017 · 4 posts · Location: area of zurich - switzerland
Group memberships: Members
Show profile · Link to this post
In reply to post ID 58492
hi,
i was playing with dbglog and learned quiet a lot. after deleting all cache files it worked also with changed names.

it's possible i was mistaken. thank you for help anyway. i'm aware no where to look now if this case happens again.
topic: solved: css.php caching ? (changes in userstyle.css not processed)  in the forum: General Help and Support General Stuff
SwissGeorge #4
Member since Oct 2017 · 4 posts · Location: area of zurich - switzerland
Group memberships: Members
Show profile · Link to this post
Subject: solved: css.php caching ?
hi (working with 2017-02-19b "Frusterick Manners")

played with userstyles.css
@font-face {
  font-family: "SpaceAge";
  src: url("lib/styles/SpaceAge.woff") format("woff");
  font-weight: normal; }

.myclass {
    font-family: "SpaceAge";
    font-size: 150%;
}
used this in tpl_header.php
'<img src="'.$logo.'" '.$logoSize[3].' alt="" /> <span class="myclass">'.$conf['title'].'</span>','accesskey="h" title="[H]"');
worked as expected, well not on first hit. i had to play for a while.

i then just rename class name <.myclass> to <.oislogo> in both files. and it does not work any more. i detected class in css is still named <.myclass>.

as mentioned in prior threads and explained in <https://www.dokuwiki.org/devel:caching> ... i called <http://192.168.1.101/dokuwiki/lib/exe/css.php?purge=true>
and i still find the old entries
<@font-face{font-family:"CenturyGothic";src:url("/dokuwiki/lib/styles/CenturyGothic.woff") format("woff");font-weight:normal;}@font-face{font-family:"SpaceAge";src:url("/dokuwiki/lib/styles/SpaceAge.woff") format("woff");font-weight:normal;}.myclass{font-family:"SpaceAge";font-size:150%;}}>

myclass does nowhere exist any more by the way. yes i made sure browser cache is empty and no errors were reported.
access.log <mydomain.ch:80 192.168.1.155 - - [21/Oct/2017:11:12:11 +0200] "GET /dokuwi
ki/lib/exe/css.php?purge=true HTTP/1.1" 200 40958 "-" "Mozilla/5.0 (Windows NT 6
.1; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0">
error.log <[Sat Oct 21 11:12:11.760794 2017] [rewrite:trace1] [pid 27446] mod_rewrite.c(480
): [client 192.168.1.155:10470] 192.168.1.155 - - [192.168.1.101/sid#1e38dd8][ri
d#2070760/initial] [perdir /opt/dokuwiki-1.5.10/] pass through /opt/dokuwiki-1.5
.10/lib/exe/css.php>

how do i have to understand this behavior? please advice ...
This post was edited on 2017-10-21, 14:54 by SwissGeorge.
Close Smaller – Larger + Reply to this post:
Special characters:
Special queries
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2019-05-26, 17:38:38 (UTC +02:00)