Not logged in. · Lost password · Register

All posts by GTNman (7)

topic: Graphic buttons in editor (Display problem)  in the forum: General Help and Support Installation and Configuration
Avatar
GTNman #1
Member since Nov 2006 · 7 posts
Group memberships: Members
Show profile · Link to this post
this happened to me as well. Clearing my browser cache seemed to do the trick though.
topic: Lighty w/ virtual host and rewrite issue. (Lighttpd and Dokuwiki)  in the forum: General Help and Support Server Setup
Avatar
GTNman #2
Member since Nov 2006 · 7 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 1478
I resolved the issue by removing all the /wiki/ instances in the rewrite.

now the site works with host http://wiki but not http://gtn-lnx3/wiki

how can i make it so both urls work?


works a'ok- modified my lighttpd and seems to work.
This post was edited on 2006-12-01, 21:29 by GTNman.
topic: Useslash setting not working properly.  in the forum: General Help and Support Server Setup
Avatar
GTNman #3
Member since Nov 2006 · 7 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 1498
removed the line from my lighttpd.conf but still not working as it should. ??

I think it is working, however I think I may have made a mistake in terms of my understanding.

I had stored all of my wiki entries in the root of dokuwiki, outside of any namespaces.  Once I created a namespace, the useslash function was working properly.

Just took some time for me to hash it out.

Thanks andi!~
This post was edited on 2006-12-02, 00:00 by GTNman.
topic: Useslash setting not working properly.  in the forum: General Help and Support Server Setup
Avatar
GTNman #4
Member since Nov 2006 · 7 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 1493
i think i posted the wrong rewrite?  does this one look better?

here is a copy of my lighttpd.conf -- > link

#### dokuwiki rewrite

url.rewrite-once = (
                    "^/wiki/(/|index.php)?$" => "/wiki/doku.php",
                    "^/wiki/lib/(.*)/?$" => "/wiki/lib/$1",
                    "^/wiki/_media/(.*)?\?(.*)$" => "/wiki/lib/exe/fetch.php?media=$1&$2",
                    "^/wiki/_media/(.*)$" => "/wiki/lib/exe/fetch.php?media=$1",
                    "^/wiki/_detail/(.*)?\?(.*)$" => "/wiki/lib/exe/detail.php?media=$1&$2",
                    "^/wiki/_detail/(.*)?$" => "/wiki/lib/exe/detail.php?media=$1",
                    "^/wiki/_export/([^/]+)/(.*)$" => "/wiki/doku.php?do=export_$1&id=$2",
                    "^/wiki/(?!doku.php|feed.php|robots.txt|sitemap.xml.gz)(.*)\?(.*)/?$" => "/wiki/doku.php?id=$1&$2",
                    "^/wiki/(?!doku.php|feed.php|robots.txt|sitemap.xml.gz)(.*)/?$" => "/wiki/doku.php?id=$1",
                  )


#### Added for dokuwiki security

# subdir of dokuwiki
var.basedir = "/wiki/"
# make sure those are always served through fastcgi and never as static files
static-file.exclude-extensions = ( ".php" )

# deny access completly to these
$HTTP["url"] =~ "/\.ht" { url.access-deny = ( "" ) }
$HTTP["url"] =~ "/_ht" { url.access-deny = ( "" ) }
$HTTP["url"] =~ "^" + basedir + "wiki/bin/"  { url.access-deny = ( "" ) }
$HTTP["url"] =~ "^" + basedir + "wiki/data/" { url.access-deny = ( "" ) }
$HTTP["url"] =~ "^" + basedir + "wiki/inc/"  { url.access-deny = ( "" ) }
$HTTP["url"] =~ "^" + basedir + "wiki/conf/" { url.access-deny = ( "" ) }
topic: Useslash setting not working properly.  in the forum: General Help and Support Server Setup
Avatar
GTNman #5
Member since Nov 2006 · 7 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 1476
I am using lighty version:  lighttpd/1.4.11

vhosts config:

$HTTP["host"] == "localhost" { server.document-root = "/var/www"
url.rewrite = ( "^/$" => "index.php", "^([^.]+)$" => "index.php/$1" )
server.indexfiles = ( "index.php", "index.html" )
index-file.names = ( "index.php", "index.html", "index.htm", "default.htm" )
  fastcgi.server = (".php" =>
        ("localhost" =>
           ("socket" => "/tmp/phpadmin.socket",
                "bin-path" => "/usr/bin/php5-cgi -c /etc/php5/cgi/php.ini",
                "bin-environment" => (
                "PHP_FCGI_CHILDREN" => "8",
                "PHP_FCGI_MAX_REQUESTS" => "500"
                                        ) )))
}

(i believe that is my vhost block)
topic: Lighty w/ virtual host and rewrite issue. (Lighttpd and Dokuwiki)  in the forum: General Help and Support Server Setup
Avatar
GTNman #6
Member since Nov 2006 · 7 posts
Group memberships: Members
Show profile · Link to this post
Subject: Lighty w/ virtual host and rewrite issue.
Here we go.
Server config
Lighttpd
PHP5

 I have doku wiki installed running in the physical path of /var/www/wiki (http://server/wiki) and I am using URL rewriting.  What I am trying to do is use virtual hosts to allow my users to access the site using the url http://wiki.

I have included the following line in my lighttpd.conf

$HTTP["host"] = "wiki" { server.document-root = "/var/www/wiki/" }

However, when I load the page, no media images display and the wiki links dont work properly.  If I turn [userewrite] to a 0 or 2 the site works fine using the virtual host.

Here is a the rewrite that I am using in my lighthttpd.conf

#### dokuwiki rewrite

url.rewrite-once = (
                    "^/wiki/(/|index.php)?$" => "/wiki/doku.php",                                                        
                    "^/wiki/lib/(.*)/?$" => "/wiki/lib/$1",
                    "^/wiki/_media/(.*)?\?(.*)$" => "/wiki/lib/exe/fetch.php?media=$1&$2",
                    "^/wiki/_media/(.*)$" => "/wiki/lib/exe/fetch.php?media=$1",
                    "^/wiki/_detail/(.*)?\?(.*)$" => "/wiki/lib/exe/detail.php?media=$1&$2",
                    "^/wiki/_detail/(.*)?$" => "/wiki/lib/exe/detail.php?media=$1",
                    "^/wiki/_export/([^/]+)/(.*)$" => "/wiki/doku.php?do=export_$1&id=$2",
                    "^/wiki/(?!doku.php|feed.php|robots.txt|sitemap.xml.gz)(.*)\?(.*)/?$" => "/wiki/doku.php?id=$1&$2",
                    "^/wiki/(?!doku.php|feed.php|robots.txt|sitemap.xml.gz)(.*)/?$" => "/wiki/doku.php?id=$1",
                  )

I am thinking there is something in the rewrite thats throwing it for a loop. Any input wouldbe much appreciated.
This post was edited on 2006-11-30, 00:03 by GTNman.
topic: Useslash setting not working properly.  in the forum: General Help and Support Server Setup
Avatar
GTNman #7
Member since Nov 2006 · 7 posts
Group memberships: Members
Show profile · Link to this post
Subject: Useslash setting not working properly.
I am running dokuwiki w/ PHP5 and lighttpd.  I have just implemented the rewrite as per the provided code.

I want to use the rewrite so that useslash is disabled.  However ever since the rewrite implementation I cannot get it working using the ':' only '/'

I am sure that it is something simple that I have missed.  Can anyone shed some light?
Close Smaller – Larger + Reply to this post:
Special characters:
Special queries
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2019-12-14, 08:27:52 (UTC +01:00)