Not logged in. · Lost password · Register

All posts by kizh (5)

topic: everything works but creating namespaces  in the forum: General Help and Support Installation and Configuration
Avatar
kizh #1
Member since Dec 2006 · 5 posts
Group memberships: Members
Show profile · Link to this post
Subject: everything works but creating namespaces
I have this problem where I can't create namespaces within dokuwiki, only manually through FTP.  Everything else works fine.  What are some things I can check to get this to work?  I'm using the PHP safemode hack.

thanks
topic: Htaccess host problem with install  in the forum: General Help and Support Installation and Configuration
Avatar
kizh #2
Member since Dec 2006 · 5 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 1575
the wiki has some nice access control management features that you can restrict people from reading/editing pages.  Although I'm not sure if it needs htaccess to work properly.  I'm really impressed with what they've done here, don't give up easily if you need flat files cause you don't have access to some sort of database!
This post was edited on 2006-12-12, 06:49 by kizh.
topic: Htaccess host problem with install  in the forum: General Help and Support Installation and Configuration
Avatar
kizh #3
Member since Dec 2006 · 5 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 1563
I had similar problem, when I installed.  what I did was go through and create all the document cache folders in FTP and then it would write correctly.  You have to do the same thing for the data dir and anything under it IIRC.\

About not having .htaccess, you can move the data directory outside of your www directory to secure it.   http://wiki.splitbrain.org/wiki:security  I'm not sure you have FTP access to your account or not.  I hope this helps, keep in mind I'm a noob too and am having my own problems.  Hopefully someone will correct me if I'm wrong about about something.

Also, you might want to have a look at the safemode hack if you haven't already. http://wiki.splitbrain.org/wiki:safemodehack
This post was edited on 2006-12-11, 19:48 by kizh.
topic: help a tard with safemode hack and root  in the forum: General Help and Support Installation and Configuration
Avatar
kizh #4
Member since Dec 2006 · 5 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 1540
well I asked my ISP to make sure, and my root is indeed /home/user

I just can't get dokuwiki to write directories for some reason, creating pages is A-OK.  It must be something else
topic: help a tard with safemode hack and root  in the forum: General Help and Support Installation and Configuration
Avatar
kizh #5
Member since Dec 2006 · 5 posts
Group memberships: Members
Show profile · Link to this post
Subject: help a tard with safemode hack and root
I just can't get this right, and I'm wondering if it is why everything is working except dokuwiki can't create name spaces.  I have to manually add them through ftp.

when I ftp into my server, I am at /home/user.  in this directory I have 'public_html' and 'mail' directories.  My dokuwiki resides in public_html/wiki

now, I can CD up to root with 'bin' 'boot' 'dev' 'etc' and others.  (I assume this is root)

do I just leave the root info blank then for safemode hack?

I've tried different things but just can not get dokuwiki to write directories.  I've had to create them by hand (including the cache directories)

Am I suffering from another problem?

and input is very welcome, I'm learning but feel like I hit a wall here
Close Smaller – Larger + Reply to this post:
Special characters:
Special queries
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2019-12-06, 09:14:08 (UTC +01:00)