Not logged in. · Lost password · Register
Page:  1  2  3 ... 301  302  303  next 

All posts by turnermm (4541)

topic: Default theme and images on new install not working  in the forum: General Help and Support Installation and Configuration
Avatar
turnermm (Moderator) #1
Member since Oct 2009 · 4629 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
I looked at your attached problem sites.  It seems as if you've solved your problem.  What your attached image shows is a CSS problem.  The css may not be loading or is corrupt. This can occur when a plugin has faulty css.
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
topic: Syntax plugin: pass data from PHP to JavaScript without an inline script  in the forum: General Help and Support Development
Avatar
turnermm (Moderator) #2
Member since Oct 2009 · 4629 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
In reply to post ID 66236
Probably I got a bit carried away. It is cached on the edit.  So, it would depend on what you are doing as to whether that would be adequate.
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
topic: Syntax plugin: pass data from PHP to JavaScript without an inline script  in the forum: General Help and Support Development
Avatar
turnermm (Moderator) #3
Member since Oct 2009 · 4629 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
In reply to post ID 66232
only in the handle method, not in render.
The reason for this is that the renderer is called after the javascript has been sent to the browser.
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
topic: Syntax plugin: pass data from PHP to JavaScript without an inline script  in the forum: General Help and Support Development
Avatar
turnermm (Moderator) #4
Member since Oct 2009 · 4629 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
In reply to post ID 66223
I am not entirely clear where this data originates.  Is it dynamically developed in the syntax plugin or does it exist outside of the syntax plugin? And is it needed in the syntax plugin, or can it be passed to jQuery independently of the syntax plugin?

Just some observations which might be of use:
1. You can set JSINFO values in an action plugin (DOKU_WIKI_STARTED) that can be accessed in a syntax plugin.  If you take this route, you have to handle it judiciously, because it could get rather messy, since syntax plugins are called multiple times during rendering, and so anything you would be doing with JSINFO could possibly be repeated with each call. So, this should be handled under the appropriate state--Enter, Exit, Matched,

2. As for using Ajax, these are calls from Javascript to php, and so the data you are accessing must already be settled,  not dynamic, i.e. not created at the time of the syntax rendering.  If that's the case, then Ajax is fine, as long as you can run it asynchronously, which is the default--synchronous calls are deprecated.

3.  You can also set JSINFO values in a syntax plugin. It's not something I've used myself, so I did some tests and found that this works only in the handle method, not in render.   But you can create class variables that can be set in the handle method and accessed in render.
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
topic: Media Manager no longer works as it did  in the forum: General Help and Support Features and Functionality
Avatar
turnermm (Moderator) #5
Member since Oct 2009 · 4629 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
In reply to post ID 66136
If you create a directory using the Filebrowser, it will not show up in the Media Manager unless you also create a page in that directory.

It turns out that this is not correct.  I just did a test and images in a folder created by the filebrowser do show up in the Media Manager.
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
topic: Media Manager no longer works as it did  in the forum: General Help and Support Features and Functionality
Avatar
turnermm (Moderator) #6
Member since Oct 2009 · 4629 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
In reply to post ID 66131
Judging from your terminology, I assume you are using ckgedit. There are two, really three, different issues here. But first, let's get our terms straight.  There is the Dokuwiki Media Manager and the ckgedit Filebrowser.

Issue 1/2
You cannot create directories using the dokuwiki Media Manager, but you can with the Filebrowser.  If you are not able to create a directory using the Filebrowser, then there is probably a permissions problem, but make sure you are using the latest version of ckgedit. If you create a directory using the Filebrowser, it will not show up in the Media Manager unless you also create a page in that directory.

Issue 3
the Media Manager and the 'Insert Image/Browse Server" locations are different
There must some kind of mis-configuration.  And there is not enough to go by for me to make a call on this.  What does "[root]" mean?  Is root "data/media"?  In the meantime, you have the option in ckgedit of using the Dokuwiki Media Manager and linkwiz by clicking on the "DW Filebrowser" button.  I would do that until and unless the mis-configuration is solved.
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
This post was edited on 2019-05-20, 17:10 by turnermm.
topic: Account removal  in the forum: Offtopic Forum Help
Avatar
turnermm (Moderator) #7
Member since Oct 2009 · 4629 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
In reply to post ID 66097
Removed your account: bobaroo
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
topic: default heading color on template (sprintdoc) + plugin (ckgedit)  in the forum: General Help and Support Templates and Layout
Avatar
turnermm (Moderator) #8
Member since Oct 2009 · 4629 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
In reply to post ID 65785
I've added a new feature which enables you to create and install a template-based style sheet for the ckeditor's editing window.  See  https://www.dokuwiki.org/plugin:ckgedit:configuration#styl…
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
topic: SPAM Alerting (current thread)  in the forum: Offtopic Forum Help
Avatar
turnermm (Moderator) #9
Member since Oct 2009 · 4629 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
In reply to post ID 65986
Removed spam from wiki page
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
topic: ePub Extension  Link/Bookmarks to Titles (Links/Bookmarks to titles)  in the forum: General Help and Support Plugins
Avatar
turnermm (Moderator) #10
Member since Oct 2009 · 4629 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
In reply to post ID 65943
I don't understand your question, which may be perfectly clear to you who are working with it every day but not to me as an outsider.  What are the epub fix tools?  Are you talking about the admin panel? And what is meant by each page listed fully?  Where?
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
topic: ePub Extension  Link/Bookmarks to Titles (Links/Bookmarks to titles)  in the forum: General Help and Support Plugins
Avatar
turnermm (Moderator) #11
Member since Oct 2009 · 4629 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
In reply to post ID 65939
There is limited support for namespaces, probably not what you need: https://www.dokuwiki.org/plugin:epub#namespaces.

As for blank pages, if by that you mean empty pages, they do not exist in dokuwiki.  An empty page is removed.

Epub can't read indexmenu html, or any html, for that matter. 

If you need an enhanced table of contents, see: https://www.dokuwiki.org/plugin:epub#enhanced_table_of_con…
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
topic: ePub Extension  Link/Bookmarks to Titles (Links/Bookmarks to titles)  in the forum: General Help and Support Plugins
Avatar
turnermm (Moderator) #12
Member since Oct 2009 · 4629 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
In reply to post ID 65937
I'm afraid I'm not sure what you are asking.  And I'm not sure what this refers to:
the hard coded pages that epub requires

In what way hard coded and what do you mean by required?
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
topic: ePub Extension  Link/Bookmarks to Titles (Links/Bookmarks to titles)  in the forum: General Help and Support Plugins
Avatar
turnermm (Moderator) #13
Member since Oct 2009 · 4629 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
In reply to post ID 65928
I don'tknow what's happening on your site, but I just test with the latest epub and it seems to be working as always.  It treats as external links local wiki pages which are not included in the epub book itself.
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
This post was edited 2 times, last on 2019-05-09, 18:11 by turnermm.
topic: ckgedit cannot save changes / page replaced with "false"  in the forum: General Help and Support Plugins
Avatar
turnermm (Moderator) #14
Member since Oct 2009 · 4629 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
In reply to post ID 65865
Have you tried the fix yet?  If not, please do.
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
topic: default heading color on template (sprintdoc) + plugin (ckgedit)  in the forum: General Help and Support Templates and Layout
Avatar
turnermm (Moderator) #15
Member since Oct 2009 · 4629 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
In reply to post ID 65871
I've been thinking about this and may have hit on a way to accommodate it.
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
Close Smaller – Larger + Reply to this post:
Special characters:
Page:  1  2  3 ... 301  302  303  next 
Special queries
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2019-05-27, 14:03:34 (UTC +02:00)