Not logged in. · Lost password · Register

All posts by escapingUser (8)

topic: Configuring single sign-on with IIS and Active Directory (Something is wrong with my set up.)  in the forum: General Help and Support Installation and Configuration
Avatar
escapingUser #1
Member since Aug 2018 · 8 posts
Group memberships: Members
Show profile · Link to this post
Subject: Configuring single sign-on with IIS and Active Directory
I am trying to get single sign on working with active directory.

In IIS if I have Windows Authentication enabled and Anonymous Authentication enabled, I can view the page, and log in with my windows credentials.

If I disable Anonymous Authentication and try to use my windows credentials it does not work (gives no error, just brings up sign in box again.)

php 7.2 is installed and php_ldap is enabled.

In internet options the allowing the passing of authentication on intranet sites is enabled.

local.protected.php is below:
  $conf['authtype']            = 'authad';
  $conf['useacl']            = 1;
 
  // configure your Active Directory data here
  $conf['auth']['authad']['account_suffix']        = '@domain.com';
  $conf['auth']['authad']['base_dn']            = 'DC=domain,DC=com';
  $conf['auth']['authad']['domain_controllers']    = 'server.domain.com';
 
  // Enable SSO
  $conf['auth']['authad']['sso']                = 1;
  $conf['auth']['authad']['admin_username']        = 'user';
  $conf['auth']['authad']['admin_password']        = 'pass';

 
  $conf['auth']['authad']['real_primarygroup']    = 1;

  $conf['auth']['authad']['use_ssl']            = 0;
  $conf['auth']['authad']['use_tls']            = 0;

  // Admin
  $conf['manager']                            = 'admin';
  $conf['superuser']                         = 'alist,ofpeople';
topic: File/media upload "Failed"  in the forum: General Help and Support Installation and Configuration
Avatar
escapingUser #2
Member since Aug 2018 · 8 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 64942
Thanks for the replies guys.

png's are fine yeah. I get the same issues on jpg also (which most images on the site are.) Nothing corrupted about them or weird in their name. Usually the images are just saved from Snipping tool (the wikis are used for internal documentation), so haven't been through anything crazy.

Names are unique, and I get the same issue even if I select 'overwrite existing files'

As for the ones that do vs don't. Nothing. In fact usually a file that fails to upload one or twice or more may in fact work on the 3rd or 4th try. Or it may not. 

And Like I said the problems are only on the one which is configured for single sign on, so I'm thinking the problem is there.

Michaelsy: True, the files may have had capital letters or spaces in the names when manually adding them to the media directory. Will have to remember that in the future! Wish I didn't have to though, I'd rather just use the uploader.
topic: File/media upload "Failed"  in the forum: General Help and Support Installation and Configuration
Avatar
escapingUser #3
Member since Aug 2018 · 8 posts
Group memberships: Members
Show profile · Link to this post
Subject: File/media upload "Failed"
I currently run 2 locally hosted wikis, both on IIS. One of which is configured with single sign on for the domain.

Uploading images to the non-SSO wiki works just fine. I have no issues there.

However the one configured with SSO gives me no end of trouble. Sometimes image uploading works, sometimes it doesn't. Searching all the threads of people who have similar issues hasn't helped, my max upload size is fine. The files are small anyways.

My ACL is very liberal, anyone should be able to upload.

I don't even know where to look at this point.

I tried just manually adding the images to the media folder on the computer that's hosting the site but that was no good either. Dokuwiki complained and wouldn't recognise them.
[Image: https://i.imgur.com/XGvxlAt.jpg]
topic: Notification Email subject line  in the forum: General Help and Support Installation and Configuration
Avatar
escapingUser #4
Member since Aug 2018 · 8 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 63545
Found the final [wikititle], it was in Discussion's 'action.php' file.

replaced "$subject_notify = '['.$conf['title'].'] '.$this->getLang('mail_newcomment');"

with
$mysubstr = mb_substr($comment['raw'], 0, 12);
$subject_notify = $this->getLang('mail_newcomment').$mysubstr;

So that the subject is something like "News Item: here is a com"
where the body is "here is a comment about some stuff"

Now the subject will at least somewhat resemble what the item is about.
topic: Notification Email subject line  in the forum: General Help and Support Installation and Configuration
Avatar
escapingUser #5
Member since Aug 2018 · 8 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 63536
Managed to get rid of the leading '[]'.

They were located in the Mailer.class.php where it sets $prefix.

I don't like that I had to edit that file to do it but I know nothing of PHP so am just kind of fumbling around.

Still not sure where the Discussion plugin adds the wiki title to the subject though.
topic: Notification Email subject line  in the forum: General Help and Support Installation and Configuration
Avatar
escapingUser #6
Member since Aug 2018 · 8 posts
Group memberships: Members
Show profile · Link to this post
Subject: Notification Email subject line
We use dokuwiki as an internal knowledge base and I have a page with the following setup:

Discussion plugin
Automatic Subscription Management

This page is used for news so when a new comment is made email is sent to all members of a group.

The mail works fine but I'm having trouble formatting the email. Particularly the subject line.

At first the subjects of the emails were something like "[wikititle][wikititle]New Comment".

I've got it down to "[][wikititle]"

I'm not sure where the second 'wikititle' is coming from, and I'd like to get rid of those pesky '[]'

Can anyone point me in the right direction?
topic: Configuring single sign-on IIS 7  in the forum: General Help and Support Installation and Configuration
Avatar
escapingUser #7
Member since Aug 2018 · 8 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 62353
I've mostly sorted things now. For those in the future with the same issue:

First step is to enable debugging and see what's going on - mine said that the PHP LDAP plugin was not installed.

When I installed PHP the PHP manager was unable to be installed for some reason and I couldn't get it to install for love nor money.
However, over here: https://www.phpmanager.xyz/ there is an up to date version you can install.

Installed that and can then see that the php-ldap.dll was not enabled. I enabled it and yay it all works fine now :)
topic: Configuring single sign-on IIS 7  in the forum: General Help and Support Installation and Configuration
Avatar
escapingUser #8
Member since Aug 2018 · 8 posts
Group memberships: Members
Show profile · Link to this post
Subject: Configuring single sign-on IIS 7
(Preface: definite noob with this, don't really know what I'm doing)

What I'm trying to do:
Host an internal wiki for all our users to add or edit.
To get people to use the site I don't want them to go through an account creation process and have to bother with passwords and usernames.

However, we need to be able to keep track of who edits the page so a single sign on using their windows credentials seems best.

What's currently set up:
Dokuwiki is installed and running fine using IIS, Windows server 2016.
Php 5.6 is installed.
Windows authentication is enabled and anonymous  is disabled.

local.protected.php has:
<?php
  // general DokuWiki options
  $conf['useacl']         = 1;
  $conf['disableactions'] = 'register';
  $conf['authtype']       = 'authad';
  // configure your Active Directory data here
  $conf['auth']['authad']['account_suffix']     = '@abc.co.uk';
  $conf['auth']['authad']['base_dn']            = 'DC=abc,DC=co,DC=uk';
  $conf['auth']['authad']['domain_controllers'] = 'domainController'; //multiple can be given
  $conf['auth']['authad']['admin_username']        = 'adminusername';
  $conf['auth']['authad']['admin_password']        = 'adminpassword';
  $conf['auth']['authad']['sso']                = 1;
  $conf['plugin']['authad']['real_primarygroup']  = 1;
  $conf['plugin']['authad']['recursive_groups']   = 1;

And I've set internet options to allow automatic login with current username and password in the intranet.

What's happening:
I am getting a username/password logon box which accepted my windows credentials (IIS's doing I guess) but it's not doing it automatically.

Additionally, if local.protected.php is there I get the messages:
"User authentication is temporarily unavailable. If this situation persists, please inform your Wiki Admin."

"No ACL setup yet! Denying access to everyone."

I'm at a bit of a loss.. Not sure what to try or what I'm missing.
Close Smaller – Larger + Reply to this post:
Special characters:
Special queries
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2019-11-20, 01:20:00 (UTC +01:00)