Not logged in. · Lost password · Register

All posts by rwshaun (3)

topic: Error 403 + 404 after farm setup via farmer plugin  in the forum: General Help and Support Installation and Configuration
Avatar
rwshaun #1
Member since Nov 2018 · 3 posts
Group memberships: Members
Show profile · Link to this post
Thanks for all your answers and efforts.

The .htaccess file with the mentioned content (with an extra rewrite flag of [QSA,DPI] is present in the directory
   /farmer/

The directory
   /barn/
does not contain a .htaccess file. Neither do the subdirectories of /barn/.

The setup using the farmer plugin has been done in the htaccess style, not the virtual host style.

The farmer/inc contains a preload.php. The content is different, though, as it has been added by the farmer plugin. My preload.php actually only includes another php file: /../lib/plugins/farmer/DokuWikiFarmCore.php

Everything is there, is present as described by you, it seems. What could be still wrong? The farmer plugin offers for configuration a 'Farmer Host Name' - I set mywiki.foo.com and a 'Base Domain for subdomain Animals' - I set myfarm.foo.com (pointing to the /barn/). Maybe there's something wrong with that setting?

It still puzzles me that I'm getting a 403, not a 404.
topic: Error 403 + 404 after farm setup via farmer plugin  in the forum: General Help and Support Installation and Configuration
Avatar
rwshaun #2
Member since Nov 2018 · 3 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 63513
The directory setup is as you describe it for .htaccess method.

It looks to me as if I lack a .htaccess file somewhere because if I use an url like myfarm.foo.com/dog/ I get a 403. Note: myfarm.foo.com already points to the barn directory. I can as well access it with mydomain.foo.com/barn/dog/ - same: 403. As soon as I make a spelling error like myfarm.foo.com/doggy/ I get a 404.
topic: Error 403 + 404 after farm setup via farmer plugin  in the forum: General Help and Support Installation and Configuration
Avatar
rwshaun #3
Member since Nov 2018 · 3 posts
Group memberships: Members
Show profile · Link to this post
Subject: Error 403 + 404 after farm setup via farmer plugin
I am using dokuwiki since a while and am quite happy with it. Now I wanted to put pages for a special subject aside in a separate wiki. I installed the farmer plugin and set up farming with default settings (htaccess it was, I think).

But how do I access the wiki for the animal?

The farmer host name is (simplified): mywiki.foo.com
The base domain for subdomain animals is myfarm.foo.com

The info page of the farmer plugin shows me the newly set up animal: 'dog'. The link is shown as dog.myfarm.foo.com. This link, however, delivers a 404.

When I try to access the animal via the url: myfarm.foo.com/dog/ I get a 403.

I checked the directory for a .htaccess file. the (sub)directories for myfarm.foo.com do not contain any. The dokuwiki directory of mywiki.foo.com does contain one, modified by the farmer plugin. I tried to copy this to the animal directory, but that didn't help.

What am I missing out?

Regards
Rudi
Close Smaller – Larger + Reply to this post:
Special characters:
Special queries
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2019-11-20, 01:13:09 (UTC +01:00)