Not logged in. · Lost password · Register

All posts by Denissen (2)

topic: [SOLVED] No LDAP login after PHP update  in the forum: General Help and Support Installation and Configuration
Avatar
Denissen #1
Member since Nov 2018 · 2 posts
Group memberships: Members
Show profile · Link to this post
Sometimes things are just too easy...

I updated the authldap-plugin we used from Version 2013-04-19 to 2015-07-13 and now everything works.
topic: [SOLVED] No LDAP login after PHP update  in the forum: General Help and Support Installation and Configuration
Avatar
Denissen #2
Member since Nov 2018 · 2 posts
Group memberships: Members
Show profile · Link to this post
Subject: [SOLVED] No LDAP login after PHP update
Hello,

we updated our PHP installation from PHP5 to PHP7.0. After the update, no login is possible with LDAP accounts. Prior the PHP update logins were possible.

This is our conf/local.php:
  1. <?php
  2.  
  3. /* General */
  4. $conf['title']       = 'Univention Dokuwiki';        //what to show in the title
  5. $conf['lang']        = 'de';
  6. $conf['showuseras']  = 'username';
  7. $conf['userewrite']  = 1;
  8. $conf['updatecheck'] = 0;
  9. $conf['license']     = '';
  10.  
  11. /* Auth & Access */
  12. $conf['useacl']      = 1;
  13. $conf['openregister']= 0;
  14. $conf['superuser']   = '@Domain Admins';
  15.  
  16. $conf['authtype']                    = 'authldap';
  17. $conf['plugin']['authldap']['server']      = 'ldaps://nissedal.knut.univention.de:7636';
  18. $conf['plugin']['authldap']['version']     = 3;
  19. $conf['plugin']['authldap']['starttls']    = 0;
  20. $conf['plugin']['authldap']['usertree']    = 'cn=users,dc=knut,dc=univention,dc=de';
  21. $conf['plugin']['authldap']['grouptree']   = 'cn=groups,dc=knut,dc=univention,dc=de';
  22. $conf['plugin']['authldap']['userfilter']  = '(&(uid=%{user})(objectClass=posixAccount))';
  23. $conf['plugin']['authldap']['groupfilter'] = '(&(objectClass=posixGroup)(|(gidNumber=%{gid})(memberUID=%{user})))';
  24. $conf['plugin']['authldap']['mapping']['mail'] = 'mailPrimaryAddress';
  25.  
  26. $conf['allowdebug']  = 1;                 //make debug possible, disable after install! 0|1
  27. $conf['plugin']['authldap']['debug']      = true; //es gibt false und true
  28.  
  29. ?>

We use the following version:
2018-04-22a "Greebo"

The following PHP packages are installed:
  • php7.0
  • php7.0-cli
  • php7.0-common
  • php7.0-curl
  • php7.0-gd
  • php7.0-intl
  • php7.0-json
  • php7.0-ldap
  • php7.0-mbstring
  • php7.0-mysql
  • php7.0-opcache
  • php7.0-readline
  • php7.0-xml

The base system is a Debian 9.

When I look at the traffic on the LDAP server with tcpdump, I can see that there is a connection from the DW server with the LDAP server.

Do you need further info on helping me resolve this issue?

Cheers,
Timo
This post was edited on 2018-11-09, 13:35 by Denissen.
Close Smaller – Larger + Reply to this post:
Special characters:
Special queries
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2019-11-20, 01:15:19 (UTC +01:00)