Not logged in. · Lost password · Register

All posts by rogerjames (15)

topic: Unable to upload mp4 files through media manager  in the forum: General Help and Support Installation and Configuration
Avatar
rogerjames #1
Member since Mar 2019 · 15 posts
Group memberships: Members
Show profile · Link to this post
Subject: Unable to upload mp4 files through media manager
I have the filelisting plugin and dropfiles plugin installed on the newest version of DokuWiki. When I try to drag and drop a mp4 file that is 32meg it shows a progress bar, but it is grey. When I do a pdf file it has a progress bar that is green. It does not give me any errors when trying to do a drag and drop of mp4 files it just never seems to turn green and the mp4 file never shows up. I have tried to upload the mp4 file through Media Manager and I am getting an error below:

copy.mp4
37.8MB Failed
Upload max. 256 MB per file.

I have checked php.ini file and it has file_uploads = On and upload_max_filesize = 256M and post_max_size = 256M and the mp4 file is only 32mb so it does not seem to be a php issue. I am running Windows Server 2016 and have IIS installed and running the dokuwiki. I can copy the mp4 file through windows explorer and the file shows up in the list of files in media manager with the date and file size. So, it does not seem to be a windows issue. Just seems to be a issue with DokuWiki not allowing mp4 files. I looked at the mime.conf file and it has mp4     video/mp4 so it does not seem to be issue with this. Not sure what else to try or what else could be causing it to fail. If any one has any ideals or suggestions, please let me know. Trying to upload a bunch of training videos but does not seem to work through DokuWiki. Yes, I can upload them through windows explorer, but I don’t want to give people access to the do this through windows explorer I want them to use DokuWiki to upload the files. Any ideals or suggestions would be appreciated. Thanks
This post was edited on 2019-03-29, 05:32 by rogerjames.
topic: Issues with Yalist with order list numbering and bullets  in the forum: General Help and Support Syntax and Usage
Avatar
rogerjames #2
Member since Mar 2019 · 15 posts
Group memberships: Members
Show profile · Link to this post
Subject: Issues with Yalist with order list numbering and bullets
Not sure if this is normal or if there seems to be an issue with the Yalist. When I have a document that has both numbering and bullets, when I start out having a number then after a few bullets the numbering seems to start over.? Example below:

1.    Some numbering text
•    Some bullets text
•    Some more bullet text
1.    Some more numbering

I would assume that when doing numbering and add some bullets between the numbers that the numbers would keep in sequence like below.

1.    Some numbering text
•    Some bullets text
•    Some more bullet text
2.    Some more numbering

So, if this is normal, or there a way we can do bullets between the numbering where the numbers do not lose the sequence? or is there something special I must do to keep the sequence? If there is a plugin that will fix this, please let me know or a plugin that will allow me to change the numbering sequence let me know please. Just seems to an issue with the Yalist on stuff like this. So not sure if this is a issue with the Yalist plugin or if there is a better one that would work for what we are trying to do? Please let me know. Any advice would be greatly appreciated
topic: Creating a yalist and images breaking the numbering  in the forum: General Help and Support Syntax and Usage
Avatar
rogerjames #3
Member since Mar 2019 · 15 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 65330
Like when you hit Enter Key on the keyboard. So guess it would be a new line. Sorry should clarify that a little more.
topic: Creating a yalist and images breaking the numbering  in the forum: General Help and Support Syntax and Usage
Avatar
rogerjames #4
Member since Mar 2019 · 15 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 65327
Ok. So, I tried that, and it works. But is this the only way for this to work is by having the image on the same line as the text above where the image was for this to work? Is there not any other way to get this to work?

For it to work I had to change it to
- Some Text\\((image003.jpg|image003}}
- Some more Text

Which ends up being:

1.    Some text
{{image003.jpg|image003}}
2.    Some more text

All of these documents was created in Microsoft Word so they have a line between each line where images are example below:

  - Some Text.

{{image003.jpg|image003.jpg}}

  - Some More Text.

Which ends up being:

1.    Some Text

{image003.jpg|image003.jpg

1.    Some More Text

So, there are extra spaces between the text and the image. Is there a way to have it where I can still have the extra line after each text and image? Or is there a plugin to allow you to change the numbering sequence like Microsoft Word has?
This post was edited 2 times, last on 2019-03-18, 19:52 by rogerjames.
topic: Creating a yalist and images breaking the numbering  in the forum: General Help and Support Syntax and Usage
Avatar
rogerjames #5
Member since Mar 2019 · 15 posts
Group memberships: Members
Show profile · Link to this post
Subject: Creating a yalist and images breaking the numbering
I apologize in advance. I am still learning a lot of this dokuwiki stuff. I am looking for some help and advice with images breaking an order list. So, for the past week I been trying to figure out how to get this set up so when I have an order list and images in a document the images won’t break the order list sequence or start over the numbering sequence. I have even installed the yalist plugin to see if this would help and it does not seem to help.  When I have a document that has an ordering list created, as soon as it gets to the line with an image, it ends up breaking the sequence of the number and after the image it starts over with the sequence.

I have tried to add line breaks \\ and have tried to put them in front of the image line and at the end of the image line and I have also tried to add it to the line above at the end of the text line. I have also tried to add <wrap>image</wrap> and <WRAP leftalign>Image</WRAP> and I have also tried to put .. in front of the image line but nothing seems to work. I have also installed the NBSP plugin and add tried adding added in the entities.local.conf \_     &nbsp; and then add \_ in front of the image line, then at the end of the image line. The numbering is still getting broken. The images are on their own line. So, when I have a document that has images they seem to keep breaking the ordering of the numbers and I can’t figure out how to reset the numbers or how to get so the images won’t break the ordering sequence. I am not sure what else to try, or do so these images won’t break the order list sequence. I have over 1000 documents that is having this problem. So, any help would be greatly apricated. Example below on what it keeps doing.

1. Some Text
2. Some Text
image
1. Some Text

So, what am I doing wrong? Is there another way I should be doing to stop the images from breaking the order list numbering sequence? Or is there another plugin I should have or try? Or is there a way to add something to the entities.local.conf to help so these images wont break the order list sequence? Any help or advice would be very apricated. Thanks in advance. I am also using the Boostrap3 template.
This post was edited on 2019-03-18, 18:49 by rogerjames.
topic: Resolved: Change width of search bar  in the forum: General Help and Support Installation and Configuration
Avatar
rogerjames #6
Member since Mar 2019 · 15 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 65307
Ok, got this figured out now. Took a while. Just incase some one else has the same question. In the userstyle.css file add the follow below and your search bar will be longer and moved over to the left so it does not cover up the menus. Thanks.

#qsearch {
  width: 100%;
  min-width: 25em;

}
form#dw__search {
  display: block;
  font-size: 100%; 
  min-width: 26em;
}
topic: Resolved: Change width of search bar  in the forum: General Help and Support Installation and Configuration
Avatar
rogerjames #7
Member since Mar 2019 · 15 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 65300
Thanks for the reply. I am using the Bootstrap3 template. Not sure if that makes a difference or not. I added that file to the wiki\config\ folder and all that seem to do is make the top bar bigger and the search bar is on the top row and the Menu's are under it. Any other ideals or suggestions to fix this? Thanks.
This post was edited on 2019-03-17, 04:35 by rogerjames.
topic: Resolved: Change width of search bar  in the forum: General Help and Support Installation and Configuration
Avatar
rogerjames #8
Member since Mar 2019 · 15 posts
Group memberships: Members
Show profile · Link to this post
Subject: Resolved: Change width of search bar
What file would I need to edit to change the width of the search bar on the top bar. I have tried looking at tons of files and not able to find this. I have users that is requesting to have the size changed so it is longer. Any advice on this would be apricated. Thanks.
This post was edited on 2019-03-17, 07:15 by rogerjames.
topic: Issues with images on same line as text  in the forum: General Help and Support Syntax and Usage
Avatar
rogerjames #9
Member since Mar 2019 · 15 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 65297
I got it figured out, something must been wrong with the XBR plugin. after looking at codes and playing with it, we reinstalled the XBR plugin and now the images are showing up perfect. Thanks.
topic: Issues with images on same line as text  in the forum: General Help and Support Syntax and Usage
Avatar
rogerjames #10
Member since Mar 2019 · 15 posts
Group memberships: Members
Show profile · Link to this post
Subject: Issues with images on same line as text
I seem to be having a lot of issues with images on the same line as the text which I do not want. What the strange part is it seems to be random too. For example, I have one document that has over 40 images. Some images will show up fine with no text on the left or right. But then I have other images that has text on the left side of them. Then I have other images that has text both left and right side of the images. that will have text on the This is causing an issue with the layout and looks horrible having it random and images all over the place. I have tried using \\ and

I have tried to put <wrap>{{image002.png}}</wrap> this does not seem to effect anything. I tried adding <wrap>{{Some Text}}</wrap> and this also does not seem to effect anything either.
I have tried the line breaks {{image002.png}}\\ This seems to work on some images where the images will use their own line and not share with text on the side of them, but then for others it does nothing for them. I have tried to put \\ at the end of the text and does not seem to do anything. I tried putting \\ and having the image on the same line as the text file and this does not seem to do nothing.
   
    So, not sure what else to try or how to fix this where I don’t have to use tons of different commands to get the results I want. I want to be able to have something like 
Some text
{{Image01}}
Some more text
{{image02}
Some more text again.

Where the images will not be on the same line as the text or have text on the left or right or both. I would like to have the images stay on the left even with all the text. I tried several sites and forums and other combos and nothing seems to be working. Does anyone has any ideals how to fix this or what script to use or plugin or commands or anything helpful? Please let me know. Thanks in advance.
topic: How to Indent without creating a Code Block  in the forum: General Help and Support Syntax and Usage
Avatar
rogerjames #11
Member since Mar 2019 · 15 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 65232
So, any one know how the <wrap> command works with all the different <wrap> syntax? I tried searching online and there really is not much details on this.

So if I want to add 2 spaces I can add <wrap>text</wrap> ?

So if I want to add 3 space I can add <wrap>text</wrap> ?

So if I want to add a tab I can add <wrap indent>text</wrap> ?

So if I want to add 2 tabs I can add <wrap indent><wrap indent> text </wrap indent> ?

Would this how I would use the <wrap> commands? Or is there better <wrap> commands to use? Thanks for all the replies.
topic: How to Indent without creating a Code Block  in the forum: General Help and Support Syntax and Usage
Avatar
rogerjames #12
Member since Mar 2019 · 15 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 65228
I am using the Word2DokuWiki macro. I had a programmer end up fixing a lot of the issues with the macro with images, formatting, and a lot of other things and got it to upload the text and images to the server and got the rest of it working great.

The problem is, a lot of these documents has tab/indent and some times there are 2 tabs or 2 indents and when the macro uploads the text files and you load the page on the dokuwiki it ends up having these tabs/indents in a code block. So not sure how to have the macro fix this or add something so it does not load the code blocks. Hope this all makes sense. Any suggestions would be appreciated.
topic: How to Indent without creating a Code Block  in the forum: General Help and Support Syntax and Usage
Avatar
rogerjames #13
Member since Mar 2019 · 15 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 65226
Is there any other way to allow non-breaking spaces, tabs, indents with out having to go into every document/text file to add that wrap line in the document/text file? Having to do this to over 1000 documents would be very time consuming. Like can we add that some where so it does it automatic or something? Sorry I am not great with some of this stuff so any help would be appreciated. Thanks for the reply.
topic: How to Indent without creating a Code Block  in the forum: General Help and Support Syntax and Usage
Avatar
rogerjames #14
Member since Mar 2019 · 15 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 65224
I have that plugin but it does not seem to help any. Is that not something you have to add <wrap> every where you have a indent, tab, extra non-breaking spaces? Because that would mean I would have to go in and add that to over 1000 documents. Thanks for your reply.
topic: How to Indent without creating a Code Block  in the forum: General Help and Support Syntax and Usage
Avatar
rogerjames #15
Member since Mar 2019 · 15 posts
Group memberships: Members
Show profile · Link to this post
Subject: How to Indent without creating a Code Block
Is there a plugin for 2018-04-22 "Greebo" that will allow tabs, indents, non-breaking spaces, ect? I have a Word Visual Basic macro that converts the word documents into a wiki document and uploads them to my server. The problem is a lot of these documents has indent/tabs and extra spaces for aligning things in the documents so when you open the document in dokuwiki it ends up a lot of code blocks because of the indent/tabs and extra spaces.

So I was hoping if any one knows if there is a plugin that is compatible with 2018-04-22 "Greebo" that will allow for tabs, indents, non-breaking spaces or if there is something that can be edit to allow this?

I would hate to have to go into each document and edit every document to try to remove code blocks or add something to every document so it does not put code blocks all over the document because I have over 1000 word documents that I have to convert and that would be very long time to do this and would be very time consuming.

So if some one knows a way around this or a plugin or how to get it to work so you can have tabs, extra non-breaking spaces in your text file and not have it convert a ton of code blocks please let me know. I would be very grateful. Thanks in advance.
Close Smaller – Larger + Reply to this post:
Special characters:
Special queries
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2020-02-17, 08:19:42 (UTC +01:00)