Not logged in. · Lost password · Register
Page:  1  2  3 ... 36  37  38  next 

All posts by cziehr (567)

topic: LaTeX plugin bringt Fehlermeldung  in the forum: Non-English Discussion German discussion
Avatar
cziehr #1
Member since Jan 2011 · 567 posts · Location: 10119 Berlin
Group memberships: Members
Show profile · Link to this post
Quote by Michaelsy:
Das ist natürlich korrekt. Aber die Frage ist halt, ob deine DS der richtige Weg für dich ist oder überhaupt sein kann. Für die absoluten Linux-Freaks, die im Zweifelsfall alles manuell in so ein Linux-System hineinbasteln können, sieht das natürlich etwas anders aus.

Ich wage die Behauptung aufzustellen, dass eine DiskStation für den normalen 0815-Benutzer einen relativ einfachen und komfortablen Start ermöglicht, wenn man allerdings was Spezielles haben möchte es deutlich komplizierter wird als mit einem "normalen" Linux, bei dem man erstens nicht erst das Betriebssystem verbiegen muss und man zweitens unzählige Dokumentationen für nahezu jeden Anwendungsfall findet.

Grundsätzlich spricht nichts dagegen eine DiskStation zu verwenden, aber man muss schauen was sie kann und vor allem was sie (jedenfalls out-of-the-box) nicht kann.

Um Michaels Post noch zu ergänzen:
Auf einem Webspace von 1&1 kann man sich mimetex ebenfalls nicht installieren, da muss man sich schon einen kompletten Server mieten. Den muss man allerdings dann auch komplett konfigurieren können, dafür braucht man schon etwas IT-Wissen um nicht innerhalb von kurzer Zeit gehackt zu werden.

Für die Anwendung daheim würde ich wie schon von Michael erwähnt z.B. einen Raspberry Pi in Betrieb nehmen.

Aber ich glaube wir schweifen gerade völlig vom Thema ab...
topic: LaTeX plugin bringt Fehlermeldung  in the forum: Non-English Discussion German discussion
Avatar
cziehr #2
Member since Jan 2011 · 567 posts · Location: 10119 Berlin
Group memberships: Members
Show profile · Link to this post
In reply to post ID 66197
Quote by eve:
Quote by Michaelsy:
Ein anderer Knackpunkt könnte das Upgrade-Plugin sein:
https://www.dokuwiki.org/plugin:upgrade
Das habe ich gar nicht installiert. Brauche ich das unbedingt?

Man braucht es nicht, aber es ist der mit Abstand komfortabelste Weg eine DokuWiki-Aktualisierung zu installieren.
topic: LaTeX plugin bringt Fehlermeldung  in the forum: Non-English Discussion German discussion
Avatar
cziehr #3
Member since Jan 2011 · 567 posts · Location: 10119 Berlin
Group memberships: Members
Show profile · Link to this post
In reply to post ID 66193
Achso, ja das stimmt natürlich.

Ich habe einen Bekannten, der hat versucht sich Nextcloud auf seiner Synology zu installieren. Es gab zwar ein fertiges Owncloud-Paket (der Vorgänger von Nextcloud), aber das war von den verfügbaren Aktualisierungen Jahre hinter dem aktuellen Stand. Er hat dann versucht Nextcloud manuell einzurichten, das hat Wochen gedauert bis alles lief. Wenn man ein paar individuelle Wünsche hat die über den Standard hinausgehen wird das bei der Synology wohl schnell kompliziert. Soweit ich weiß musste bei meinem Bekannten dann noch einiges im Betriebssystem rumgepfuscht werden usw.
Ich dachte dass man vielleicht wenigstens die normalen Linux-Pakete per Kommandozeile installieren kann, aber selbst das war wohl schon zu viel...
topic: LaTeX plugin bringt Fehlermeldung  in the forum: Non-English Discussion German discussion
Avatar
cziehr #4
Member since Jan 2011 · 567 posts · Location: 10119 Berlin
Group memberships: Members
Show profile · Link to this post
In reply to post ID 66191
Quote by Michaelsy:
Ein anderer Knackpunkt könnte das Upgrade-Plugin sein:
https://www.dokuwiki.org/plugin:upgrade

Wie kann denn das Upgrade-Plugin helfen ein Software-Paket im Betriebssystem zu installieren (oder stehe ich jetzt gerade auf dem Schlauch)?
topic: LaTeX plugin bringt Fehlermeldung  in the forum: Non-English Discussion German discussion
Avatar
cziehr #5
Member since Jan 2011 · 567 posts · Location: 10119 Berlin
Group memberships: Members
Show profile · Link to this post
In reply to post ID 66188
Quote by eve:
Ergebnis:
sudo: apt: command not found

Ich hatte kurz zur Synology gegoogelt und mehrfach gefunden dass jemand den "sudo apt-get install"-Befehl zur Installation benutzt hat (so wie er z.B. auch in Debian oder Ubuntu verwendet wird), von daher war ich davon ausgegangen dass dieser grundsätzlich funktioniert. Aber anscheinend geht das dann doch nicht standardmäßig.

Bitte wende Dich an ein Synology-Forum um zu erfahren wie Du eigene Pakete nachinstallieren kannst, zumindest ich kann dabei leider nicht weiterhelfen, ich hatte mit Synology noch nichts zu tun.
topic: LaTeX plugin bringt Fehlermeldung  in the forum: Non-English Discussion German discussion
Avatar
cziehr #6
Member since Jan 2011 · 567 posts · Location: 10119 Berlin
Group memberships: Members
Show profile · Link to this post
In reply to post ID 66186
Quote by Michaelsy:
Quote by Annel:
Auf jedenfall funktionierte es mit dem Beispiel auf Anhieb..

Mit dem Mimetex Plugin bekomme ich jetzt anstelle einer Formel die folgende Fehlermeldung angezeigt:
**ERROR RENDERING LATEX**:
could not locate 'mimetex' command

Ich frage mich gerade, wie es erst funktionieren konnte und dann doch wieder nicht  :huh:

Weil es bei Annel auf Anhieb funktioniert hat und bei eve nicht ;-)
topic: LaTeX plugin bringt Fehlermeldung  in the forum: Non-English Discussion German discussion
Avatar
cziehr #7
Member since Jan 2011 · 567 posts · Location: 10119 Berlin
Group memberships: Members
Show profile · Link to this post
In reply to post ID 66184
Statt

sudo apt-get install mimetex

geht auch

sudo apt install mimetex

Versuche das bitte nochmal.
topic: LaTeX plugin bringt Fehlermeldung  in the forum: Non-English Discussion German discussion
Avatar
cziehr #8
Member since Jan 2011 · 567 posts · Location: 10119 Berlin
Group memberships: Members
Show profile · Link to this post
In reply to post ID 66180
Gerne ;-)

Ich muss allerdings beichten, dass ich selbst die Seite auch gar nicht so weit gelesen habe  :-D
topic: LaTeX plugin bringt Fehlermeldung  in the forum: Non-English Discussion German discussion
Avatar
cziehr #9
Member since Jan 2011 · 567 posts · Location: 10119 Berlin
Group memberships: Members
Show profile · Link to this post
In reply to post ID 66178
Quote by eve:
...und wie finde ich heraus, welches PHP-Modul da fehlen könnte? (Wie gesagt, ich habe von PHP absolut keine Ahnung)

Das wollte ich gerade noch schreiben, da bist Du mir zuvor gekommen ;-)

Du hast geschrieben dass Du das Wiki auf Deiner Synology betreibst. So wie mir das aussieht fehlt da nicht "nur" ein PHP-Modul, sondern das kompette Programm mimetex (was offensichtlich erforderlich ist).

Um das zu installieren gehst Du wie folgt vor:

Logge Dich mittels ssh auf Deiner Synology ein. Falls Du nicht weist wie das geht, ist das z.B. hier beschrieben: https://www.synology-wiki.de/index.php/Die_Kommandozeile

Sobald Du eingeloggt bist, führst Du folgendes Kommando aus, um mimtex zu installieren:

sudo apt-get install mimetex

Du musst dazu dann wahrscheinlich noch Dein Admin-Passwort eingeben (was Du wahrscheinlich aber auch schon benötigst um Dich überhaupt per SSH einzuloggen), und dann werden die erforderlichen Pakete heruntergeladen und installiert. Sobald die Installation abgeschlossen ist, solltest Du mimetex ohne weitere Einstellungen benutzen können.

Viele Grüße,
Christoph
topic: LaTeX plugin bringt Fehlermeldung  in the forum: Non-English Discussion German discussion
Avatar
cziehr #10
Member since Jan 2011 · 567 posts · Location: 10119 Berlin
Group memberships: Members
Show profile · Link to this post
In reply to post ID 66168
Quote by Annel:
Zwei Warnungen sind noch übrig gebleiben.

Eine davon wird von der latexinc.php ausgelöst, für die bei "github" aber keine Änderung ängegeben ist.

Warning: Declaration of syntax_plugin_latex_common::render($mode, &$renderer, $data) should be compatible with DokuWiki_Syntax_Plugin::render($format, Doku_Renderer $renderer, $data) in E:\...\plugins\latex\latexinc.php on line 157

In der monierten Zeile 157 steht nur das letzte, schließende Bracket und danach kommt nichts mehr.

Die dollar.php ist trotz der Änderung noch nicht in Ordnung.

Warning: Declaration of syntax_plugin_latex_dollar::handle($match, $state, $pos, &$handler) should be compatible with DokuWiki_Syntax_Plugin::handle($match, $state, $pos, Doku_Handler $handler) in E:\..\plugins\latex\syntax\dollar.php on line 28

Hallo Anne,

die Lösung des Problems steht eigentlich schon in der Fehlermeldung selbst drin, das muss man aber wissen :-)
Nur die Zeilenangaben stimmen nicht so ganz.

In der latexinc.php musst Du in Zeile 68 den Inhalt von

function render($mode, &$renderer, $data) {

auf

function DokuWiki_Syntax_Plugin::render($format, Doku_Renderer $renderer, $data) {

ändern.

In der dollar.php änderst Du in Zeile 23 den Code von

function handle($match, $state, $pos, &$handler) {

zu

function DokuWiki_Syntax_Plugin::handle($match, $state, $pos, Doku_Handler $handler) {

Hab es nicht getestet, aber es sollte funktionieren.

Viele Grüße,
Christoph
topic: toptoclevel Inhaltsverzeichnis H1 ausblenden funktioniert nicht  in the forum: Non-English Discussion German discussion
Avatar
cziehr #11
Member since Jan 2011 · 567 posts · Location: 10119 Berlin
Group memberships: Members
Show profile · Link to this post
In reply to post ID 66172
Das Ausblenden könnte man wahrscheinlich auch relativ einfach per CSS machen. Aber vielleicht gibts ja schon ne Lösung.
topic: LaTeX plugin bringt Fehlermeldung  in the forum: Non-English Discussion German discussion
Avatar
cziehr #12
Member since Jan 2011 · 567 posts · Location: 10119 Berlin
Group memberships: Members
Show profile · Link to this post
In reply to post ID 66163
Quote by eve:
Quote by cziehr:
Anscheinend wird das Plugin leider nicht mehr gewartet,
Also ein "toter Gaul", wie Michaelsy es so schön genannt hat? Dann sollte ich vielleicht doch besser ein anderes Latex-Plugin suchen...

Na ja, das kann man so allgemein nicht sagen. Ich benutze auch Plugins, die schon seit Jahren nicht mehr aktualisiert wurden und von denen ich weiß, dass sich der Autor von DokuWiki verabschiedet hat. Aber da sie immer noch funktionieren, spricht meiner Meinung nach nichts dagegen.

Mir ist es auch schon mehrfach passiert, dass so ein nicht mehr betreutes Plugin nach einem Upgrade von DokuWiki oder PHP nicht mehr funktioniert hat. Unter anderem hatte ich auch schon das gleiche Problem wie Du es beschrieben hast, aber es gab auch schon andere Ursachen, wie z.B. dass eine vom Plugin genutzte PHP-Funktion zur Zerlegung von Zeichenketten in der aktuellen PHP-Version nicht mehr zur Verfügung stand.

Da die Plugins hier ja aber genauso wie DokuWiki praktisch alle als OpenSource veröffentlicht wurden, hab ich es bis jetzt immer geschafft meine betroffenen Plugins in kurzer Zeit zu reparieren und konnte sie dann weiter verwenden. Dabei möchte ich ausdrücklich hervorheben, dass meine PHP-Programmier-Fähigkeiten nicht über die absoluten Basics hinausgehen. Wirklich schwierig wird es meiner Meinung nach erst, wenn man bei einem fremden Plugin ohne viel PHP-Kenntnissen funktional etwas ändern möchte oder muss.

Viele Grüße,
Christoph
topic: LaTeX plugin bringt Fehlermeldung  in the forum: Non-English Discussion German discussion
Avatar
cziehr #13
Member since Jan 2011 · 567 posts · Location: 10119 Berlin
Group memberships: Members
Show profile · Link to this post
In reply to post ID 66160
Hallo,

der Grund des Fehlers ist, dass das Plugin mit PHP 7 nicht mehr funktioniert. Man kann sich aber behelfen, indem man ein paar kleine Änderungen in den Dateien des Plugins vornimmt. Diese sind im Einzelnen hier beschrieben:

https://github.com/marklundeberg/dokuwiki-plugin-latex/pul…

Das was rot gekennzeichnet ist ist das alte falsche, und das was grün gekennzeichnet ist, ist so wie es jetzt sein muss.

Anscheinend wird das Plugin leider nicht mehr gewartet, da andi (der Erfinder und Hauptentwickler von DokuWiki) bereits 2016 den oben verlinkten Patch an den Entwickler geschickt hat, dieser hat ihn jedoch noch nicht integriert.

Viele Grüße,
Christoph
topic: [gelöst] youarehere und breadcrumbs-Anzeige der Startseite funktioniert nicht korrekt  in the forum: Non-English Discussion German discussion
Avatar
cziehr #14
Member since Jan 2011 · 567 posts · Location: 10119 Berlin
Group memberships: Members
Show profile · Link to this post
In reply to post ID 66155
Hallo,

hast Du die neuste DokuWiki-Version installiert? Ich erinnere mich, dass es in einer Version mal Probleme mit der Breadcrumbs-Darstellung gab, das sollte in der aktuellen Version aber wieder funktionieren.

Viele Grüße,
Christoph

Nachtrag: Das Problem damals sah so aus: https://forum.dokuwiki.org/thread/15795 Zu Deiner Darstellung passt das nicht so 100%, aber ein Ansatz wäre es vielleicht trotzdem!?
topic: Zugriff auf Namensraum für Bilder  in the forum: Non-English Discussion German discussion
Avatar
cziehr #15
Member since Jan 2011 · 567 posts · Location: 10119 Berlin
Group memberships: Members
Show profile · Link to this post
In reply to post ID 66088
Quote by grummel:
Aber was auch immer ich mache - es will nicht funktionieren; weder {{file>///localhost/C/Daten/test.txt}} noch {{file://localhost/C/Daten/test.txt}} oder {{filelist>127.0.0.1/C/Daten/test.txt}} oder andere Kombinationen in dieser Art ergeben das gewünschte Resultat ...

Das hat aber gar nichts mit DokuWiki zu tun, sondern ist eine Sicherheitsfunktion moderner Browser.

Wenn man ganz tief in die Konfiguration von Firefox einsteigt, kann man das wohl deaktivieren und dann wäre ein Zugriff so wie von Dir gewünscht möglich. Wenn ich mich recht erinnere wurde das hier im Forum schonmal irgendwo besprochen. Alternativ findet man aber sicher auch bei Google was.

Viele Grüße,
Christoph
Close Smaller – Larger + Reply to this post:
Special characters:
Page:  1  2  3 ... 36  37  38  next 
Special queries
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2019-05-23, 05:15:36 (UTC +02:00)