Not logged in. · Lost password · Register
Page:  1  2  3  4  5  6  7  next 

All posts by crazyburn (98)

topic: Login mit SSO ohne Gruppeninformationen  in the forum: Non-English Discussion German discussion
crazyburn #1
Member since Mar 2012 · 98 posts
Group memberships: Members
Show profile · Link to this post
Kein Problem,

dafür ist ein Forum ja da, um sich auszutauschen ;)
topic: Login mit SSO ohne Gruppeninformationen  in the forum: Non-English Discussion German discussion
crazyburn #2
Member since Mar 2012 · 98 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 44188
Hallo Maddes,

trag bitte mal folgende Optionen mit in deine local.protected.php:

  //user account with permission to perform AD lookups
  $conf['plugin']['authad']['admin_username']        = 'Benutzer';
  $conf['plugin']['authad']['admin_password']        = 'BenutzerPW';

Das muss kein Administrator sein. Der Benutzer braucht lediglich rechte um sich AD-Informationen zu beschaffen.
Bei uns ist das ein stinknormaler Benutzer
topic: Subskription verschickt keine Mail  in the forum: Non-English Discussion German discussion
crazyburn #3
Member since Mar 2012 · 98 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 44089
Hallo raba,

ich benutze nur die normale Abofunktion vom Dokuwiki.
Den Exchange spreche ich bei uns über das Swiftmail-Plugin an.
topic: Suche vom Wiki (Index eventuell in Datenbank schreiben?)  in the forum: Non-English Discussion German discussion
crazyburn #4
Member since Mar 2012 · 98 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 44028
ich hab mir mal das sphinxsearch angeguckt.
Irgendwie werd' ich da nicht ganz schlau draus.

Das Plugin ist über den Pluginmanager installiert.

Bei den Anforderungen steht das Sphinx Search mit xmlpipe2 gebraucht wird.
(wird nicht gebraucht wenn das binary package benutzt wird)

Wir benutzen einen Windows Server 2008 R2 x64 mit IIS 7.5.
Dementsprechend hab ich mir die "Win64 binaries w/MySQL+PgSQL+libstemmer+id64 support" 2.1.8 gedownloadet.

In der Installationsanweisung von Sphinx steht:
- das man es entpacken,
- in der sphinx.conf.in den Pfad anpassen soll
- den Dienst installieren
- den Sphinx konfigurieren und den Index erstellen und den Dienst starten

Und da habert es...

jetzt weiß ich nicht nach welcher Anleitung ich jetzt weitermachen sollte. Der von dem Sphinxsearch-Plugin oder nach Quicktour... wobei das schwer ist, weil es für Linux und nicht für Windows geschrieben wurde...
topic: Suche vom Wiki (Index eventuell in Datenbank schreiben?)  in the forum: Non-English Discussion German discussion
crazyburn #5
Member since Mar 2012 · 98 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 44008
hat da schon wer Erfahrungen gemacht?
topic: Suche vom Wiki (Index eventuell in Datenbank schreiben?)  in the forum: Non-English Discussion German discussion
crazyburn #6
Member since Mar 2012 · 98 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 43987
ich glaub du kennst das Problem schon. Hatten auch schonmal letztes Jahr am Telefon gesprochen, das Docsearch so lange braucht.


Hier mal eine Auflistung aller aktuell installierten Plugins:

aceeditor   
acl   
addnewpage   
anchor   
authad   
authldap   
authmysql   
authpgsql   
authplain   
config   
confmanager   
deniedpage   
docsearch   
dw2pdf   
fckg    (fckglite)
filelist   
gallery   
hidden   
iframe   
indexmenu   
info   
ireadit   
logstats   
move   
numberof   
orphanswanted   
pageredirect   
plugin   
popularity   
removeold   
revert   
safefnrecode   
searchindex   
searchtablejs   
searchtext   
snippets   
sortablejs   
statdisplay   
swiftmail   
tab   
templatebyname   
testing   
text   
tooltip   
upgrade   
usermanager   
wikicalendar   
wrap
topic: Suche vom Wiki (Index eventuell in Datenbank schreiben?)  in the forum: Non-English Discussion German discussion
crazyburn #7
Member since Mar 2012 · 98 posts
Group memberships: Members
Show profile · Link to this post
Subject: Suche vom Wiki
Hallo zusammen,

unser Wiki ist glaub ich an seine Grenzen gestoßen.
Die Suchanfragen dauern Teilweise Minuten oder es gibt einen Fehler, weil die Zeit für die Scriptausführung von PHP überschritten wurde (max_execution_time steht im Moment auf 300). In der Zeit ist der CPU unter volllast und andere Benutzer haben es schwer überhaupt eine Seite zu öffnen.

Webserver:

IIS 7.5
PHP 5.4.28

Zum Wiki:

Release 2013-12-08 "Binky"
Modifiziertes Vector Template

Seiten: 1588
Medien: 7066


Wäre es vielleicht Möglich die Suche über einen Datenbank gestützten Index laufen zu lassen.
Datenbanken haben meines Wissens schneller Zugriffs- und Antwortzeiten.

Ist dies überhaupt möglich, den Index auszusondern und die Suche über eine Datenbank anstatt über die Dateien selber laufen zu lassen?

Bin mal auf eure Antworten gespannt.

Gruß crazy
topic: Neues Dokuwiki mit LDAP anbindung  in the forum: Non-English Discussion German discussion
crazyburn #8
Member since Mar 2012 · 98 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 43905
Mir ist da gerade noch etwas ganz wichtiges eingefallen.

Ich hatte damals Probleme mit dem Anmelden weil die local.protected.php oder die local.php mit dem falschen Zeichenkodierung gespeichert waren.

Was auch noch ein Problem war, ich wollte die Domänen-Admin Gruppe als Administrator eintragen, und dies funktionierte nicht wegen dem Umlaut.

Zum Anmelden kannst du auch einen Benutzer nehmen, der in das AD reinschauen darf.
topic: Neues Dokuwiki mit LDAP anbindung  in the forum: Non-English Discussion German discussion
crazyburn #9
Member since Mar 2012 · 98 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 43859
Die LDAP-Erweiterung (php_ldap.dll) in PHP ist bei dir aber noch aktiv?

Ich kenne mich leider nicht mit Apache aus, ich habe das Wiki bei uns mit IIS 7.5 laufen.

Außerdem hat der Webserver keine Schreibrechte auf deine Verzeichnisse.
topic: Neues Dokuwiki mit LDAP anbindung  in the forum: Non-English Discussion German discussion
crazyburn #10
Member since Mar 2012 · 98 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 43756
Guten Morgen,

geh bitte mal auf das Wiki und benutz mal folgende URL: http://<servername>/doku.php?id=start&do=check

Überprüfe mal damit, ob der Anmeldename und die Berechtigungen usw. passen.

Kann auch ein Problem bei der Webserverkonfiguration sein.
topic: Neues Dokuwiki mit LDAP anbindung  in the forum: Non-English Discussion German discussion
crazyburn #11
Member since Mar 2012 · 98 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 43717
@hahnl: so haben wir auch mal angefangen als internes Dokumentationswerkzeug.

Mittlerweile ist es unser Firmenintranet, mit Mitteilungsseite und Dokumentationsseiten der einzelnen Abteilungen oder halt interne Breiche der Abteilungen.

Du möchtest nicht wissen wie viele ACL-Einträge ich machen musste XD (zum Glück mit Gruppen und nicht mit einzelnen Usern)
topic: Neues Dokuwiki mit LDAP anbindung  in the forum: Non-English Discussion German discussion
crazyburn #12
Member since Mar 2012 · 98 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 43700
zur Erklärung:

Der Name local.protectet.php ist mit Absicht gewählt. Diese Datei kann nicht aus dem Wiki heraus bearbeitet werden. Die Parameter sind zwar im Konfigurationmenü angezeigt, kann aber nicht geändert werden und überschreibt die Daten aus der local.php.

Erste Frage zu deiner Konfiguration:

hast du in deinem AD eine Gruppe mit dem Namen "Wikiadmin"? Die Gruppe hat bei dir im Wiki Superuserrechte, deswegen die Frage.


Zweite Frage:

du hast SSO (SingleSignOn) aktiviert. Die Benutzer Melden sich auch mit dem DomänenBenutzer am PC an?


Dritte Frage:

Warum haben die Domänen-Benutzer bei dir keine Lese-Rechte?
Setze mal noch in acl.auth.php die Gruppe "@domain%5fusers" auf 1


Bei uns war noch das Problem, das die SSL-Authentifizierung nicht ging. Überprüfe das auch nochmal.
topic: Direkte Ausführung beim Aufruf einer Seite  in the forum: Non-English Discussion German discussion
crazyburn #13
Member since Mar 2012 · 98 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 43668
wenn die PDF und Bilddateien im Wikiverzeichis liegen, musst du _blank aber auch noch Mediafiles eintragen.
topic: Neues Dokuwiki mit LDAP anbindung  in the forum: Non-English Discussion German discussion
crazyburn #14
Member since Mar 2012 · 98 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 43664
falls du es nicht hinbekommen solltest, hier ist eine vorkonfiguriert Datei.
Diese Datei anpassen und in das /.conf Verzeichnis schieben.

Die letzte Zeile kannst du auch anpassen, wenn du das FileList-Plugin auch nutzt...
The author has attached one file to this post:
local.protected.php.zip 1,198 Bytes
You have no permission to open this file.
topic: Direkte Ausführung beim Aufruf einer Seite  in the forum: Non-English Discussion German discussion
crazyburn #15
Member since Mar 2012 · 98 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 43610
Hallo,
hilft es dir vielleicht wenn die Links in einem extra Tab bzw Fenster aufgehen?

Das lässt sich einfach reallisieren:

Geh einfach in den Adminbereich > Konfiguration > Links
und trage bei externen Links "_blank" (ohne Anführungszeichen) ein.

Das gleiche kannst du auch für die anderen Dateitypen wie Mediafiles machen.
Close Smaller – Larger + Reply to this post:
Special characters:
Page:  1  2  3  4  5  6  7  next 
Special queries
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2019-12-08, 03:24:16 (UTC +01:00)