Not logged in. · Lost password · Register
Forum: General Help and Support Installation and Configuration RSS
CSS not loading after upgrade
Avatar
PeterRJG #1
Member since Oct 2010 · 9 posts
Group memberships: Members
Show profile · Link to this post
Subject: CSS not loading after upgrade
Site in question - http://aesedra.com/wiki/

Ever since upgrading to the Ponder Stibbons version, my site regularly fails to load its CSS. I've disabled all plug-ins, reverted the theme back to default and/or dokuwiki for testing purposes, turned off gzip compression (advice I found on Google) and nothing really fixes it.

Turning off gzip compression got rid of all the cannot parse PHP errors, but the CSS still does not load regularly. It will the first time I change the theme in configuration, then after that it fails to load. Clearing browser cache doesn't help.

Any ideas?
Avatar
turnermm (Moderator) #2
Member since Oct 2009 · 4675 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
Have you tried clearing out data/cache of all directories?  And of course the browser cache.
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
Avatar
ach (Administrator) #3
Member since May 2006 · 1921 posts · Location: Folkestone, UK
Group memberships: Administrators, Members, Super Mods, Wiki Managers
Show profile · Link to this post
In reply to post #1
Your CSS is completely empty, which might point to a fatal PHP error. Have you checked your server/error logs?
Avatar
PeterRJG #4
Member since Oct 2010 · 9 posts
Group memberships: Members
Show profile · Link to this post
In reply to post #2
Quote by turnermm:
Have you tried clearing out data/cache of all directories?  And of course the browser cache.

Just deleted the cache directory - no change. And I already said I cleared the browser cache. In fact, I've tried the site from a number of browsers on a different number of platforms.
Avatar
PeterRJG #5
Member since Oct 2010 · 9 posts
Group memberships: Members
Show profile · Link to this post
In reply to post #3
Quote by ach:
Your CSS is completely empty, which might point to a fatal PHP error. Have you checked your server/error logs?

Not sure what you mean by completely empty. When I click on that link in both Chrome and IE on this computer I get a lengthy CSS file.

My server logs are showing nothing unusual apart from a few weird 412 precondition failed errors for a couple of images.
Avatar
ach (Administrator) #6
Member since May 2006 · 1921 posts · Location: Folkestone, UK
Group memberships: Administrators, Members, Super Mods, Wiki Managers
Show profile · Link to this post
Quote by PeterRJG:
Quote by ach:
Your CSS is completely empty, which might point to a fatal PHP error. Have you checked your server/error logs?

Not sure what you mean by completely empty. When I click on that link in both Chrome and IE on this computer I get a lengthy CSS file.

I guess that's what you meant by "the CSS still does not load **regularly**". It's still completely empty for me, but I can imagine it's only sometimes empty, the way you've described it.
Avatar
Michitux #7
Member since Apr 2008 · 377 posts · Location: Karlsruhe, Germany
Group memberships: Members, Wiki Managers
Show profile · Link to this post
This seems to be some problem with caching, when I disable caching by appending &purge=true to the URL, I get the CSS. However without the purge, the CSS is empty. Is there maybe some problem with cache file writing, for example is the disk full or something like that? Do you get any messages in the PHP error log?
Did you like my help or work for DokuWiki (plugins)? Consider giving something back.
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2019-07-23, 01:05:02 (UTC +02:00)