Not logged in. · Lost password · Register
Forum: General Help and Support Plugins RSS
[solved] Linkmanager pcfg_openfile error
Avatar
salto #1
Member since Aug 2007 · 20 posts
Group memberships: Members
Show profile · Link to this post
Subject: [solved] Linkmanager pcfg_openfile error
I would really like to use the linkmanager http://wiki.splitbrain.org/plugin:linkmanager, but I have a persistent pcfg_openfile error. The image does not show up in the button toolbar. When I click the link in the button I get a popup with an 403.
Permissions for files/directories are the same as everywhere else in the wiki folder: 600/700, as is the owner. Experiments with other permissions did not make a difference.

My Apache log shows
Permission denied: /usr/www/users/etc...../lib/plugins/linkmanager/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable, referer: http://my.domain/doku.php?id=start&do=edit&rev=

So now I am stuck, what else could I try?

Apache 2.2.4, FreeBSD 6.2-RELEASE-p1, PHP 5.2.3 as CGI, safe mode Off
This post was edited on 2007-08-21, 09:10 by salto.
Avatar
salto #2
Member since Aug 2007 · 20 posts
Group memberships: Members
Show profile · Link to this post
OK, I solved this issue, finally, but the solution does not seem rational in any way to me so I do not know if this is of any use for anyone else banging his/her head against the monitor.
But here you go:
If you installed the plugin trough the plugin manager, have this issue and tried all variations of CHMODS already, do delete the linkmanager directory on your server and copy the files via FTP from your computer to the plugins directory. Do not ask me why, I do not know, but there seems to be a difference.
After copying the files through FTP, CHMOD both the plugins/linkmanager/exe and the plugins/linkmanager/images directories to 755. Do not think 777 would be any better, because it is not, at least, not in my configuration. Even CHMOD 777 kept throwing persistent 403's.
Then go to plugins/linkmanager/images/page_link.png and CHMOD that one to 644.
Sigh......
This post was edited on 2007-08-21, 09:29 by salto.
Avatar
andi (Administrator) #3
User title: splitbrain
Member since May 2006 · 3471 posts · Location: Berlin Germany
Group memberships: Administrators, Members
Show profile · Link to this post
This sounds like some security module is interfering. The difference between plugin manager and FTP upload is probably the files being created with a different owner triggering different rules of the security module... just speculating...
Read this if you don't get any useful answers.
Lies dies wenn du keine hilfreichen Antworten bekommst.
Avatar
salto #4
Member since Aug 2007 · 20 posts
Group memberships: Members
Show profile · Link to this post
The silly thing was that the owner was the same everywhere in the doctree, very confusing. I made a test installation on a dedicated server to be sure owners could not interfere and had the same problem.
The only thing I can think of is a glitch in the php wrapper. There as a new edition released a couple of weeks ago, I had no problems so far, but there might be something interfering in that binary. That one I still have to check out.
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2019-08-21, 18:44:08 (UTC +02:00)