Not logged in. · Lost password · Register
Forum: General Help and Support Installation and Configuration RSS
Solved: ACL not working on Namespace Index
Avatar
goblin #1
Member since Jul 2006 · 4 posts
Group memberships: Members
Show profile · Link to this post
Subject: Solved: ACL not working on Namespace Index
Hi,

maybe someone could help me configuring namespace ACL's correctly.

I have the ACL configured:
doku:kunden:*   @ALL    0

No Site below doku:kunden ist displayed, so the ACL is working as it should. But if I go to the Site Index
doku.php?idx=doku:kunden all the namespaces (no sites)   below are shown :-( eg: doku:kunden:kunde1, doku:kunde:kunde2

I don't want that everyone could see the name of my customers.

Is this a bug, or is there a way to configure this properly?

Thanks for Your help!

Klaus
This post was edited on 2006-07-28, 16:08 by goblin.
Avatar
lornajane #2
Member since Jul 2006 · 14 posts
Group memberships: Members
Show profile · Link to this post
I think that is expected behaviour - the access control won't hide pages from the listings or links that the user doesn't have access to, but it won't let the user actually view that page.
LornaJane ( www.lornajane.net )
Avatar
goblin #3
Member since Jul 2006 · 4 posts
Group memberships: Members
Show profile · Link to this post
Hi,

thanks for your reply!

I think you are not right. The Pages are hidden from the listings in the automatically generated index, only the namespaces are not.  Sure, if you make a link to a page a user dont have access to, this link is not hidden.

Bye
Avatar
goblin #4
Member since Jul 2006 · 4 posts
Group memberships: Members
Show profile · Link to this post
Solved the problem myself.

# diff inc/search.php inc/search.php.DIST
136,139c136
<   // changed
<   // Don't want to display empty namespaces that are not allowed by ACL
<   //
<   if(auth_quickaclcheck($id) < AUTH_READ){
---
>   if($type=='f' && auth_quickaclcheck($id) < AUTH_READ){

Bye
Avatar
efege #5
Member since Jun 2007 · 13 posts
Group memberships: Members
Show profile · Link to this post
The sneaky_index config option solves this problem. Check this thread: http://forum.dokuwiki.org/thread/672.
Avatar
goblin #6
Member since Jul 2006 · 4 posts
Group memberships: Members
Show profile · Link to this post
Thanks for this hint. This thread was started about 1 year ago. This option doesn't exist in a dokuwiki installation at this time and i had to find a solution myself.

I want to thank the dokuwiki developers for the continuous work on this fine wiki!

Bye
Klaus
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2020-01-18, 12:19:07 (UTC +01:00)