Not logged in. · Lost password · Register
Forum: General Help and Support Syntax and Usage RSS
Automatically uploading large number of images to dokuwiki
Avatar
tomkeus #1
Member since Mar 2015 · 5 posts
Group memberships: Members
Show profile · Link to this post
Subject: Automatically uploading large number of images to dokuwiki
When I copy a bunch of images to /data/media/wiki they remain inaccessible from the wiki. The only way to be able to access them is by uploading them from the Media Manager. I presume this is due to the need to cache the images or something similar.

Since my dokuwiki content is automatically generated from the calculations I am running and it is too laborious and error prone for me to manually deal with the images, is there any way to circumvent this behavior and just force dokuwiki externally to accept the images?
Avatar
turnermm (Moderator) #2
Member since Oct 2009 · 4741 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
This is possibly a permissions issue.  The files have to be readable by the web server.
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
eilko #3
Member since Feb 2012 · 22 posts
Group memberships: Members
Show profile · Link to this post
and check the naming of the files. At my server I don't see files that have upper case and special characters in its name. When I upload them via dokuwiki I see that these files get renamed, but uploading them directly doesn’t change the name.
Avatar
turnermm (Moderator) #4
Member since Oct 2009 · 4741 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
Yes.  See https://www.dokuwiki.org/pagename for Douwiki's page naming conventions.
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
Avatar
tomkeus #5
Member since Mar 2015 · 5 posts
Group memberships: Members
Show profile · Link to this post
In reply to post #2
Quote by turnermm on 2015-09-17, 14:59:
This is possibly a permissions issue.  The files have to be readable by the web server.

Yup that was it. Thanks. Just needed to chmod 644
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2019-12-14, 08:29:59 (UTC +01:00)