Not logged in. · Lost password · Register
Forum: General Help and Support Installation and Configuration RSS
problems with PHP 7.1
Avatar
HonkXL #1
Member since Dec 2016 · 1 post
Group memberships: Members
Show profile · Link to this post
Subject: problems with PHP 7.1
Today I tried to upgrade my server to PHP 7.1 (from PHP 7.0). After this, the layout of DokuWiki looked completely wrong.
Then I downgraded.

What can I do to swith to PHP 7.1?
Avatar
turnermm (Moderator) #2
Member since Oct 2009 · 4755 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
See: https://forum.dokuwiki.org/thread/14303
Make sure all your  plugins and your template are PHP 7 ready.
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
Avatar
andi (Administrator) #3
User title: splitbrain
Member since May 2006 · 3509 posts · Location: Berlin Germany
Group memberships: Administrators, Members
Show profile · Link to this post
You will also need a current development version of DokuWiki. The current stable is not compatible with PHP 7.1, yet.
Read this if you don't get any useful answers.
Lies dies wenn du keine hilfreichen Antworten bekommst.
Avatar
raksasas #4
Member since Feb 2017 · 11 posts · Location: Central Texas
Group memberships: Members
Show profile · Link to this post
Quote by andi on 2016-12-14, 09:02:
You will also need a current development version of DokuWiki. The current stable is not compatible with PHP 7.1, yet.

Is this still the case with stable 2017-02-19a?

From what I can tell I have the wiki running with php 71. Currently having a problem when I click "install" when wanting to install a plugin from within the Extension Manager.

Got the plugins working. I didn't have php71-zlib installed...
This post was edited on 2017-02-26, 00:50 by raksasas.
Avatar
LMS23 #5
Member since Feb 2014 · 174 posts · Location: Bayern, Deutschland
Group memberships: Members
Show profile · Link to this post
i have no problems with my dw on php 7.1:

version      Release 2017-02-19b "Frusterick Manners"
webserver      nginx/1.6.2
php_version      7.1.2
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2020-01-18, 07:48:49 (UTC +01:00)