Not logged in. · Lost password · Register
Forum: General Help and Support Features and Functionality RSS
Surprising memory errors loading images
Avatar
espiegel #1
Member since Mar 2013 · 59 posts
Group memberships: Members
Show profile · Link to this post
Subject: Surprising memory errors loading images
Over the last few months some change on our server (which is on a shared server) has resulted in images (local on the server) not loading. These are mostly jpgs and png files that have dimensions from 512*256 to 800*600.

The log shows errors like this:

[Wed Dec 21 10:06:19 2016] [error] [client 107.207.36.154] File does not exist: /home/metas1/public_html/500.shtml, referer: http://metasynth.com/wikifarm/artmatic/doku.php/artmatic:e…
[Wed Dec 21 10:06:19 2016] [error] [client 107.207.36.154] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/metas1/public_html/wikitop/lib/exe/indexer.php, referer: http://metasynth.com/wikifarm/artmatic/doku.php/artmatic:e…


I get these errors whether images are being resized or not.

It happens even if I turn off all plugins. I use the lightbox plugin and thought that it might be related. But that seems not to be the case.

Here are a few pages where you can see the problem:

http://metasynth.com/wikifarm/artmatic/doku.php/blog:itbl_…

http://metasynth.com/wikifarm/artmatic/doku.php/artmatic:e…



I have seen a few reports that indicate that others have run into this issue but haven't seen anything about whether there is something one can do to solve it. I have tried every possible setting that I can think of that might be relevant but found nothing that has an impact.

Thank you,

In desperation,

Edward
Avatar
turnermm (Moderator) #2
Member since Oct 2009 · 3518 posts · Location: Canada
Group memberships: Global Moderators, Members
Show profile · Link to this post
Can your run this locally?  If it works locally and not on the shared server, then the likelihood is that the shared server is overbooked.
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
Avatar
espiegel #3
Member since Mar 2013 · 59 posts
Group memberships: Members
Show profile · Link to this post
It works fine on the local server (I downloaded the copy into an empty directory from the remote server to make sure that they are identical).

It does seem like something weird with the shared server's resource allocation -- but our site doesn't get a lot of traffic -- and there haven't been problems in the past. They seem to have some secret new resource limits that they won't share. I just got off the phone with their support people whose response was "we can see that your resource usage is generally low but some activity has triggered a CPU and memory limitation for you -- but I can't tell you more than that. We recommend that you consider modernizing your website. Perhaps dokuwiki demands too many resources."

So, I don't really know what to do.
Avatar
turnermm (Moderator) #4
Member since Oct 2009 · 3518 posts · Location: Canada
Group memberships: Global Moderators, Members
Show profile · Link to this post
You'll excuse the expression -- but that's a lot of bull.  It doesn't have anything to do with your use of resources but with their overselling capacity.  You should shop around for a new hosting service.
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
Avatar
turnermm (Moderator) #5
Member since Oct 2009 · 3518 posts · Location: Canada
Group memberships: Global Moderators, Members
Show profile · Link to this post
Here is an interesting offer: http://www.informatick.net/

And checkout this page: https://www.dokuwiki.org/hosting
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
Avatar
espiegel #6
Member since Mar 2013 · 59 posts
Group memberships: Members
Show profile · Link to this post
Thanks! It really felt like I was getting a runaround. Time to start looking for a new host.

It is a shame. For a number of years, they were a good ISP.
Avatar
espiegel #7
Member since Mar 2013 · 59 posts
Group memberships: Members
Show profile · Link to this post
I have now tested this particular dokuwiki on a few different hosts and I am getting these out of memory errors on several but not all of them. It seems to be fetch.php and indexer.php that are most likely to trigger them.

A typical one is:

[Wed Dec 28 15:43:48.731623 2016] [:error] [pid 105282] (12)Cannot allocate memory: [client myipaddress:51333] couldn't create child process: /opt/suphp/sbin/suphp for /home/edward41/public_html/wikitop/lib/exe/fetch.php, referer: http://edwardspiegel.org/wikifarm/artmatic/doku.php/artmat…

Is there some setting in dokuwiki that can be used to reduce the memory load?

Best,

Edward
Avatar
turnermm (Moderator) #8
Member since Oct 2009 · 3518 posts · Location: Canada
Group memberships: Global Moderators, Members
Show profile · Link to this post
Then why don't you persist with one which is working for you and and see how far you get?
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2017-02-21, 06:50:02 (UTC +01:00)