Not logged in. · Lost password · Register
Forum: Community dokuwiki.org RSS
Does PHPMailer critical bug concern dokuwiki or any Plugin?
Avatar
feeghib #1
Member for 2 months · 2 posts · Location: France
Group memberships: Members
Show profile · Link to this post
Subject: Does PHPMailer critical bug concern dokuwiki or any Plugin?
Hello all!

I read on a french website that all PHPMailer versions prior to the 5.2.18 one (that was released on christmas day) are vulnerable.
More informations available on that english website:
Millions of Websites Vulnerable Due to Security Bug in Popular PHP Script

So, I wonder if that PHPMailer critical bug concerns either dokuwiki or any plugin like Bureaucracy. Using recursive grep, I didn't saw any occurrence of the word "phpmailer" in the source code of dokuwiki. But when I read and try to translate that post, I'm affraid any portion of dokuwiki may rely on PHPMailer.

Does anybody know if dokuwiki is concerned?

Best regards
Avatar
turnermm (Moderator) #2
Member since Oct 2009 · 3518 posts · Location: Canada
Group memberships: Global Moderators, Members
Show profile · Link to this post
I doubt that this is a problem.  Dokuwiki has its own Mailer.class.  But if you are concerned, write to the mailing list: https://www.dokuwiki.org/mailinglist.
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
Avatar
feeghib #3
Member for 2 months · 2 posts · Location: France
Group memberships: Members
Show profile · Link to this post
Thanks for your response.
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2017-02-21, 06:47:48 (UTC +01:00)