Not logged in. · Lost password · Register
Forum: General Help and Support Installation and Configuration RSS
Your PHP seems to miss SSL support. Downloading will not work for many DokuWiki extensions.
Page:  1  2  next 
Avatar
MichaelWaterman #1
Member since Jan 2017 · 6 posts · Location: the Netherlands
Group memberships: Members
Show profile · Link to this post
Subject: Your PHP seems to miss SSL support. Downloading will not work for many DokuWiki extensions.
Hi all,

I've seen to be having a problem with my DokuWiki site. When I login and browse to the extensions page I get this message:

"Your PHP seems to miss SSL support. Downloading will not work for many DokuWiki extensions."

And indeed no extensions can be downloaded. To be honest I have no idea where to begin. Is there anyone that can assist?

Thanks in advance.

Michael
Avatar
MichaelWaterman #2
Member since Jan 2017 · 6 posts · Location: the Netherlands
Group memberships: Members
Show profile · Link to this post
Fixed it!

I'm running dokuwiki on a sinology NAS and upgraded the software (Incl php) last week. Apparently the openssl extension wasn't enabled by default, hence the error message. After enabling the openssl in the php extension interface it started working again!

Hope anyone can make use of this information!

Michael
Avatar
courtland #3
Member since Mar 2015 · 96 posts · Location: USA
Group memberships: Members
Show profile · Link to this post
I had that issue when I installed it on a VPS and I got frustrated and took it back to shared hosting. I bet this was the issue for my install as well, thanks! I'll try it again on my VPS.
Courtland
Avatar
raksasas #4
Member since Feb 2017 · 11 posts · Location: Central Texas
Group memberships: Members
Show profile · Link to this post
I had to install php##-openssl.  The message went away after I installed and restarted apache.
Avatar
bmentink #5
Member since Sep 2014 · 24 posts
Group memberships: Members
Show profile · Link to this post
In reply to post #2
Quote by MichaelWaterman on 2017-01-06, 21:54:
Fixed it!

I'm running dokuwiki on a sinology NAS and upgraded the software (Incl php) last week. Apparently the openssl extension wasn't enabled by default, hence the error message. After enabling the openssl in the php extension interface it started working again!

Hope anyone can make use of this information!

Michael

Can you elaborate a bit more on how you enabled this. I have the same issue running dokuwiki on FreeNAS..
Thanks
Avatar
Megachip #6
Member since Nov 2017 · 9 posts
Group memberships: Members
Show profile · Link to this post
Dear Community,

I've the same problem with a Synology NAS. Openssl and imap are activated (phpinfo shown this) but DokuWiki told me, that both are not supported/activated :(

Quote by bmentink on 2017-04-03, 22:04:
Can you elaborate a bit more on how you enabled this. I have the same issue running dokuwiki on FreeNAS..
Thanks
Go to WebStation and than php settings. Edit your default profile and activate the necessary extensions.


Best,
Meg
Avatar
Ragnvald #7
Member since Dec 2017 · 1 post
Group memberships: Members
Show profile · Link to this post
Hi
There is something else weird here.

I have two of these Synology's.

Both behave the same way ("Your PHP seems to miss SSL support. ") and both have imap and open-ssl activated as described.

But that does not help.

Some idea about where to start looking would be much appreciated. It did work...

All the best

Ragnvald
Avatar
PJO #8
Member since Aug 2015 · 9 posts
Group memberships: Members
Show profile · Link to this post
I have the same problem following unintentionally allowing DSM to install beta software. I now have two versions of Apache (2.2 and 2.4) and of MariaDB (5 and 10) and of PhP (5.6 and 7).

I have already got a commercial certificate installed for https but get the same error message when looking to update extensions

It seems that php.ini is missing some settings. See https://www.softaculous.com/board/index.…?tid=7440&t…

I tried setting the values for openssl.cafile and openssl.capth as follow, respectively to

/usr/syno/etc/certificate/system/default/cert.pem

and

/usr/syno/etc/certificate/system/default/cert.pem

in /usr/syno/etc/packages/WebStation/php56/php.ini and then in the WebStation PHP 5.6 Settings

-- restarting the web server (and dokuwiki). Neither resolved the problem, but I think I'm somewhere close.

The following command at a terminal prompt

$ php -r "print_r(openssl_get_cert_locations());"

yields

Array
(
    [default_cert_file] => /etc/ssl/cert.pem
    [default_cert_file_env] => SSL_CERT_FILE
    [default_cert_dir] => /etc/ssl/certs
    [default_cert_dir_env] => SSL_CERT_DIR
    [default_private_dir] => /etc/ssl/private
    [default_default_cert_area] => /etc/ssl
    [ini_cafile] =>
    [ini_capath] =>
)

even after I've tried to update these, so I'd guess I'm not making the changes in the right place. Perhaps it should be here:

/usr/local/etc/php56/php.ini

I'll try this tomorrow -- if it's not going to work I don't want to know just now.

Incidentally, the openssl and mcrypt boxes are checked in the WebStation's list of PhP extensions.
Avatar
turnermm (Moderator) #9
Member since Oct 2009 · 4762 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
You  have to install ssl support in php.  This is separate from https support on the server.  It generally comes pre-installed in linux php.  But in Windows you may have to enable the extension in php.ini.
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
Avatar
PJO #10
Member since Aug 2015 · 9 posts
Group memberships: Members
Show profile · Link to this post
I'm using Linux. OpenSSL is installed and the extension is enabled.

In my case, like some others here, I'm using a Synology Diskstation which was borked by a software "upgrade". Fortunately, it's only something I was playing around with as a background project but Synology's lack of quality control over updates is worrying. I tried removing and reinstalling Dokuwiki and also switching to PhP 7, without result.

This may help if I can understand what's needed https://secure.php.net/manual/en/migration56.openssl.php
This post was edited on 2018-01-09, 13:15 by PJO.
Avatar
turnermm (Moderator) #11
Member since Oct 2009 · 4762 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
Create a php file containing the following:
<?php
phpinfo();

Then load this file into your browser.  It should contain a section labeled openssl.  Or, if you have command line access type the following at the command line:

php -m

That will give you a list of the enabled extensions and should contain openssl.  If these report that you have ssle enabled, then it's possible that your php can't find the ssl libraries.  In that case  perhaps one of these comments might help, even though they are diurfected at Windows:  http://php.net/manual/en/openssl.installation.php
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
Avatar
PJO #12
Member since Aug 2015 · 9 posts
Group memberships: Members
Show profile · Link to this post
Thanks, just getting back to this.

Openssl is enabled (checked with php -m)

My sites-enabled folder (/usr/local/etc/apache22/sites-enabled) contains a file called dokuwiki.conf with only the following:

<Directory "/var/services/web/dokuwiki">
    <IfModule fastcgi_module>
        AddHandler php-fastcgi .php .php3 .php4 .php5 .php7 .phtml
        Action php-fastcgi /php70-fpm-handler.fcgi
    </IfModule>
</Directory>

I think some changes are needed here.
Avatar
turnermm (Moderator) #13
Member since Oct 2009 · 4762 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
Your solution may be to load the required module, as suggested in the link above.
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
Avatar
PJO #14
Member since Aug 2015 · 9 posts
Group memberships: Members
Show profile · Link to this post
I adapted the config file here: https://freedif.org/dokuwiki-host-your-own-wiki-on-your-se…

and replaced the dokuwiki.conf file. However, I have no idea if the .conf is significant or not (the article says a "dokuwiki" file not a "dokuwiki.conf" file).

It didn't change things. Meanwhile, I have found on the Synology forum where others have reported difficulties relating to the same software update which broke things:

I did the following to fix it

1 Uninstalled Apache 2.2 and 2.4
2 Uninstalled Web Station Beta
3 Unselected the show me beta version setting in the Package Center
4 Installed the vanilla Web Station from the Package Center
5 Re-installed Apache 2.2 and 2.4 from the Package Center
6 Started vanilla Web Station and I could configure my missing settings
7 Clear the auto-update option in the Web Station package settings
8 My sites are working again, phew!


I'm running the latest (beta) version of Webstation and it looks like I'll have to either wait or go through the rigamarole above. Alternatively, not use my Synology for this.
Avatar
andi (Administrator) #15
User title: splitbrain
Member since May 2006 · 3512 posts · Location: Berlin Germany
Group memberships: Administrators, Members
Show profile · Link to this post
In reply to post #12
Quote by PJO:
Openssl is enabled (checked with php -m)

The commandline PHP may use a different config than the one used for the web. So you have to create a phpinfo file (as described by turnermm) and look at it through your web browser.

Quote by PJO:
My sites-enabled folder (/usr/local/etc/apache22/sites-enabled) contains a file called dokuwiki.conf with only the following:

I think some changes are needed here.

No. The check done by dokuwiki is actually pretty simple. It checks that ssl is a registered stream transport. That transport gets registered automatically when the SSL PHP extension is loaded. This has absolutely nothing to do with the webserver configuration. Since your command line PHP has the extension all you need to do is to enable it for the web as well.

So what you need to do is:

  • confirm that the extension is missing as described by turnermm
  • find the correct php.ini file used by FPM
  • ensure the php.ini loads the SSL extension

Maybe check the synology forums if someone can help you with that.
Read this if you don't get any useful answers.
Lies dies wenn du keine hilfreichen Antworten bekommst.
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Page:  1  2  next 
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2020-01-27, 19:00:51 (UTC +01:00)