Not logged in. · Lost password · Register
Forum: General Help and Support General Stuff RSS
[SOLVED] Synchronize Wikis Plugin - Parse error: syntax error, unexpected T_OBJECT_OPERATOR
Avatar
Rotten Ronnie #1
User title: wiki.RedDirtRiders.com
Member since Feb 2015 · 10 posts · Location: Charlottetown PE, Canada
Group memberships: Members
Show profile · Link to this post
Subject: [SOLVED] Synchronize Wikis Plugin - Parse error: syntax error, unexpected T_OBJECT_OPERATOR
I've got XMLRPC enabled on the remote server, and it used to work fine until post upgrade.

I now get an error message when selecting a profile:
Failed to talk to remote wiki. Make sure the remote wiki allows XMLRPC requests and that you set up the endpoint URL correctly. parse error. not well formed

I navigated to the XMLRPC URL https://mysite.com/lib/exe/xmlrpc.php and got this error message:
 
Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /home/mysite/public_html/dokuwiki/lib/exe/xmlrpc.php on line 7

I edited line 7 of the file and commented it out for testing, and the sync worked perfectly.
//if(!$conf['remote']) die((new IXR_Error(-32605, "XML-RPC server not enabled."))->getXml());


Any ideas? Should I create an issue on github?
This post was edited on 2017-03-09, 03:53 by Rotten Ronnie.
Avatar
turnermm (Moderator) #2
Member since Oct 2009 · 3896 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
I would report this as an issue on the github plugin page.
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
Avatar
Rotten Ronnie #3
User title: wiki.RedDirtRiders.com
Member since Feb 2015 · 10 posts · Location: Charlottetown PE, Canada
Group memberships: Members
Show profile · Link to this post
For future reference to other users that encounter this issue...

PHP 5.3 will throw this error.

I'm hosted on a legacy server and can't upgrade it myself. :'(

On the plus side, the hosting is free, so I can only complain where others won't hear me.
Avatar
turnermm (Moderator) #4
Member since Oct 2009 · 3896 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
I assume you mean 5.3.3?  At the moment, I believe that 5.3. 4 is the minimum required.  So this may not be a valid reportable error.
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
This post was edited on 2017-03-09, 04:36 by turnermm.
Avatar
Rotten Ronnie #5
User title: wiki.RedDirtRiders.com
Member since Feb 2015 · 10 posts · Location: Charlottetown PE, Canada
Group memberships: Members
Show profile · Link to this post
Quote by turnermm:
I assume you mean 5.3.3?  At the moment, I believe that 5.3. 4 is the minimum required.

Sadly, it is specifically PHP Version 5.3.29

I'll keep my fingers crossed and hope for the best.
Avatar
turnermm (Moderator) #6
Member since Oct 2009 · 3896 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
5.3.29 is more recent than 5.4.

That should have been "more recent than 5.3.4."
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
This post was edited on 2017-03-09, 17:07 by turnermm.
Avatar
andi (Administrator) #7
User title: splitbrain
Member since May 2006 · 3187 posts · Location: Berlin Germany
Group memberships: Administrators, Members
Show profile · Link to this post
In reply to post #3
Quote by Rotten Ronnie:
I'm hosted on a legacy server and can't upgrade it myself. :'(

Just as a heads up. The next release will require 5.6 at least (maybe higher) better start thinking about how to move to a sane server.
Read this if you don't get any useful answers.
Lies dies wenn du keine hilfreichen Antworten bekommst.
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2017-11-22, 06:42:20 (UTC +01:00)