Not logged in. · Lost password · Register
Forum: General Help and Support Installation and Configuration RSS
Cannot stay logged in as admin
I can log in as admin but get logged out as soon as I visit any page beyond the first one
Page:  previous  1  2 
Avatar
freecicero #16
Member for 2 months · 7 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 60195
In hopes that my work will help someone I will post what I try:

First, I have found that something breaks when I copy my /data directory to a new dokuwiki I set up for testing purposes.  I first set up a new install and verified that it was running and I could access admin panel.  I then copied the /pages subdirectory over, and the new installation continued to work. Then I copied the entire /data directory over and started getting the same area again.
Avatar
freecicero #17
Member for 2 months · 7 posts
Group memberships: Members
Show profile · Link to this post
Subject: Data Points:  Some Browsers have this problem while other browsers do not.
I have made a significant discovery.   I run MX-17 Linux and have chrome, palemoon, brave and Seamonkey installed.  They all exhibit the same maddening error - login appears to work, but as soon as I try to edit a page, go to the admin panel, or even refresh the page, it logs me out.

HOWEVER I also have qupzilla2.2.2.appimage running on my machine, and when I access my wiki through that, it works fine! Editing is fine! Admin panel is fine! Saving changes is fine! It never logs me out!

Now what could explain that?

(Note 1:  This is after downloading the updated /inc/init.php which has the changed lines 45/46.  I am not sure if that change has anything to do with Qupzilla working, or whether Qupzilla would have worked without the change.  All I know is that the same wiki that won't let me stay logged in with Chrome, Brave, Palemoon, or Seamonkey WILL let me stay loggedin qith Qupzilla222.appimage)

Note 2:  I am continuing to test other browsers.  Netsurf also works - like Qupzilla222.appimage, it does not log me out.

Note 3:  I just realized I had an older version of Qupzilla.  Downloaded the latest appimage2.2.6 and that works too.

Note 4:  HOWEVER, after copying the Qupzilla 2.2.6 appimage to a second computer - same problem as before!!! Qupzilla appimage fails like Chrome, Palemoon, etc.  HOWEVER Netsurf DOES work on the second computer.  So the same second computer that continously logs out under Chrome/Qupzilla does NOT have that issue under Netsurf.

Note 5:  Computer 3 - Chrome/Brave/Seamonkey/Palemoon continuously log out.  Qupzilla DOES work on this one - no logouts (did not test Netsurf but bet it would work here too.)

Note 6:  Virtualbox running W7 - Chrome exhibits the same faulty operation issue.  Virtualbox running XP - Both Seamonkey (downloaded today) and Slimjet (Version 10.0.13.0 (based on Chromium 50.0.2661.75)) do NOT display the same faulty problem - both operate fine.

Note 7:  I also find that I can edit properly on my android tablet.
This post was edited 6 times, last on 2018-04-29, 00:42 by freecicero.
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Page:  previous  1  2 
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2018-05-20, 13:54:14 (UTC +02:00)