Not logged in. · Lost password · Register
Forum: General Help and Support Installation and Configuration RSS
Admin
Avatar
p3aul #1
Member since Aug 2006 · 19 posts
Group memberships: Members
Show profile · Link to this post
Subject: Admin
I'm having trouble accessing the admin feature. I have changed local.php renamed the other two files from .dist to php but I still don't get the admin button. Oh, yes, I have changed permissions to 777  also
Thanks,
Paul
Avatar
BlackFog #2
Member since May 2006 · 95 posts
Group memberships: Members
Show profile · Link to this post
Did you activated the acl's? It's prerequisite ;)


BlackFog
Avatar
p3aul #3
Member since Aug 2006 · 19 posts
Group memberships: Members
Show profile · Link to this post
I'm not sure. How do I do that?
Thanks,
Paul
Avatar
p3aul #4
Member since Aug 2006 · 19 posts
Group memberships: Members
Show profile · Link to this post
In reply to post #2
I'm not sure. How do I do that?
Thanks,
Paul
Avatar
koko #5
Member since May 2006 · 161 posts · Location: Zonhoven Belgium
Group memberships: Members
Show profile · Link to this post
In reply to post #3
You have to change the config-file of dokuwiki:

Enable the variable to use ACL en set yourself as superuser. To help you with this: http://wiki.splitbrain.org/wiki:acl
Programming today is a race between software engineers striving to build bigger and better idiot-proof programs, and the Universe trying to produce bigger and better idiots. So far, the Universe is winning.
Avatar
p3aul #6
Member since Aug 2006 · 19 posts
Group memberships: Members
Show profile · Link to this post
Ok I have renamed the dist files to .PHP I have changed local.php to give me admin privileges, but I still don't see the button. Do I have to move the files I renamed to a different folder? The manual said something about using command-line to create an encryped password. I don't have telnet access to my server.
Paul
Avatar
koko #7
Member since May 2006 · 161 posts · Location: Zonhoven Belgium
Group memberships: Members
Show profile · Link to this post
hi,

No need to. Did you also make users.auth.php? If you didn't, try to read the link i gave you.
The steps you have to follow:
  * Enable ACL (in config)
  * Choose the way your users will be controlled (most fo the time plain)
  * Choose your nickname and set it as superuser
  * Make the files (users.auth.php en check for acl.auth.php)
  * Make a user manually (your variables; you can read this in http://wiki.splitbrain.org/wiki:auth:plain)
  * Finetune your installation

These are the rough steps you have to take. If it still doesn't work, just come to our IRC-channel: #dokuwiki :-D
Programming today is a race between software engineers striving to build bigger and better idiot-proof programs, and the Universe trying to produce bigger and better idiots. So far, the Universe is winning.
Avatar
p3aul #8
Member since Aug 2006 · 19 posts
Group memberships: Members
Show profile · Link to this post
Ok. Is # a comment in PHP? I uncommented lines that looked like PHP and left the instructions commented.
This is what I have for users.auth.php
users.auth.php
 <?php exit()?>
 Don't modify the lines above

 Userfile

 Format:

 user:MD5password:paul:email:admin,user
Under Local.php I did this:
<?php
/*
  This is an example of how a local.php coul look like.
//  Simply copy the options you want to change from dokuwiki.php
// to this file and change them
 


$conf['title']       = 'My Wiki';        //what to show in the title

$conf['useacl']      = 1;                //Use Access Control Lists to restrict access?
$conf['superuser']   = '@admin';

/* The following options are usefull, if you use a MySQL
 * database as autentication backend. Have a look into
 * mysql.conf.php too and adjust the options to match
 * your database installation.
 */
$conf['authtype']   = 'mysql';

I commented out //require_once ("mysql.conf.php");
since since I don't use Mysql with dokuwiki.
Avatar
koko #9
Member since May 2006 · 161 posts · Location: Zonhoven Belgium
Group memberships: Members
Show profile · Link to this post
hi,

You have to change
$conf['authtype']   = 'mysql';
to I think
$conf['authtype']   = 'plain';
Programming today is a race between software engineers striving to build bigger and better idiot-proof programs, and the Universe trying to produce bigger and better idiots. So far, the Universe is winning.
Avatar
p3aul #10
Member since Aug 2006 · 19 posts
Group memberships: Members
Show profile · Link to this post
Ok this is what I have now, but still no login button :'(

$conf['useacl']      = 1;                //Use Access Control Lists to restrict access?
$conf['superuser']   = '@admin';

/* The following options are usefull, if you use a MySQL
 * database as autentication backend. Have a look into
 * mysql.conf.php too and adjust the options to match
 * your database installation.
 */
$conf['authtype']   = 'plain';
//require_once ("mysql.conf.php");
Avatar
purplepaisley #11
Member since May 2006 · 142 posts · Location: UK
Group memberships: Members
Show profile · Link to this post
Your local.php looks correct, as long the filename is "local.php" and not "Local.php as you have and is in the dokuwiki/conf/ directory?
Avatar
p3aul #12
Member since Aug 2006 · 19 posts
Group memberships: Members
Show profile · Link to this post
Yes, my file name is all lower case(local.php). So what is wrong?
Thanks,
Paul
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2020-02-26, 14:56:15 (UTC +01:00)