Not logged in. · Lost password · Register
Forum: General Help and Support Installation and Configuration RSS
Admin - Configuration Panel is empty
Avatar
franc #1
Member since Sep 2009 · 22 posts
Group memberships: Members
Show profile · Link to this post
Subject: Admin - Configuration Panel is empty
Hallo
I have DokuWiki version 2017-02-19b „Frusterick Manners“ [49.2] on my server running. I know not since when, but if I try to open configuration in the admin section, there is an empty field. No errors visible there, just nothing, see Screenshot.
This is when I click on 'Konfiguration' in the Admin section.
Is there any logfile in Dokuwiki where I can have a look or am I thrown only to php logs?
Thank for a little hint.
Frank
The author has attached one file to this post:
Bildschirmfoto 2017-11-30 um 12.19.04.png 15.5 kBytes
You have no permission to open this file.
Avatar
franc #2
Member since Sep 2009 · 22 posts
Group memberships: Members
Show profile · Link to this post
I mean with admin section this, see Screenshot.
The author has attached one file to this post:
Bildschirmfoto 2017-11-30 um 12.18.50.png 44.6 kBytes
You have no permission to open this file.
Avatar
andi (Administrator) #3
User title: splitbrain
Member since May 2006 · 3330 posts · Location: Berlin Germany
Group memberships: Administrators, Members
Show profile · Link to this post
https://www.dokuwiki.org/faq:blankpage
Read this if you don't get any useful answers.
Lies dies wenn du keine hilfreichen Antworten bekommst.
Avatar
franc #4
Member since Sep 2009 · 22 posts
Group memberships: Members
Show profile · Link to this post
First I did comment out the line:

error_log = php_errors.log

in my php.ini (which is in my case in: /etc/php5/apache2/php.ini)
Then I could read in my dokuwiki folder:

[01-Dec-2017 22:17:51 Europe/Berlin] PHP Warning:  require_once(/var/www/example.org/wiki/inc/ZipLib.class.php): failed to open stream: No such file or directory in /var/www/example.org/wiki/lib/plugins/odt/renderer.php on line 20
[01-Dec-2017 22:17:51 Europe/Berlin] PHP Fatal error:  require_once(): Failed opening required '/var/www/example.org/wiki/inc/ZipLib.class.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/example.org/wiki/lib/plugins/odt/renderer.php on line 20

Indeedly, the file ZipLib.class.php is missing. I find it only in

lib/plugins/odt/ZipLib.class.php

and in some backups. I must have messed it up somehow :(
So I just copied it (which must not really be the real solution, I know) and back it is, the config site.
I must find the real reason why it was missing and find all other missing files if there any are, which I believe.

Thank, andi !

frank
Avatar
andi (Administrator) #5
User title: splitbrain
Member since May 2006 · 3330 posts · Location: Berlin Germany
Group memberships: Administrators, Members
Show profile · Link to this post
Some outdated plugin seems to be using a deprecated class there.
Read this if you don't get any useful answers.
Lies dies wenn du keine hilfreichen Antworten bekommst.
Avatar
turnermm (Moderator) #6
Member since Oct 2009 · 4292 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
I was using ZipLib in Windows installations for the epub plugin.  Is there any reason not to use it? If there is, then where do I find the API for splitbrain\PHPArchive\Zip or is there just the xref?  So far no one has complained, but I assume that's because they are using Linux and there I'm using the native zip as a fallback.

Just did a quick test and see that splitbrain\PHParchive\Zip, autoloaded, still gives me a functioning reference to ZipArchive and provides the few basic methods that I was using before.  No need to reply: I'm happy.
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
This post was edited on 2017-12-02, 03:26 by turnermm.
Avatar
franc #7
Member since Sep 2009 · 22 posts
Group memberships: Members
Show profile · Link to this post
After having still some difficulties with empty admin pages I installed again fresh from git, Version 49.5 stable.
The update with git merge is not as easy and self running as I thought.
Because I have some hacks, I thought merge would do that better, but I guess with the .gitignore there was some new stuff just missing.

Apart of that, I had a problem with the plugin redirect, I got an error in php:

[20-Mar-2018 12:21:15 Europe/Berlin] PHP Parse error:  syntax error, unexpected '.', expecting ',' or ';' in /var/www/ew6.org/wiki/lib/plugins/redirect/helper.php on line 19

Seems that there is the DOKU_CONF constant not known. I didnt skrutinize it but installed pageredirect Plugin, that works.
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2018-09-20, 11:05:15 (UTC +02:00)