Not logged in. · Lost password · Register
Forum: General Help and Support Installation and Configuration RSS
Solved - Unable to access Dokuwiki on LAN
Installed Docuwiki can access from local pc but no access from other pc's on LAN
Avatar
poggles #1
User title: poggles
Member for 3 months · 1 post
Group memberships: Members
Show profile · Link to this post
Subject: Solved - Unable to access Dokuwiki on LAN
Hello all,

I have been tasked to install Docuwiki on our isolated LAN.  After some research I settled on using the Xampp stack and the docuwiki package from Bitnami.  The installation and initial configuration went very smoothly with the only change being changing Apache to listen on Port 8090.

I can access and configure Docuwiki from my local PC but when I attempt to access from other PC's on my LAN I get an Error 404 Object not found.  The URL I am using is http://"IP of host PC:8090"/docuwiki/docu.php.

From the remote PC's I can access the Xampp homepage. URL http://"IP of host PC:8090"/

I realise that Xampp is not secure and should be used for local development but this is an isolated environment with no external connectivity.

The host PC is Windows 7,  Firewall has been configured to allow access,  as proven by connecting to Xampp homepage.

I think that it something to do with the Apache / PHP configuration files not pointing to the actual wiki files and this is where I am struggling as I do not have any experience of Apache / PHP or the stack.

I have edited rhe Apache httpd.conf file to point the document root to Docuwiki, ie C:/xampp/apps/docuwiki/htdocs but Apache refuses to start.  As soon as I change it back to the default Apache restarts.

Any pointers or help will be greatly appreciated

Edit - I have found some information on setting an Alias in httpd.conf.  After setting this I get an Error 403 Access Forbidden.  I have gave full permissions to Authenticated Users and checked that the Index.php file in in this alias location C:/xampp/apps/docuwiki/htdocs

Edit - After many rabbit holes I have managed to resolve this it was the location in the httpd.conf file where I was putting the alias that was wrong.
This post was edited 4 times, last on 2018-04-10, 11:49 by poggles.
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2018-07-16, 18:18:23 (UTC +02:00)