Not logged in. · Lost password · Register
Forum: General Help and Support General Stuff RSS
DokuWiki not load after upgrade
PHP Fatal error:  Uncaught Error: Call to undefined function json_encode()
Avatar
morube #1
Member since Nov 2017 · 4 posts
Group memberships: Members
Show profile · Link to this post
Subject: DokuWiki not load after upgrade
Hi,

After upgrade to 2018-04-22a "Greebo" when I try to load dokuwiki's web, blank page load instead my dokuwiki home page.
Apache2's error.log:

[Tue May 22 18:08:55.777023 2018] [:error] [pid 28924] [client 81.34.21.219:53089] PHP Fatal error:  Uncaught Error: Call to undefined function json_encode() in /var/www/html/dokuwiki/inc/template.php:343\nStack trace:\n#0 /var/www/html/dokuwiki/lib/tpl/bootstrap3/main.php(25): tpl_metaheaders()\n#1 /var/www/html/dokuwiki/inc/actions.php(27): include('/var/www/html/d...')\n#2 /var/www/html/dokuwiki/doku.php(120): act_dispatch()\n#3 {main}\n  thrown in /var/www/html/dokuwiki/inc/template.php on line 343

I'm running Raspian 9, I tried all posible solutions found but problem persist.

Any idea?

Thanks
Avatar
LarsDW223 #2
Member since Sep 2014 · 398 posts · Location: Paderborn
Group memberships: Members
Show profile · Link to this post
See https://forum.dokuwiki.org/thread/15812.
Avatar
morube #3
Member since Nov 2017 · 4 posts
Group memberships: Members
Show profile · Link to this post
Hi,

I saw the link https://forum.dokuwiki.org/thread/15812, I'm on php 7.0.27,
I had already installed php7.0-json but the problem persist.

Thanks
Avatar
turnermm (Moderator) #4
Member since Oct 2009 · 4629 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
Did you restart the web sever?
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
Avatar
morube #5
Member since Nov 2017 · 4 posts
Group memberships: Members
Show profile · Link to this post
yes....
Avatar
morube #6
Member since Nov 2017 · 4 posts
Group memberships: Members
Show profile · Link to this post
Purge php installation and then reinstall php works for me!.

Thanks
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2019-05-26, 17:38:44 (UTC +02:00)