Not logged in. · Lost password · Register
Forum: General Help and Support General Stuff RSS
Can't access the top page since I moved DokuWiki data between servers
Avatar
hokkaidoperson #1
Member since Apr 2018 · 35 posts · Location: Sapporo, Hokkaido, Japan
Group memberships: Members
Show profile · Link to this post
Subject: Can't access the top page since I moved DokuWiki data between servers
I'm setting the config 'start' with 'index', and using URL rewriting (https://www.dokuwiki.org/start?id=rewrite).
The top page in my wiki is https://jdwiki.hkdyukkuri.space/index.

However, since I moved the data between my old and new servers, I don't know why but the top page trys to access the page 'redirect:doku.php'.
I want to know how to fix this issue.
Thanks
Avatar
hokkaidoperson #2
Member since Apr 2018 · 35 posts · Location: Sapporo, Hokkaido, Japan
Group memberships: Members
Show profile · Link to this post
Now I am temporatily setting the redirect from https://jdwiki.hkdyukkuri.space/index to https://jdwiki.hkdyukkuri.space/ , but when I try to edit the top page, the system opens the screen to edit 'redirect:doku.php'.
This post was edited on 2018-06-10, 09:22 by hokkaidoperson.
Avatar
hokkaidoperson #3
Member since Apr 2018 · 35 posts · Location: Sapporo, Hokkaido, Japan
Group memberships: Members
Show profile · Link to this post
p.s.
The other pages can be accessed normally, so it may not be a problem with .htaccess .
Avatar
hokkaidoperson #4
Member since Apr 2018 · 35 posts · Location: Sapporo, Hokkaido, Japan
Group memberships: Members
Show profile · Link to this post
p.s.
I reuploaded all system files of DokuWiki, but the problem persists.
Avatar
turnermm (Moderator) #5
Member since Oct 2009 · 4347 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
There is probably an error in the rewrite rules in .htaccess.
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
Avatar
hokkaidoperson #6
Member since Apr 2018 · 35 posts · Location: Sapporo, Hokkaido, Japan
Group memberships: Members
Show profile · Link to this post
Mm...... but most pages can be accesed, this problem occurs only when I try to access the top page.

P.S. Also, I'm properly setting the htaccess file according to https://www.dokuwiki.org/rewrite .
Avatar
hokkaidoperson #7
Member since Apr 2018 · 35 posts · Location: Sapporo, Hokkaido, Japan
Group memberships: Members
Show profile · Link to this post
Subject: Something in the setting of my server resulted in this problem
I installed another DokuWiki to the same server, and I found that this problem surely occurs on my server when I did both of following things:
  * set URL rewriting according to https://www.dokuwiki.org/rewrite
  * set the config 'start' with 'index'

I wonder what kind of the setting of my server makes this problem...
Avatar
hokkaidoperson #8
Member since Apr 2018 · 35 posts · Location: Sapporo, Hokkaido, Japan
Group memberships: Members
Show profile · Link to this post
I found the cause!!
For example, when we access https://www.hkdyukkuri.space/index (my private website in Japanese), it shows the top page saved as index.html .  In short, the URL /index is accessable as well as /index.html .
Maybe that function causes the issue.
Now I am contacting the company hosting the server to ask how to invalidate the function.  This problem will soon be solved.
Avatar
StarArmy #9
Member since Nov 2011 · 46 posts
Group memberships: Members
Show profile · Link to this post
The responses on this page may be useful to you: https://stackoverflow.com/questions/7873634/why-does-index…
Avatar
hokkaidoperson #10
Member since Apr 2018 · 35 posts · Location: Sapporo, Hokkaido, Japan
Group memberships: Members
Show profile · Link to this post
The company managing my server said that I'm not allowed to change the setting to automatically load "/index.php" or "index.html" when "/index" is requested (this setting may cause the problem), and recommend me to use URL rewriting, but I couldn't do it well, so I just changed the start page from "index" to "indexpage".
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2018-10-21, 10:22:03 (UTC +02:00)