Not logged in. · Lost password · Register
Forum: General Help and Support Templates and Layout RSS
[Solved] Migrating a site to new server: Vector template not showing custom logo image
Avatar
foisys #1
Member since Oct 2009 · 39 posts · Location: Montreal,Qc
Group memberships: Members
Show profile · Link to this post
Subject: [Solved] Migrating a site to new server: Vector template not showing custom logo image
Hi,

I have a wiki running Vector that I created on my laptop (under Mac OS X) to keep all my docs organized and I just moved it to a new server (Synology) running latest DSM 6.2.

Everything works a-ok except one thing: I have created a custom logo for this template to give my wiki a little distinctive look ;-) The migrated site does not show it, only an empty spot in the top left corner...

My diagnostic so far:

- The file is in lib/tpl/vector/user;
- Its permissions are -rw-r--r--, so it can be read by anyone;
- The source code for the page seems to point toward the right location: <a href="/impilo/doku.php?id=origin" style="background-image:url(/impilo/lib/tpl/vector/user/logo.jpg);" accesskey="h" title="[ALT+H]"></a>
- It does bring me back to the index page specified (id=origin);
- Beside basic dokuwiki template, vector is my only template on this site.

Any idea to bring this logo back on my site?

Best regards

Sylvain
This post was edited on 2018-10-09, 01:47 by foisys.
Avatar
Michaelsy #2
Member since Jun 2015 · 573 posts · Location: Düsseldorf, Germany
Group memberships: Members
Show profile · Link to this post
Be aware that the image file must be accessible from the browser. That's why you can test this directly.

Its permissions are -rw-r--r--, so it can be read by anyone;

No, not by anyone outside the server (via url). Here play e.g. also settings in .htaccess a role.

Feedback welcome

HTH - Michael Sy.
By Patreon.com a few eurons can be fed into the code phasers of
the DokuWiki engine. Besides, Andi's posts are worth reading.
This post was edited on 2018-10-08, 18:19 by Michaelsy.
Avatar
foisys #3
Member since Oct 2009 · 39 posts · Location: Montreal,Qc
Group memberships: Members
Show profile · Link to this post
Hi,

Thanks for the input ;-) Permissions for this file is the same between my working site and kind-of-not-working site on the new server: it shows for the first but not for the later... I could chmod o-r for this file but I don't think that would fix this in any case since the web server would be able to read it anyway.

Best regards

S
Avatar
Michaelsy #4
Member since Jun 2015 · 573 posts · Location: Düsseldorf, Germany
Group memberships: Members
Show profile · Link to this post
The question is whether your web server wants to deliver this file to the browser or not. And that is e.g. depending on the .htaccess file(s).
By Patreon.com a few eurons can be fed into the code phasers of
the DokuWiki engine. Besides, Andi's posts are worth reading.
Avatar
foisys #5
Member since Oct 2009 · 39 posts · Location: Montreal,Qc
Group memberships: Members
Show profile · Link to this post
Hi,

Never used a .htaccess file before on a DokuWiki site... Just tried with Apache 2.2 instead of 2.4 and it works ;-) So will stick with 2.2 for the moment and investigate this.

So case closed ;-)

Best regards

S
Avatar
Michaelsy #6
Member since Jun 2015 · 573 posts · Location: Düsseldorf, Germany
Group memberships: Members
Show profile · Link to this post
Are you using an older version of DokuWiki?

Can you please put a [Solved] in the title?

Greetings - Michael Sy.
By Patreon.com a few eurons can be fed into the code phasers of
the DokuWiki engine. Besides, Andi's posts are worth reading.
Avatar
foisys #7
Member since Oct 2009 · 39 posts · Location: Montreal,Qc
Group memberships: Members
Show profile · Link to this post
Hi,

No I use the latest stable release...

Best regards

S
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2018-12-19, 03:10:54 (UTC +01:00)