Not logged in. · Lost password · Register
Forum: General Help and Support Plugins RSS
Tag Plugin
Nothing was found after clicking on the link with a tag
Avatar
andrewgmusic #1
Member since May 2018 · 8 posts
Group memberships: Members
Show profile · Link to this post
Subject: Tag Plugin
I installed the plugin tag and pagelist, then on different pages added the same tag {{tag>test}} and after clicking on it the page "nothing was found" appears. What do I change to make it work?
Avatar
Michaelsy #2
Member since Jun 2015 · 569 posts · Location: Düsseldorf, Germany
Group memberships: Members
Show profile · Link to this post
Did you already consider this note from the plugin documentation?

Nothing was found.
Same here, get a Nothing was found page.
(2017-03-28) I had the same problem. By coincidence, I switched to the default Dokuwiki template for an unrelated reason and got a different error when I clicked a tag link: “Helper plugin pagelist is not available.” Installed the pagelist plugin and then it worked. This dependency needs to be documented.

Feedback welcome - Michael Sy.
By Patreon.com a few eurons can be fed into the code phasers of
the DokuWiki engine. Besides, Andi's posts are worth reading.
Avatar
andrewgmusic #3
Member since May 2018 · 8 posts
Group memberships: Members
Show profile · Link to this post
Yes, the pagelist plugin is installed and I use default Dokuwiki template
Avatar
Michaelsy #4
Member since Jun 2015 · 569 posts · Location: Düsseldorf, Germany
Group memberships: Members
Show profile · Link to this post
For me it works. Are you using the latest version of DokuWiki (Greebo.a)?
By Patreon.com a few eurons can be fed into the code phasers of
the DokuWiki engine. Besides, Andi's posts are worth reading.
Avatar
andrewgmusic #5
Member since May 2018 · 8 posts
Group memberships: Members
Show profile · Link to this post
Yes, I use latest release. I don't have any idea how to risolve that
Avatar
virk #6
Member since Aug 2008 · 576 posts · Location: Aachen, Germany
Group memberships: Members
Show profile · Link to this post
1) Can you provide a link or is it a closed wiki?
2) Perhaps the index is broken. You can install "searchindex manager" to delete index and have it rebuilt.
Avatar
Michaelsy #7
Member since Jun 2015 · 569 posts · Location: Düsseldorf, Germany
Group memberships: Members
Show profile · Link to this post
In reply to post #5
Yes, I use latest release. I don't have any idea how to risolve that

Further step:

Take a look at the check view. To do that append ?do=check or &do=check to your URL.
Example1: http://www.dokuwiki.org/dokuwiki?do=check  (This URL actually works.)
Example2: http://www.yourdomain.com/doku.php?id=start&do=check

While you are logged in as superuser/admin.

Any abnormalities?
By Patreon.com a few eurons can be fed into the code phasers of
the DokuWiki engine. Besides, Andi's posts are worth reading.
This post was edited 2 times, last on 2018-11-13, 19:12 by Michaelsy.
Avatar
andrewgmusic #8
Member since May 2018 · 8 posts
Group memberships: Members
Show profile · Link to this post
In reply to post #6
It is a closed wiki. I've just rebuilt the index but the tag plugin is still not working
Avatar
andrewgmusic #9
Member since May 2018 · 8 posts
Group memberships: Members
Show profile · Link to this post
In reply to post #7
Any abnormalities?

appending ?do=check I get the check page https://i.imgur.com/ILi1gIU.jpg
appending ?do=check I get 404 error
Avatar
Michaelsy #10
Member since Jun 2015 · 569 posts · Location: Düsseldorf, Germany
Group memberships: Members
Show profile · Link to this post
Quote by andrewgmusic:
I get the check page https://i.imgur.com/ILi1gIU.jpg
As far as everything seems to be okay.

BTW: You can append a screenshot direct to your post. See underneath the reply window: "Post options".

I suppose you are using a self installed ubuntu system? A typical problem is that there are missing one (or more) PHP module(s).

So you should check your error log. Here are some hints where to find it: https://www.dokuwiki.org/faq:blankpage

If you use the Showphperrors plugin as a substitute, you have to activate it in the Configuration Settings after installation.
By Patreon.com a few eurons can be fed into the code phasers of
the DokuWiki engine. Besides, Andi's posts are worth reading.
Avatar
andrewgmusic #11
Member since May 2018 · 8 posts
Group memberships: Members
Show profile · Link to this post
I suppose you are using a self installed ubuntu system? A typical problem is that there are missing one (or more) PHP module(s).
Yes, it's a VPS server with ubuntu

If you use the Showphperrors plugin as a substitute
Showphperrors shows the following error when I click on a tag:
Notice: Undefined index: ns in /var/www/dokuwiki/lib/plugins/tag/action.php on line 82
I took a look at the line 82 and we can see there the following string: $ns    = trim($_REQUEST['ns']);
So, I suppose I won't be able to resolve it on my own because I am totally rookie at that. I rely on you guys
This post was edited on 2018-11-13, 23:57 by andrewgmusic.
Avatar
Michaelsy #12
Member since Jun 2015 · 569 posts · Location: Düsseldorf, Germany
Group memberships: Members
Show profile · Link to this post
With the Showphperrors plugin I get (among other messages) the same notice, when I click on the tags link. However as I said above, my system does the job...

Notice: Undefined index: ns in /homepages/18/d150228280/htdocs/subs/handy/dw1/lib/plugins/tag/action.php on line 82

So that does not seem to be an indication of the problem. And it's just a "Notice". I had rather hoped for an "Error" or the like.

One should consider that the actual error could occur when entering (resp. saving) the tag on the wiki page (not on clicking the tag-link).
By Patreon.com a few eurons can be fed into the code phasers of
the DokuWiki engine. Besides, Andi's posts are worth reading.
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2018-12-14, 22:55:51 (UTC +01:00)