Not logged in. · Lost password · Register
Forum: General Help and Support Plugins RSS
My Wiki Crached after installing a Plugin
Avatar
nassaleh #1
Member for a month · 4 posts
Group memberships: Members
Show profile · Link to this post
Subject: My Wiki Crached after installing a Plugin
Hi,
I am new to Wiki. I installed and it was working fine. I started expirimenting i started experimenting with plugins everything was great till I installed “toolbuttondel “ pluging. Now I get locked out of the wiki, I am getting “http error 500 “and could not reach my dokuwiki. I have access to the Ubuntu server that has the wiki installed on, can I deactivate the bag plugin or delete from the server. Please help
Avatar
LarsDW223 #2
Member since Sep 2014 · 344 posts · Location: Paderborn
Group memberships: Members
Show profile · Link to this post
You can simply remove the plugin by deleting the folder {dokuwiki-installation-dir}/lib/plugins/toolbuttondel.
Avatar
nassaleh #3
Member for a month · 4 posts
Group memberships: Members
Show profile · Link to this post
Thank you for the reply. When I tried to do that I got access denied, it has a lock on the ”toolbuttondel” folder
Avatar
LarsDW223 #4
Member since Sep 2014 · 344 posts · Location: Paderborn
Group memberships: Members
Show profile · Link to this post
You will need root/admin permissions to delete the folder. Do you have that? Be carefull that you only delete that folder, nothing else.
Avatar
nassaleh #5
Member for a month · 4 posts
Group memberships: Members
Show profile · Link to this post
I have admin root on the my user, but i think i have to log in as root. I will try that and let you know.
Thank you again,
Avatar
turnermm (Moderator) #6
Member since Oct 2009 · 4399 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
In reply to post #1
The plugin itself does not have a lock.  If you can't delete the folder from the command line or from ftp, and if you installed it using the extension manager, then it's because it belongs to the web server and you have no rights to it.  The "500" is probably a php error, so if you can, check your web server's error log for the error.  If you are on a hosted service, maybe the host administrator can help you delete the folder and identify the error.

If there is an error then it would be helpful to know what its is.  The plugin has been in use for 5 years without any previous issues, so there may be something in your setup, possibly a conflict with another plugin, that is causing this.  It would be helpful to know this so that it can be fixed.
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
Avatar
nassaleh #7
Member for a month · 4 posts
Group memberships: Members
Show profile · Link to this post
In reply to post #5
Thank you all.
It Worked
Avatar
turnermm (Moderator) #8
Member since Oct 2009 · 4399 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
What did you do?  And do you have any more information?
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2018-12-14, 22:51:27 (UTC +01:00)