Not logged in. · Lost password · Register
Forum: General Help and Support Templates and Layout RSS
Page Tools icons missing
Page:  1  2  next 
Avatar
User-RM #1
Member since Apr 2018 · 21 posts
Group memberships: Members
Show profile · Link to this post
Subject: Page Tools icons missing
Hi there,

I'm having an issue where my page tools are not showing. I was messing around with some of the files in the lib/tpl/dokuwiki directory and now I'm not sure what's gone wrong. The menu still displays the text; 'edit this page,' 'old revisions,' etc but the icons are missing. Anyone know how I can get the icons to show again?

Thanks in advance.
Avatar
Michaelsy #2
Member since Jun 2015 · 567 posts · Location: Düsseldorf, Germany
Group memberships: Members
Show profile · Link to this post
I was messing around with some of the files in the lib/tpl/dokuwiki directory...

You should restore the original content of this directory. You can find the files in the installation files.
By Patreon.com a few eurons can be fed into the code phasers of
the DokuWiki engine. Besides, Andi's posts are worth reading.
Avatar
User-RM #3
Member since Apr 2018 · 21 posts
Group memberships: Members
Show profile · Link to this post
Thanks for the reply, I restored the original files but I've still got the issue of the icons not showing. Not sure what's happening
Avatar
Michaelsy #4
Member since Jun 2015 · 567 posts · Location: Düsseldorf, Germany
Group memberships: Members
Show profile · Link to this post
You have a userstyle.css? Deactivate that (e.g. by renaming).
By Patreon.com a few eurons can be fed into the code phasers of
the DokuWiki engine. Besides, Andi's posts are worth reading.
Avatar
User-RM #5
Member since Apr 2018 · 21 posts
Group memberships: Members
Show profile · Link to this post
Ok I've deactivated it and it seems to have had no effect
Avatar
Michaelsy #6
Member since Jun 2015 · 567 posts · Location: Düsseldorf, Germany
Group memberships: Members
Show profile · Link to this post
Did you make sure that no cache (DokuWiki cache, browser cache) was accessed?
By Patreon.com a few eurons can be fed into the code phasers of
the DokuWiki engine. Besides, Andi's posts are worth reading.
Avatar
User-RM #7
Member since Apr 2018 · 21 posts
Group memberships: Members
Show profile · Link to this post
I've cleared both the browser and Dokuwiki cache
Avatar
Michaelsy #8
Member since Jun 2015 · 567 posts · Location: Düsseldorf, Germany
Group memberships: Members
Show profile · Link to this post
Have you included own CSS files in other ways? (e.g. via style.ini / bundled Styling plugin)

Have you made any changes in other original DokuWiki files (CSS, PHP)? (like you did in the default template)
By Patreon.com a few eurons can be fed into the code phasers of
the DokuWiki engine. Besides, Andi's posts are worth reading.
Avatar
User-RM #9
Member since Apr 2018 · 21 posts
Group memberships: Members
Show profile · Link to this post
I don't believe so, the only files I made changes to were main.php, detail.php,pagetools.less and userstyle.css if I remember correctly.
Avatar
Michaelsy #10
Member since Jun 2015 · 567 posts · Location: Düsseldorf, Germany
Group memberships: Members
Show profile · Link to this post
Here is a link to an unchanged standard DokuWiki installation (by me):
http://ts-imagescaling.informantum.de/doku.php?id=test.test

Find out where the HTML code or CSS code is different from your DokuWiki output. You can compare both outputs with a suitable browser tool like Firefox Inspector (<F12> and/or <Strg><Shift><C>).
By Patreon.com a few eurons can be fed into the code phasers of
the DokuWiki engine. Besides, Andi's posts are worth reading.
Avatar
User-RM #11
Member since Apr 2018 · 21 posts
Group memberships: Members
Show profile · Link to this post
Ok thank you, I'll have a look and see what I can find :)
Avatar
turnermm (Moderator) #12
Member since Oct 2009 · 4399 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
In reply to post #3
Make sure you have not somehow either deleted, removed web server access from, or in some other way blocked lib/images/menu, which is where the svg files for menu items are stored.
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
Avatar
Michaelsy #13
Member since Jun 2015 · 567 posts · Location: Düsseldorf, Germany
Group memberships: Members
Show profile · Link to this post
Quote by turnermm:
[...] lib/images/menu, which is where the svg files for menu items are stored.

You're right. And I learned something again, I misinterpreted my investigation of the HTML code.
By Patreon.com a few eurons can be fed into the code phasers of
the DokuWiki engine. Besides, Andi's posts are worth reading.
Avatar
User-RM #14
Member since Apr 2018 · 21 posts
Group memberships: Members
Show profile · Link to this post
Thanks both, I've checked the HTML code and CSS with the link you provided and also with another wiki I have running. Only difference I could see between my wiki and http://ts-imagescaling.informantum.de/doku.php?id=test.test was a <svg xmlns> tag. But comparing it with the second wiki I had running showed nothing, yet the page tools icons display on my second instance.

And I looked in the lib/images directory but couldn't see where the icons would be stored and not sure how I could have blocked access to it?
Avatar
turnermm (Moderator) #15
Member since Oct 2009 · 4399 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
If you didn't find lib\images\menu then for some reason the images are not installed or have been removed.  The menu icons are svg images.
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Page:  1  2  next 
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2018-12-14, 04:19:08 (UTC +01:00)