Not logged in. · Lost password · Register
Forum: General Help and Support Plugins RSS
Getting plugin:authsaml to work
user login works, but not functional
Avatar
datomtom #1
Member since Dec 2018 · 1 post
Group memberships: Members
Show profile · Link to this post
Subject: Getting plugin:authsaml to work
In my setup on a dedicated root server I have got a working simplesamlphp installation, which uses a SQL connection to authenticate users managed in a database. I tried to connect it with my dokuwiki installation. Hence I used the https://www.dokuwiki.org/plugin:authsaml ... a big thanks to the developers. I got it working to a point where the username (uid) gets propagated to dokuwiki apparently, since I get directed to the start-page and have the username in parentheses in the top right corner. Logging into dokuwiki with an administrator account shows me that formerly non existing users are created and also their real names are brought into dokuwiki's users, so this seems to work.

But after authenticating with simplesaml and working in my dokuwiki as "logged in" user, as soon as I click on any link in the sidebar (changing to another namespace in dokuwiki) or try the "update profile" link next to the username, the username disappears in the top right corner. Also if I configured the users through dokuwiki's ACL to be able to edit pages I never see a pen symbol next to an article.

Any ideas on that?
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2019-05-25, 20:17:48 (UTC +02:00)