Not logged in. · Lost password · Register
Forum: General Help and Support Plugins RSS
Upgrade plugin
fails with 'cannot connect to github'
Avatar
hj #1
Member since Apr 2008 · 167 posts · Location: Lancaster, UK
Group memberships: Members
Show profile · Link to this post
Subject: Upgrade plugin
I've got a whacking great orange bar on my wiki saying I need to make a 'hotfix' update....from  2018-04-22a "Greebo" to all of  2018-04-22b "Greebo"  :rolleyes:

Unfortunately the Upgrade plugin doesn't seem able to handle this - it's reporting:

Downloading archive from https://github.com/splitbrain/dokuwiki/archive/stable.tar.….
! Could not connect to ssl://github.com:443 (0)
! Download failed.


I'll just have to turn off notifications to get rid of the orange warning bar, I guess.   PS. how about a config option to make warning notifications only visible to admins?
Avatar
turnermm (Moderator) #2
Member since Oct 2009 · 4607 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
Those notice are normally visible only to administrators.  As for the upgrade issue, your php has to be configured to use ssl.  On Windows machines this seems to be done by uncommenting the openssl extension.  On linux machines, with current versions of php, this should be possible by installing openssl and restarting your server.
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
Avatar
hj #3
Member since Apr 2008 · 167 posts · Location: Lancaster, UK
Group memberships: Members
Show profile · Link to this post
Thanks Myron.  You're right, the orange bar is only visible to admins - escaped my eye that I was logged in.

It's probably not an essential upgrade, anyway.  I'm actually working a site up on MAMP localhost, but obviously am internet connected or I wouldn't be getting the message!  My apache stack is running PHP 5.6.10  and phpinfo shows openssl as being enabled.
Avatar
turnermm (Moderator) #4
Member since Oct 2009 · 4607 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
Afraid I can't be of much more help.  The upgrade plugin changes frequently, so you might try to reinstall it, even if you do it manually by downloading it and then installing it manually:  https://github.com/splitbrain/dokuwiki-plugin-upgrade/arch…
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
Avatar
hj #5
Member since Apr 2008 · 167 posts · Location: Lancaster, UK
Group memberships: Members
Show profile · Link to this post
No that's fine, thanks for the suggestion anyway.  I might try a manual install, but becasue I'm on a Mac and you can't just drop and replace the files but have to use the terminal, it puts me off - I don't do terminal stuff  :scared:
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2019-04-26, 00:50:03 (UTC +02:00)