Not logged in. · Lost password · Register
Forum: General Help and Support Plugins RSS
[Solved] tplinc plugin display issue
Avatar
sandos #1
Member since Oct 2018 · 9 posts
Group memberships: Members
Show profile · Link to this post
Subject: [Solved] tplinc plugin display issue
Hi,

I'm trying to use https://www.dokuwiki.org/plugin:tplinc to include a footer on every page in every namespace.

I created a page https://servername.tld/dokuwiki/seitezwei which i want to use as the footer for the other pages.

In the config-section of the tplinc plugin I tried the following:


Pattern | Page | Location
:** | seitezwei | Footer below the page content

The documentation says: For namespaces including subnamespaces use namespace:**
But the footer is only shown on pages in the same namespace. As soon as i change the namespace, the footer isn't displayed at all.

Do you have an idea? What am I doing wrong?

Thx in advance
Sandos
This post was edited on 2019-04-03, 23:02 by sandos.
Avatar
Sand #2
Member since Mar 2019 · 2 posts · Location: France
Group memberships: Members
Show profile · Link to this post
Hello,

Did you try without colon :

Pattern | Page | Location
** | seitezwei | Footer below the page content

Best regards,
Sand
Avatar
sandos #3
Member since Oct 2018 · 9 posts
Group memberships: Members
Show profile · Link to this post
Hi Sand,

thx for the advice, but it is still not working. Even on a fresh install with just sprintdoc as a template and tplinc aktivated i still have the same "problem".

Any advice on what to check, or how to check?

Sandos
Avatar
sandos #4
Member since Oct 2018 · 9 posts
Group memberships: Members
Show profile · Link to this post
Just checked again and tried a bit, and it seems, taht is has something to do with the https://www.dokuwiki.org/config:userewrite setting. If i set it to "none" everything works as expected, but if i switch to either ".htaccess" or "DokuWiki internal" it won't work anymore. I think i set up my .htacess correct, or do I miss something?



## You should disable Indexes and MultiViews either here or in the
## global config. Symlinks maybe needed for URL rewriting.
#Options -Indexes -MultiViews +FollowSymLinks

## make sure nobody gets the htaccess, README, COPYING or VERSION files
<Files ~ "^([\._]ht|README$|VERSION$|COPYING$)">
    <IfModule mod_authz_host>
        Require all denied
    </IfModule>
    <IfModule !mod_authz_host>
        Order allow,deny
        Deny from all
    </IfModule>
</Files>

## Don't allow access to git directories
<IfModule alias_module>
    RedirectMatch 404 /\.git
</IfModule>

## Uncomment these rules if you want to have nice URLs using
## $conf['userewrite'] = 1 - not needed for rewrite mode 2
RewriteEngine on

RewriteRule ^_media/(.*)              lib/exe/fetch.php?media=$1  [QSA,L]
RewriteRule ^_detail/(.*)             lib/exe/detail.php?media=$1  [QSA,L]
RewriteRule ^_export/([^/]+)/(.*)     doku.php?do=export_$1&id=$2  [QSA,L]
RewriteRule ^$                        doku.php  [L]
RewriteCond %{REQUEST_FILENAME}       !-f
RewriteCond %{REQUEST_FILENAME}       !-d
RewriteRule (.*)                      doku.php?id=$1  [QSA,L]
RewriteRule ^index.php$               doku.php

## Not all installations will require the following line.  If you do,
## change "/dokuwiki" to the path to your dokuwiki directory relative
## to your document root.
RewriteBase /dokuwiki_testing
#
## If you enable DokuWikis XML-RPC interface, you should consider to
## restrict access to it over HTTPS only! Uncomment the following two
## rules if your server setup allows HTTPS.
#RewriteCond %{HTTPS} !=on
#RewriteRule ^lib/exe/xmlrpc.php$      https://%{SERVER_NAME}%{REQUEST_URI} [L,R=301]
Avatar
sandos #5
Member since Oct 2018 · 9 posts
Group memberships: Members
Show profile · Link to this post
ok, my last assumption was wrong. Even when setting the "userewrite" option to none, the page isn't shown. I misinterpreted it because of some colon-slash-confusion on my end :-/

I really don't know where to look any further. I just installed a freshly bitnami dokuwiki stack locally with default dokuwiki-theme and just tplinc-plugin installed (besides the bundled plugins) even there I am not able to configure the tplinc-plugin to show a specific page on _every_ page in the whole wiki. It always just works for target-pages located in the root-directory of the wiki.

I know it must work somehow because i saw it on the sprintdoc-demo page. So every hint would be appreciated.

Thx in advance

Sandos
Avatar
schplurtz (Moderator) #6
Member since Nov 2009 · 470 posts · Location: France, Finistère
Group memberships: Global Moderators, Members
Show profile · Link to this post
Patterns /.*/, ** or :** work equally well.

Pattern | Page | Location
:** | seitezwei | Footer below the page content
...
 As soon as i change the namespace, the footer isn't displayed at all.
As per the doc, unqualifed pagename are relative to the current namespace. The page is not shown when you change namespace because there is no seitezwei page in the namespace you enter. You should use an aboslute pagename ie :seitezwei or :whatever:seitezwei.

see how it's done on the sample config:
[Image: https://www.dokuwiki.org/_media/plugin:tplinc.png]
Avatar
sandos #7
Member since Oct 2018 · 9 posts
Group memberships: Members
Show profile · Link to this post
Oh my god. I'm so sorry for my inability to read documentation properly :-/
Now everything works like a charm.

Thank you very much

Sandos
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2019-09-23, 15:39:54 (UTC +02:00)