Not logged in. · Lost password · Register
Forum: General Help and Support Installation and Configuration RSS
Active Directory Authentication Failed
Avatar
MisterB #1
Member since Apr 2019 · 2 posts
Group memberships: Members
Show profile · Link to this post
Subject: Active Directory Authentication Failed
Hi everybody,

I am currently migrating my dokuwiki to a new server.

Old configuration:
Windows 2008 Server R2
PHP 5.5.5
IIS 7.5

New Configuration:
Windows 2012 Server R2
PHP 7.2.17
IIS 8.5

I have copied all my configuration files via Robocopy and configure IIS but I have an authentication problem.

Indeed, my new configuration does not retrieve all the AD groups to which the user belongs, which prevents the wiki doesnt'work.

Is it a compatibility problem ?

Thank you for your support.

Regards

Steve
Avatar
Exzellius #2
Member since Jan 2019 · 26 posts · Location: Bamberg
Group memberships: Members
Show profile · Link to this post
Hi,

maybe you need to install a additional Php-Plugin for communication with AD?
I am running dokuwiki on linux and needed to install php7-ldap to get ad-authentication working.

Greetings Dominik
Avatar
MisterB #3
Member since Apr 2019 · 2 posts
Group memberships: Members
Show profile · Link to this post
Thanks Dominik.

I have checked and the plugin is actually use.

Regards
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2019-11-17, 12:26:41 (UTC +01:00)