Not logged in. · Lost password · Register
Forum: General Help and Support Plugins RSS
[solved] Problem sending notifications with watchcycle-plugin
Avatar
sandos #1
Member since Oct 2018 · 8 posts
Group memberships: Members
Show profile · Link to this post
Subject: [solved] Problem sending notifications with watchcycle-plugin
Hi there,

I've got a problem, that dokuwiki won't send notifications from the watchcycle plugin. Other Mails, like when editing a page are sent correctly. I'm using the smtp-Plugin for sending mails.

I allwas get an "There was an unexpected problem communicating with SMTP: Unexpected return code - Expected: 354, Got: 554 | 554 5.5.1 Error: no valid recipients" Error when the plugin tries to send the Notification.

The Adress of the user is correct, as other mails are sent correctly.

Perhaps someone has an idea?

thx in advance

Sandos

Here is the complete smtp-log (with sensitive data replaced):
Set: the server
Set: the auth
Set: a message will be sent
Connecting to smtp.mailbox.org at 587
Got: 220 smtp2.foobar.org ESMTP Postfix
Sent: EHLO [127.0.0.1]
Got: 250-smtp2.foobar.org
Got: 250-PIPELINING
Got: 250-SIZE 143699726
Got: 250-ETRN
Got: 250-STARTTLS
Got: 250-ENHANCEDSTATUSCODES
Got: 250-8BITMIME
Got: 250 DSN
Sent: STARTTLS
Got: 220 2.0.0 Ready to start TLS
Sent: EHLO [127.0.0.1]
Got: 250-smtp2.foobar.org
Got: 250-PIPELINING
Got: 250-SIZE 143699726
Got: 250-ETRN
Got: 250-AUTH PLAIN LOGIN
Got: 250-AUTH=PLAIN LOGIN
Got: 250-ENHANCEDSTATUSCODES
Got: 250-8BITMIME
Got: 250 DSN
Sent: AUTH LOGIN
Got: 334 VXNlcm5hbWU6
Sent: c2FuZG9zQG1haWxib3gub3Jn
Got: 334 UGFzc3dvcmQ6
Sent: TTByZDByMTg3
Got: 235 2.7.0 Authentication successful
Sent: MAIL FROM:<sender@foobar.org>
Got: 250 2.1.0 Ok
Sent: DATA
Got: 554 5.5.1 Error: no valid recipients
This post was edited on 2019-06-06, 15:56 by sandos.
Avatar
cziehr #2
Member since Jan 2011 · 579 posts · Location: 10119 Berlin
Group memberships: Members
Show profile · Link to this post
The Plugin was upgraded on 2019-05-15, and something with the mail notification was changed.

I've tried the latest version mentioned above a few days ago, and mail notifications worked well for me. Do you have the latest version installed?
Avatar
sandos #3
Member since Oct 2018 · 8 posts
Group memberships: Members
Show profile · Link to this post
Thanks for your reply. Just checked, and i have the latest version installed. :-/
Avatar
sandos #4
Member since Oct 2018 · 8 posts
Group memberships: Members
Show profile · Link to this post
Problem solved with lates update of the watchcycle-plugin (version 2019-06-04). After installing this update the problem disappeared. Also there was some fixing concerning dertermining correct maintainer-email-adress. (https://github.com/cosmocode/dokuwiki-plugin-watchcycle/co…)

Thx for the update.

Sandos
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2019-06-24, 21:50:18 (UTC +02:00)