Not logged in. · Lost password · Register
Forum: Non-English Discussion German discussion RSS
A PCRE internal error occured. This might be caused by a faulty plugin
Avatar
haiflosse #1
Member since Dec 2015 · 17 posts
Group memberships: Members
Show profile · Link to this post
Subject: A PCRE internal error occured. This might be caused by a faulty plugin
Hallo!
Ich wollte heute eine Änderung einer Seite durchführen. Nachdem ich die Seite gespeichert habe bekomme ich oben in rotem Hintergrund folgende Meldung:
A PCRE internal error occured. This might be caused by a faulty plugin

Meine Seite erkennt nun keine dokuwiki Zeichen und der Text wird in einem Fließtext angezeigt.

Hoffe es kann mir jemand weiterhelfen.
Vielen Dank
Avatar
cziehr #2
Member since Jan 2011 · 599 posts · Location: 10119 Berlin
Group memberships: Members
Show profile · Link to this post
Hallo Haiflosse!

Hast Du kürzlich ein Plugin aktualisiert?

Die Fehlermeldung lässt ja darauf schließen dass es ein Plugin-Problem ist. Falls Du noch in den Admin-Bereich kommst, deaktiviere mal ein Plugin nach dem anderen und schalte es danach jeweils wieder an, um zu sehen welches Plugin die Ursache ist. Falls Du nicht mehr in den Admin-Bereich kommst, kannst Du die Plugins auch mittels der plugins.local.php abschalten.

Evtl. ist auch ein Blick in die Server-Logdateien aussagekräftig um welches Plugin es sich handelt.

Viele Grüße,
Christoph
Avatar
haiflosse #3
Member since Dec 2015 · 17 posts
Group memberships: Members
Show profile · Link to this post
Danke für die Antwort.
Ich habe kein Plugin Update durchgeführt.
Ich komme noch in den Adminbereich.
Ich habe alle Pllugins deaktiviert und es kommt noch immer die Meldung und das Problem, dass mein Text als Fließtext angezeigt wird.
Ich habe dann ein Update von color syntax plugin durchgeführt.
This post was edited on 2019-06-24, 00:29 by haiflosse.
Avatar
Michaelsy #4
Member since Jun 2015 · 969 posts · Location: Düsseldorf, Germany
Group memberships: Members
Show profile · Link to this post
Bezieht sich das Problem nur auf diese eine Seite bzw. auf diesen speziellen Content?

PCRE steht ja für "Perl Compatible Regular Expressions", über die sehr umfangreich Such- und Interpretationsvorgänge durchgeführt werden. Der Fehler könnte also auch von einer speziellen Wikicode-Eingabe ausgelöst werden. Das könnte man dann durch Trial&Error näher eingrenzen. Denkbar wäre vielleicht auch, dass sich irgendwelche nicht sichtbaren Steuerzeichen in den Wikicode eingeschlichen haben.

HTH - Michael Sy.
By Patreon.com a few eurons can be fed into the code phasers of
the DokuWiki engine. Besides, Andi's posts are worth reading.
Avatar
haiflosse #5
Member since Dec 2015 · 17 posts
Group memberships: Members
Show profile · Link to this post
Danke für die Antwort.
Ich habe alle Seiten gelöscht und auch eine neue Installation durchgeführt.
Es bleibt bei dem Fließtext.
Avatar
Michaelsy #6
Member since Jun 2015 · 969 posts · Location: Düsseldorf, Germany
Group memberships: Members
Show profile · Link to this post
Ich mutmaße aus deinen Worten heraus, dass grundsätzlich alle Seiten davon betroffen sind (an denen du irgendwelche Änderungen vornimmst)?

Zur weiteren Fehlereingrenzung würde ich dann eine zusätzliche, ganz jungfräuliche DokuWiki-Installation auf demselben Server durchführen. Möglicherweise liegt das Problem am Server.


Edit: Vielleicht gibt dir auch ein http://.../doku.php?do=check irgendwelche Hinweise.


Noch ein Edit: Ich war in meiner Antwort davon ausgegangen, dass du keine ganz neue Installation gemacht hast, sondern versucht hast, die alte durch ein Drüberkopieren zu reparieren.
By Patreon.com a few eurons can be fed into the code phasers of
the DokuWiki engine. Besides, Andi's posts are worth reading.
This post was edited 4 times, last on 2019-06-24, 17:55 by Michaelsy.
Avatar
turnermm (Moderator) #7
Member since Oct 2009 · 4696 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
In reply to post #5
If you've done a new install, and you have no pages of your own, then I suspect there is a confliclt between something in the DokuWiki core and your server's version of PHP.  Do you know what version of PHP your server is running?  Also, you haven't said whether you've been able to check your server's log files, because the error is almost certain to be written to the log.


Ich habe vergessen, welche Sprache wir hier verwenden. Vielleicht es gibt ein Konflikt zwischen das PHP auf dem Server und  DokuWiki.  Überprüfe die Server-Logdateien, wie @cziehr hat gesagt
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
This post was edited on 2019-06-24, 17:56 by turnermm.
Avatar
haiflosse #8
Member since Dec 2015 · 17 posts
Group memberships: Members
Show profile · Link to this post
Hallo!
Ich habe jetzt neu installiert.
Jetzt funktioniert wieder alles, muss nur leider alle Dateien neu hochladen.
lg
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2019-09-17, 09:20:34 (UTC +02:00)