Not logged in. · Lost password · Register
Forum: General Help and Support Installation and Configuration RSS
AD authenticated Users cannot create pages
Avatar
pdossett #1
Member since Apr 2019 · 2 posts
Group memberships: Members
Show profile · Link to this post
Subject: AD authenticated Users cannot create pages
Hi all,
I run a wiki at my organisation and we recently implemented AD authentication. When i tried to do this with just the ADAuth plugin I couldn't get it to work but eventually got it working by implementing the Chained Authentication Plugin. I have some unexpected behaviour though. One issue is that my users cannot create new pages.
Let me briefly explain my setup. I use ACLs and my users are in an AD group called itwiki. This group has 'Delete' permissions in the ACL.
When they try to create a page (normally by searching for the namespace/page which doesn't exist and then clicking on the 'If you didn't find what you were looking for, you can create or edit the page' link) there is no such link to create the new page.
I do however get the link to create a new page when I log in with an account from the group specified in the superuser group of the authentication configuration.
Can anyone push my troubleshooting in the right direction?
Avatar
pdossett #2
Member since Apr 2019 · 2 posts
Group memberships: Members
Show profile · Link to this post
Resolved: Creating a page from a search seems to happen outside of the namespace where you are trying to create the page. Giving these users create options at the root means they now get the create page option when doing a search
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2019-12-07, 14:39:48 (UTC +01:00)