Not logged in. · Lost password · Register
Forum: General Help and Support Templates and Layout RSS
bootstrap 3:  userstyle.css
Avatar
Wolfgang Henderkes #1
Member since Dec 2015 · 9 posts
Group memberships: Members
Show profile · Link to this post
Subject: bootstrap 3:  userstyle.css
Hi,

I have updated bootstrap 3 to last version 2019-05-22 and now the conf/userstyle.css has no effect anymore.

Wolfgang
Wolfgang Henderkes
etok.de
Avatar
turnermm (Moderator) #2
Member since Oct 2009 · 4702 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
Try refreshing your browser cache and, if necessary, deleting the cache directories in data/cache.
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
Avatar
Wolfgang Henderkes #3
Member since Dec 2015 · 9 posts
Group memberships: Members
Show profile · Link to this post
It is the same problem in all browsers on all devices.
Wolfgang Henderkes
etok.de
Avatar
turnermm (Moderator) #4
Member since Oct 2009 · 4702 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
If the userstyle.css settings apply to the template, it's possible that the update has changed the css.
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
Avatar
Wolfgang Henderkes #5
Member since Dec 2015 · 9 posts
Group memberships: Members
Show profile · Link to this post
According to my understanding the userstyle.css is not assigned to a template, but is used automatically by its existence.

Independently of this, the file exists with correct content and is also displayed by other templates.
Wolfgang Henderkes
etok.de
Avatar
turnermm (Moderator) #6
Member since Oct 2009 · 4702 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
My point was if the settings in userstyle.css apply specifically to bootstrap3.
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
Avatar
Wolfgang Henderkes #7
Member since Dec 2015 · 9 posts
Group memberships: Members
Show profile · Link to this post
usersyle.css was used before updating bootstrap 3. Since the update the problem occurs.
Wolfgang Henderkes
etok.de
Avatar
turnermm (Moderator) #8
Member since Oct 2009 · 4702 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
\my point is this:  if your own styles apply to the bootstrap template and if the update to the template has changes that affect your styles, then maybe that is the problem. 

Could you attach your userstyle.css?
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
Avatar
Wolfgang Henderkes #9
Member since Dec 2015 · 9 posts
Group memberships: Members
Show profile · Link to this post
Here it is:
/* Version 3.0 */   
/* 28.6.18 */   
   
   
/* General style guide */   
body   
    {
    font-size: 1.2em;
    margin: 0.0em;
    line-height: 1.6em;
    }
   
   
p:first-letter   
    {
    font-size: 1.0em;
    }
   
   
/* Listing */   
div.dokuwiki li   
    {
    font-size: 1em;
    line-height: 1.4em;
    text-indent: 0em;
    margin-bottom: 0.5em;
    }

   
/* Code */   
code   
    {
    font-size: 1.0em;
    color: #008080;
    }   

   
/* Tables */   
div.dokuwiki table
    {
    margin-top: 2.0em;
    margin-bottom: 0.0em;
    }
   
div.dokuwiki td, td p   
    {
    font-size: 1.0em;
    margin-top: 0.0em;
    color: #000000;
    line-height: 100%;
    text-indent: 0em;
    }
   
div.dokuwiki td p:first-letter   
    {
    font-size: 1.0em;
    }
   
div.dokuwiki thead, thead p   
    {
    font-size: 1.0em;
    font-weight: bold;
    margin-top: 0.0em;
    color: #808080;
    text-align: left;
    line-height: 80%;
    text-indent: 0.0em;
    }
   
div.dokuwiki thead p:first-letter   
    {
    font-size: 1.0em;
    }
   
   
   
/* Headers */   
div.dokuwiki H1   
    {
    font-size: 1.0em;
    margin: 0;
    }
   
div.dokuwiki H2   
    {
    font-size: 1.0em;
    margin: 0;
    text-align: right;
    }
   
div.dokuwiki H3   
    {
    font-size: 1.8em;
    margin: 1.0em;
    color: #b7274c;
    text-align: center;
    }
   
div.dokuwiki H4   
    {
    font-size: 1.5em;
    margin-top: 1.5em;
    text-align: left;
    color: #808080;
    }

div.dokuwiki H5
    {
    font-size: 1.2em;
    margin-top: 0.5em;
    margin-bottom: 2.5em;
    text-align: left;
    color: #000000;
    }

   
/* HyperLInks */   
div.dokuwiki A   
    {
    color: #29a6e5;
    text-decoration: none;
    }
   
div.dokuwiki A:visited   
    {
    color: #66669C;
    text-decoration: none;
    }
   
div.dokuwiki A:active   
    {
    color: #FB0000;
    text-decoration: none;
    }
   
div.dokuwiki A:hover   
    {
    color: #BD4542;
    text-decoration: underline;
    }

div.dokuwiki div.left_sidebar {
  background: url('lib/tpl/arctic/images/logo.png') no-repeat;
  padding-top: 64px;
}
Wolfgang Henderkes
etok.de
Avatar
turnermm (Moderator) #10
Member since Oct 2009 · 4702 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
It did make changes but not what was expected.  But it did have an effect.

Did you clear out data/cache?  I had to clear out data/cache to get back to where the template was before inserting your code.
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
Avatar
Wolfgang Henderkes #11
Member since Dec 2015 · 9 posts
Group memberships: Members
Show profile · Link to this post
It cannot be a problem of the cache. It is the same problem in all browsers on all devices.

1. Independant from that, I have deactivated the userstyle.css and changed the template: the effects of userstyle.css disappeared. 

2. I have activated the userstyle.css and the effects are displayed. 

3. I changed the template back to bootstrap 3 and the effects of userstyle.css disappeared again.
Wolfgang Henderkes
etok.de
Avatar
turnermm (Moderator) #12
Member since Oct 2009 · 4702 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
I updated to the current bootstrap and did some tests.  I added two rules to the end of your userstyle.css file:
h1 { font-style: italic !important; }
h2 { color: #FFA500 !important; }
The result is here. 
[Image: https://i.imgur.com/eNluWLf.png]
In other words, it accepted my two rules but rejected yours.

When applying the same css to the dokuwiki template, I get the following:
[Image: https://i.imgur.com/oq7l8Vv.png]
Here it is a combination of your css with my additions.  But there is something skewed here, because the header 3 is shifted to the right, and I don't think that is what you intended.  So I suspect there is something in your css which is not correct and/or conflicts with the bootstrap css.
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
This post was edited on 2019-07-15, 19:55 by turnermm.
Avatar
ach (Administrator) #13
Member since May 2006 · 1932 posts · Location: Folkestone, UK
Group memberships: Administrators, Members, Super Mods, Wiki Managers
Show profile · Link to this post
In reply to post #11
Quote by Wolfgang Henderkes:
It cannot be a problem of the cache. It is the same problem in all browsers on all devices.

There are different types of cache. turnermm was talking about DokuWiki's cache in your server's data/cache directory. The CSS gets rebuilt if you save your config settings. More about DokuWiki's caching.
Avatar
lotar #14
Member since Apr 2015 · 9 posts · Location: Rome, Italy
Group memberships: Members
Show profile · Link to this post
Hi,
this is not a DokuWiki cache problem.

In last release have accidentally removed the "div.dokuwiki" selector, used in some plugins and thirth-party css files (aka userstyle.css).

Have created a patch for master branch for solve this issue.
Please reinstall the template again.

Sorry,
Joseph
Avatar
Wolfgang Henderkes #15
Member since Dec 2015 · 9 posts
Group memberships: Members
Show profile · Link to this post
Solved. Thank you.

Wolfgang
Wolfgang Henderkes
etok.de
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2019-09-23, 16:10:55 (UTC +02:00)