Not logged in. · Lost password · Register
Forum: General Help and Support Installation and Configuration RSS
[Solved] Locked myself out by enabling Oauth plugin
I forgot to enable logging in by google on the admin account before I changed auth methods.
Avatar
eligaultney #1
Member for a month · 2 posts
Group memberships: Members
Show profile · Link to this post
Subject: [Solved] Locked myself out by enabling Oauth plugin
After a bit of fumbling I finally enabled the oauth plugin. My organization (who I'm setting up the wiki for) uses GSuite and we wanted to make it the only way to log in. I got it working, and now new users are able to quickly sign in uses oauth and their work google account. Unfortunately, my work email account was tied to the admin account from before I used the oauth plugin.

I made the mistake of not enabling google login for my own account before I swapped over to oauth. Now, when I try to login using oauth I get to the google account selection page, select my account, and am redirected back to our homepage with the following error message at the top of the page:

The account associated with your email address has not enabled logging in with Google. Please login by other means and enable it in your profile.

Unfortunately the only login option now is with Google. The correct email is associated with the admin account--I just need to be able to log in once to tick that box! Any help is greatly appreciated! Also, I apologize if this is the wrong place to post. I'll happily take any redirection suggestions.
This post was edited on 2019-10-17, 11:28 by eligaultney.
Avatar
schplurtz (Moderator) #2
Member since Nov 2009 · 493 posts · Location: France, Finistère
Group memberships: Global Moderators, Members
Show profile · Link to this post
I don't know oauth (yet). Perhaps, you could revert to the standard user/password auth, tick that box and go back to oauth ?
find the file conf/local.php. edit this file and remove the line that reads
$conf['authtype']= something
.
This will revert to the standard DW user/password authentication method.

Another solution could be to use a working account as superuser, modify your account and set your account back as the admin account. See https://www.dokuwiki.org/faq:forgotten_password
Avatar
eligaultney #3
Member for a month · 2 posts
Group memberships: Members
Show profile · Link to this post
You're the best!

That totally worked. For anyone else who searches for the error message and has done a similar thing I followed schplurtz's advice to remove (or in my cautious case, comment out) the
$conf['authtype']= oauth
line and I was able to log back in with my usual credentials. I then changed Oauth's configuration panel (in the configuration page section of the admin panel) to "Allow All Services". At this point I was able to go to my account profile and tick the box for allowing login with google. Now I can go back and change the Oauth setting back to login with only the single service (Google, in my case) and I'm good to go.
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2019-11-12, 05:56:32 (UTC +01:00)